incubator-cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nguyễn Đình Việt <Viet...@viettel.com.vn>
Subject RE: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????
Date Sat, 08 Sep 2012 04:28:03 GMT
Hi,
I run 2 VM on 2 different hosts (VM XP run on host 1, VM hyperv run on host 2, and VR running
on host 2, VR's ip address is 10.1.1.1. All host running on the same VLAN), only VM hyperv
obtained IP address from VR.  This is result in /var/log/message on VR:

Sep  8 04:12:13 r-468-VM cloud: edithosts: update 02:00:27:b0:00:35 10.1.1.90 XP to hosts
Sep  8 04:12:13 r-468-VM cloud: /root/edithosts.sh: setting default router for 10.1.1.90 to
10.1.1.1
Sep  8 04:12:13 r-468-VM cloud: /root/edithosts.sh: setting dns server for 10.1.1.90 to 10.1.1.1
Sep  8 04:12:44 r-468-VM cloud: edithosts: update 02:00:04:d3:00:3a 10.1.1.107 hyperv to hosts
Sep  8 04:12:44 r-468-VM cloud: /root/edithosts.sh: setting default router for 10.1.1.107
to 10.1.1.1
Sep  8 04:12:44 r-468-VM cloud: /root/edithosts.sh: setting dns server for 10.1.1.107 to 10.1.1.1

When I use renew ip address command on VM XP (run on host 1, other with VR)  and tcpdump command
on VR then I don't receive any DHCP packet from VM XP.
Can u help me ?


Thanks & Best Regards.

------------------------------------
Nguyen Dinh Viet
Specialist – Security Dept
Cloud Computing Research Center
Viettel Research and Development Institute
No. 380 Lac Long Quan Str, Tay Ho Dist, Hanoi, Vietnam
Phone: (84.4) 62 731 708   Fax: (84.4) 62 838 838   
Mobile: (84) 976766287
Website: http://viettelrd.com.vn 


-----Original Message-----
From: Prasanna Santhanam [mailto:prasanna.santhanam@citrix.com] 
Sent: Friday, September 07, 2012 6:04 PM
To: CloudStack Users
Subject: Re: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????

On Fri, Sep 07, 2012 at 06:42:27AM -0400, Nguyễn Đình Việt wrote:
> Hi,
> 
> I deployed Cloudstack with 1 Management Server (CentOS 6.03) and 3
> host on XCP 1.1. I created VMs instance run fine. But I have a
> problem. When VMs instance run on other with VR ( Examp: VR run on
> host 1, VM run on node 2) then VMs can not aquire IP address via
> DHCP. If I migrate it to the same host with VR, it’s OK. I use
> advance networking and Network Offering is default (Offering for
> Isolated networks with Source Nat service enabled).
> 

Can you jump in to the VR from the XCP host?
 - ssh -i .ssh/id_rsa.cloud -p 3922 <vr-link-local-ip-on-ui>

Then check if you see dhcp requests when you spin a VM on the
host that does not have your VR. /var/log/messages should show them. 

If no - this issue sounds like something wrong with your VLAN
configuration. If there are no VLANs configured on your switch check
if all packets are broadcast all over or if they are getting ignored.

> 		
> 
> Can u help me to resolve this problem
> 
> Ps: Can u send me detail document about cloudstack networking ? I
> search on internet but most of them doesn’t descipt detail about
> network problem.
> 
>  

-- 
Prasanna.,

Mime
View raw message