incubator-cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Rozanec <jroza...@tendrilinc.com>
Subject Unable to deploy VM with "unable to allocate vnet as a part of network" log message
Date Mon, 14 May 2012 19:03:24 GMT
Hello,

We were able to setup cloudstack, but when attempting to create VMs, we get
an alert with the following message: "Unable to create a deployment for VM"

Looking at the logs (http://pastebin.com/mbQ6zCJT), we see the "unable to
allocate vnet as a part of network" log message.
>From here<http://git.cloud.com/cgit/cloudstack-oss/commit/?id=d2adbcfc0aeb14f2efd82713519b500871e58b23>we
see that the exception is thrown if a null is returned when attempting
to allocate a vnet. Looking at cloudstack sources we saw it invokes
getVlan() method on a DataCenterVnetVO instance at DataCenterDaoImpl, which
should return a value from the op_dc_vnet_alloc table. Our table is empty
(mysql> select * from op_dc_vnet_alloc;Empty set (0.00 sec))

Our setup is an advanced configuration. The only network offering we can
take is "Offering for Isolated networks with Source Nat service enabled".
We created an "isolated" guest network without a VLAN id.

Any ideas/workarounds? When does cloudstack put some data into
op_dc_vnet_alloc?

Thanks in advance.

Jose.

 
This email and any files transmitted with it are confidential and intended solely for the
use of the individual or entity to whom they are addressed.
If you have received this email in error please notify the sender.
Please note that any views or opinions presented in this email are solely those of the author
and do not necessarily represent those of the company.
Finally, the recipient should check this email and any attachments for the presence of viruses.
The company accepts no liability for any damage caused by any virus transmitted by this email.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message