incubator-cloudstack-users-cn mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From allen xiang <allen6876...@gmail.com>
Subject Re: 关于CloudStack配置VMware的若干问题
Date Wed, 16 Jan 2013 12:29:14 GMT
*@  ChunFeng:  Thanks!*

我是一步步按照
http://note.youdao.com/share/?id=81d978774b880063c350b75d90e73e25&type=note
,其中配置ip步骤是:

>    Pod name:
>    Reserved system gateway: 10.128.74.1
>    Reserved system netmask: 255.255.255.0
>    Start Reserved system IP:  10.128.74.160
>    End Reserved system IP:   10.128.74.170
>
>    配置Guest Traffic
>    Guest Gateway:    10.128.68.1
>    Guest Netmask:    255.255.255.0
>    Guest Start IP:      10.128.68.160
>    Guest End IP:        10.128.68.170
这样配置下来,
现在的结果是,vCenter里面能看到 s-1-VM
和 v-2-VM,过一段时间后,两VM开始running,通过vCenter的Console进去check,状态也正常。
不过后来,好像 s-1-VM 不知不觉的power-off了。
相应的mangement-server.log文件黏贴在附件中。
 management-server.log<https://docs.google.com/file/d/0B-FO_fSgCThbQm1uVFV1NS1kaGc/edit>
从log上看来,由于在不同网段,可能要设置什么route之类的,但不知怎么去设置?
按道理来说,两段ip域是可以在不同网段的吧?


2013/1/16 Tian ChunFeng <tianyunqushi@gmail.com>

> system vm password:  6m1ll10n
>
> 可以把日志贴出来看看。
>
>
> 2013/1/16 allen xiang <allen6876xwh@gmail.com>
>
> > Hi, 各位!
> >
> > 本人在装好CloudStack,并安装好VMware的system vm template,
> > (注:先后安装过 acton-systemvm-02062012.ova 或 burbank-systemvm-08012012.ova),
> > 再配置 VMware 的一套东东,出现了一些问题,这里恳请大侠帮忙看一下...
> >
> > 先说一下系统的具体情况:
> > Management Server: CloudStack版本为4.0.0,运行在VM上,OS是CentOS 6.3
> > x64,ip地址是*10.128.
> > 74.149*,子网掩码255.255.255.0
> > vCenter: 版本为5.1,运行在VM上,OS是Windows 2008 Server,ip地址是*10.128.74.95*
> > ,子网掩码255.255.255.0
> > ESXi Hypervisor: 版本为5.1,运行在一台富士通的Server上,ip地址是*10.128.68.51*
> > ,子网掩码255.255.255.0
> > 注:由与Mangement Server及vCenter都以VM的形式运行在公司的另一台ESXi
> Server上,其网段为*10.128.74.**,
> >       而CloudStack要连上的VMware
> > Hypervisor的网段为*10.128.68.**,两者在不同网段,不过在Mangement
> > Server上是可以ping通该Hypervisor的。
> >
> > 本人在实践过程中,
> > 之前是添加Cluster失败,
> > 后来,Zone算是添加成功了,但是发现两个System VM的状态老是Starting,
> > 去vSphere Client里面看了一下,有时候能却能看到两个VM的状态都是running...
> > 从CloudStack的mangement-server.log看出,貌似是网络问题,CloudStack连不上system
VM...
> >
> > 本人这里有几个问题:
> > *1. 对于本人的环境,在添加Basic
> > Zone时,相关的IP配置该怎么去配?不清楚哪里是配74的网段,哪里是配68的网段以及相应的Gateway.*
> >    配置Pod时:
> >    Pod name:
> >    Reserved system gateway:
> >    Reserved system netmask:
> >    Start Reserved system IP:
> >    End Reserved system IP:
> >
> >    配置Guest Traffic
> >    Guest Gateway:
> >    Guest Netmask:
> >    Guest Start IP:
> >    Guest End IP:
> >
> > *2. Sytem VM 里面的两个VM是干嘛用的?没有它们,CloudStack是不是就工作不了了?*
> >     本人在vSphere Client里面登录这两个VM,发现它们都是Debian
> > Linux,是command界面,以root账户登录进去,尝试了几个密码(password/cloudstack等),
> >     发现都不对,*不知密码是多少?*
> >     与这个相关的,系统VM模板 acton-systemvm-02062012.ova 或
> > burbank-systemvm-08012012.ova 我是从官方文档中的链接下的,
> >     这些ova不知是不是CloudStack的Developer专门制作的,加入了CloudStack的一些东西?
> >     还是,自己可以制作一个ova也可以用作system vm template?我试过,在VMware
> > WorkStation下面是可以export一个ova模板的。
> >
> >
> > 以上这些问题,貌似官方文档中我看了也没有相关的解释,还是我没找对文件...
> >
> > 之前看到坛子里的人有配vmware成功过的...
> >
> > 写的有点长,不知道有没有神人指点下:-)
> >
>
>
>
> --
> Tian ChunFeng
> http://cloud.domolo.com
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message