incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prachi Damle <Prachi.Da...@citrix.com>
Subject RE: HypervisorVmPlannerSelector Run Level - can we increase?
Date Mon, 18 Mar 2013 18:00:48 GMT
Thanks for the observation Joe. I will make the change to AdapterBase - seems like we need
to run all adapters at level 5.

Thanks,
Prachi

-----Original Message-----
From: Kelven Yang 
Sent: Monday, March 18, 2013 10:52 AM
To: cloudstack-dev@incubator.apache.org; Prachi Damle
Subject: Re: HypervisorVmPlannerSelector Run Level - can we increase?

Joe,

Regular plugin/adapter components should usually be loaded at run level RUNLEVEL_COMPONENT(5).
I think we can increase it to level 5

Kelven

On 3/18/13 2:38 AM, "Mills, Joseph" <joe@midokura.jp> wrote:

>Hi Prachi,
>
>I had a question regarding your commit for CLOUDSTACK-1604.
>
>I noticed that the HypervisorVmPlannerSelector run level is currently 0.
>This didn't appear to cause any problems until the fix for 
>CLOUDSTACK-1604, where a dependency on the 'configuration' database 
>table was introduced.
>ConfigurationServerImpl appears to be the component that saves the 
>default values to the 'configuration' table, but it's run level is 2. 
>This means that on an initial boot up (where we populate the database 
>for the first time), HypervisorVmPlannerSelector will get NULL for the 
>config value it needs, which will prevent the user from deploying VMs later on.
>
>com.cloud.utils.exception.CloudRuntimeException: cannot find 
>DeployPlannerSelector for vm[uuid:63b7bd9e-7be7-41e8-87e2-658d009e34cb,
>hypervisorType:KVM]
>
>Is this all correct? If so, can we increase the run level of 
>HypervisorVmPlannerSelector to 5?
>
>Thanks,
>Joe


Mime
View raw message