incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pradeep Soundararajan <pradeep.soundarara...@citrix.com>
Subject RE: (CLOUDSTACK-1252) Failed to download default template in VMware
Date Fri, 08 Mar 2013 11:05:14 GMT
Hugo,

It seems this defect is not reproducible right now.  Meanwhile, shall we use that workaround
as I suggested in the bug.  

Thanks,
Pradeep S


-----Original Message-----
From: Pradeep Soundararajan 
Sent: Wednesday, March 06, 2013 12:02 AM
To: cloudstack-dev@incubator.apache.org; Animesh Chaturvedi
Cc: Kelven Yang; Hugo Trippaers (HTrippaers@schubergphilis.com); Noa Resare <noa@spotify.com>
(noa@spotify.com); Wido den Hollander (wido@widodh.nl)
Subject: RE: (CLOUDSTACK-1252) Failed to download default template in VMware

The below entries are created during "mvn -P systemvm -Dnonoss install" build for the respective
master and 4.1 builds.  I am able to grep for all vmware related jars from these zip files.

ASF-master/services/console-proxy/server/dist/systemvm.zip
cloud-plugin-hypervisor-vmware-4.2.0-SNAPSHOT.jar
vmware-vim25-5.1.jar
cloud-vmware-base-4.2.0-SNAPSHOT.jar

ASF-4.1/console-proxy/dist/systemvm.zip
cloud-vmware-base-4.1.0-SNAPSHOT.jar
vmware-apputils-4.1.jar
cloud-plugin-hypervisor-vmware-4.1.0-SNAPSHOT.jar
vmware-vim25-4.1.jar
vmware-vim-4.1.jar

During packaging I am seeing the same vmware jars are not available in  systemvm.zip  which
is present under <workspace>/dist/rpmbuild/BUILDROOT/cloudstack-4.2.0-SNAPSHOT.el6.x86_64/usr/share/cloudstack-common/vms/systemvm.zip.
 

diff -b services/console-proxy/server/dist/systemvm.zip  dist/rpmbuild/BUILDROOT/cloudstack-4.2.0-SNAPSHOT.el6.x86_64/usr/share/cloudstack-common/vms/systemvm.zip
Binary files services/console-proxy/server/dist/systemvm.zip and dist/rpmbuild/BUILDROOT/cloudstack-4.2.0-SNAPSHOT.el6.x86_64/usr/share/cloudstack-common/vms/systemvm.zip
differ

I think that is the reason behind this issue.  *vmware*.jar are not getting copied to systemvm.zip
during package creation.

Thanks,
Pradeep S

-----Original Message-----
From: Chip Childers [mailto:chip.childers@sungard.com]
Sent: Saturday, March 02, 2013 6:42 PM
To: Animesh Chaturvedi
Cc: cloudstack-dev@incubator.apache.org; Kelven Yang; Hugo Trippaers (HTrippaers@schubergphilis.com)
Subject: Re: (CLOUDSTACK-1252) Failed to download default template in VMware

Hugo,

Can you take a look at this?

On Mar 1, 2013, at 11:27 PM, Animesh Chaturvedi <animesh.chaturvedi@citrix.com> wrote:

> Chip, Hugo
>
> Please see comment from Kelven regarding this issue pointing to RPM build. Can someone
familiar with RPM investigate?
>
>
> Animesh
>
> -----Original Message-----
> From: Kelven Yang (JIRA) [mailto:jira@apache.org]
> Sent: Friday, March 01, 2013 5:55 PM
> To: Animesh Chaturvedi
> Subject: [jira] [Commented] (CLOUDSTACK-1252) Failed to download 
> default template in VMware
>
>
>    [
> https://issues.apache.org/jira/browse/CLOUDSTACK-1252?page=com.atlassi
> an.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId
> =13591204#comment-13591204 ]
>
> Kelven Yang commented on CLOUDSTACK-1252:
> -----------------------------------------
>
> This is what I've done to check the problem
>
> 1) Check RPM cloud.spec and found out that target ISO installation 
> path is at /usr/share/cloudstack-share/vms and the built-in path in 
> Java is not the same as RPM spec, This leads to CLOUDSTACK-1262
> 2) Check an existing RPM setup, search for systemvm.iso using "rpm -qal | grep cloud"
>    mount -t iso9660 -o loop /usr/share/cloudstack-common/.../systemvm.iso /mnt
>    unzip -l systemvm.zip
>
> and found out that the content inside the ISO does not contain files 
> for VMware
>
> The problem seems to come from the RPM build that is for non-oss 
> packages, RPM build should issue maven command with following options
>
> mvn -P systemvm -Dnonoss ....
>
> Could someone who is familar with RPM build to take a look?
>
>
>
>
>
>
>> Failed to download default template in VMware
>> ---------------------------------------------
>>
>>                Key: CLOUDSTACK-1252
>>                URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1252
>>            Project: CloudStack
>>         Issue Type: Bug
>>     Security Level: Public(Anyone can view this level - this is the default.)
>>         Components: KVM, VMware
>>   Affects Versions: 4.1.0
>>        Environment: CentOS6.3
>> 4.1 branch build
>> Hyper visor : VMware
>>           Reporter: Rayees Namathponnan
>>           Assignee: Kelven Yang
>>           Priority: Blocker
>>            Fix For: 4.1.0
>>
>>        Attachments: cloud.rar
>>
>>
>> Step 1 : Created new build from 4.1 branch Step 2 : Install and 
>> configured MS server on CentOS 6.3 Step 3 : Prepared system template 
>> and created advanced zone Actual result System VM are created, but 
>> "default templates" are not available in template section.
>>
>> I tried to started agent from SSVM, with command ">service 
>> cloudstack-agent start" and failed,  but command ">service cloud 
>> start" works If you look at the SSVM cloud.out
>> (/var/log/cloud/clout.out) you can see class not found exception
>> java.lang.ClassNotFoundException:
>> com.cloud.storage.resource.PremiumSecondaryStorageResource
>> + java -Djavax.net.ssl.trustStore=./certs/realhostip.keystore -mx168m 
>> + -cp 
>> + ./:./conf:aopalliance-1.0.jar:apache-log4j-extras-1.1.jar:aspectjrt
>> + -
>> + 1.7.1.jar:aspectjweaver-1.7.1.jar:aws-java-sdk-1.3.21.1.jar:backpor
>> + t
>> + -util-concurrent-3.1.jar:bcprov-jdk16-1.46.jar:cglib-nodep-2.2.2.ja
>> + r
>> + :cloud-agent-4.1.0-SNAPSHOT.jar:cloud-api-4.1.0-SNAPSHOT.jar:cloud-
>> + c
>> + onsole-proxy-4.1.0-SNAPSHOT.jar:cloud-core-4.1.0-SNAPSHOT.jar:cloud
>> + -
>> + utils-4.1.0-SNAPSHOT.jar:commons-codec-1.6.jar:commons-collections-
>> + 3
>> + .2.1.jar:commons-configuration-1.8.jar:commons-dbcp-1.4.jar:commons
>> + -
>> + discovery-0.5.jar:commons-httpclient-3.1.jar:commons-lang-2.6.jar:c
>> + o
>> + mmons-logging-1.1.1.jar:commons-pool-1.6.jar:dom4j-1.6.1.jar:ehcach
>> + e
>> + -1.5.0.jar:ejb-api-3.0.jar:gson-1.7.1.jar:guava-14.0-rc1.jar:httpcl
>> + i
>> + ent-4.1.jar:httpcore-4.1.jar:jackson-core-asl-1.8.9.jar:jackson-map
>> + p
>> + er-asl-1.8.9.jar:jasypt-1.9.0.jar:java-ipv6-0.8.jar:javassist-3.12.
>> + 1
>> + .GA.jar:javax.inject-1.jar:javax.persistence-2.0.0.jar:jsch-0.1.42.
>> + j
>> + ar:jsr107cache-1.0.jar:log4j-1.2.16.jar:reflections-0.9.8.jar:sprin
>> + g
>> + -aop-3.1.2.RELEASE.jar:spring-asm-3.1.2.RELEASE.jar:spring-beans-3.
>> + 1
>> + .2.RELEASE.jar:spring-context-3.1.2.RELEASE.jar:spring-core-3.1.2.R
>> + E
>> + LEASE.jar:spring-expression-3.1.2.RELEASE.jar:spring-web-3.1.2.RELE
>> + A
>> + SE.jar:trilead-ssh2-build213-svnkit-1.3-patch.jar:xml-apis-1.0.b2.j
>> + a r com.cloud.agent.AgentShell template=domP type=secstorage
>> + host=10.223.49.197 port=8250 name=s-3-VM zone=1 pod=1 guid=s-3-VM 
>> + resource=com.cloud.storage.resource.PremiumSecondaryStorageResource
>> + instance=SecStorage sslcopy=true role=templateProcessor mtu=1500
>> + eth2ip=10.223.243.20 eth2mask=255.255.255.192 gateway=10.223.243.1
>> + public.network.device=eth2 eth0mask=0.0.0.0 eth0ip=0.0.0.0
>> + eth1ip=10.223.250.169 eth1mask=255.255.255.192
>> + mgmtcidr=10.223.49.192/26 localgw=10.223.250.129
>> + private.network.device=eth1 eth3ip=10.223.250.156
>> + eth3mask=255.255.255.192 storageip=10.223.250.156
>> + storagenetmask=255.255.255.192 storagegateway=10.223.250.129
>> + internaldns1=10.223.110.254 internaldns2=10.223.110.253
>> + dns1=72.52.126.11 dns2=72.52.126.12
>> log4j:WARN No appenders could be found for logger (org.apache.commons.httpclient.params.DefaultHttpParams).
>> log4j:WARN Please initialize the log4j system properly.
>> log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
>> Unable to start agent: Resource class not found:
>> com.cloud.storage.resource.PremiumSecondaryStorageResource due to:
>> java.lang.ClassNotFoundException:
>> com.cloud.storage.resource.PremiumSecondaryStorageResource
>> Attached cloud.out for reference
>
> --
> This message is automatically generated by JIRA.
> If you think it was sent incorrectly, please contact your JIRA 
> administrators For more information on JIRA, see:
> http://www.atlassian.com/software/jira

Mime
View raw message