incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Prasanna Santhanam" <Prasanna.Santha...@citrix.com>
Subject Re: Review Request: fix bug CLOUDSTACK-1531: vmware create volume from snapshot will missing data
Date Fri, 08 Mar 2013 11:35:53 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/9772/
-----------------------------------------------------------

(Updated March 8, 2013, 11:35 a.m.)


Review request for cloudstack, Sateesh Chodapuneedi, mice xia, and Kelven Yang.


Changes
-------

Adding the right reviewers


Description
-------

fix bug CLOUDSTACK-1531: vmware create volume from snapshot will missing data
The code works in ssvm


This addresses bug CLOUDSTACK-1531.


Diffs
-----

  plugins/hypervisors/vmware/src/com/cloud/hypervisor/vmware/manager/VmwareStorageManagerImpl.java
8650274 

Diff: https://reviews.apache.org/r/9772/diff/


Testing
-------

1. deploy a centos vm 
2. create a volume v0 and attached to the vm 
3. before formatting v0, take a snapshot s1, then format it and touch some files 
4. take another snapshot s2, and detach v0 
5. create volume v1 from s1 and then create volume v2 from s2

Success. v1 and v2 has different data. v1 doesn't contains partition and v2 has files I touched.


Thanks,

Hongtu Zang


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message