incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Federle (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-1432) Inconsistent field names in "Add Cluster" dialog
Date Wed, 27 Feb 2013 21:29:14 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-1432?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13588786#comment-13588786
] 

Brian Federle commented on CLOUDSTACK-1432:
-------------------------------------------

The reason '...name' isn't present on those other fields is because they are drop-down selections
of existing items. '...name' is only added when the user is supposed to name something. Also,
in the background these dialogs are actually passing the ID, not the name, to the API on creation.
Thus, it's more the 'object' that is being chosen here, not the name string.
                
> Inconsistent field names in "Add Cluster" dialog
> ------------------------------------------------
>
>                 Key: CLOUDSTACK-1432
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1432
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: UI
>    Affects Versions: 4.0.0, 4.0.1, 4.0.2, 4.1.0, 4.2.0
>         Environment: Running in Chrome on Mac OS X 10.8.2
>            Reporter: Mike Tutkowski
>            Assignee: Pranav Saxena
>            Priority: Minor
>             Fix For: 4.2.0
>
>
> Go into the "Add Cluster" dialog.
> Notice the field name "Cluster Name" has the word "Name" in it, but "Zone" and "Pod"
do not.
> I believe it would be nicer from a usability standpoint if we were consistent in how
we describe fields (in this case, either use "Name" in all three places or in none of those
places).
> This is probably a larger issue than just on this dialog.
> *** Later Edit ***
> On the "Add Primary Storage" dialog, we say "Cluster" (not "Cluster Name"), "Zone", and
"Pod".
> We might actually want to change "Cluster Name" to "Name" since on the "Add Primary Storage"
dialog, we use the word "Name" with implicit reference to what we're creating (we don't say
"Primary Storage Name").

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message