incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rayees Namathponnan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CLOUDSTACK-1326) KVM - Failed to start cloud agent from SSVM
Date Tue, 19 Feb 2013 18:21:12 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-1326?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rayees Namathponnan updated CLOUDSTACK-1326:
--------------------------------------------

    Summary: KVM - Failed to start cloud agent from SSVM   (was: Failed to start cloud agent
from SSVM )
    
> KVM - Failed to start cloud agent from SSVM 
> --------------------------------------------
>
>                 Key: CLOUDSTACK-1326
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1326
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Install and Setup
>    Affects Versions: 4.1.0
>         Environment: 4.1 build 
> KVM
> CentOS6.3
>            Reporter: Rayees Namathponnan
>            Assignee: Nitin Mehta
>            Priority: Blocker
>             Fix For: 4.1.0
>
>
> Step 1 : Created new build from 4.1 branch 
> Step 2 : Install and configured MS server on CentOS 6.3 
> Step 3 : Prepared system template and created advanced zone 
> Actual Result 
> System VM are up and running now, but cloud agent is not running on SSVMs and failed
to download default template 
> login into SSVM and trying to start server > service cloud start, its failed
> root@s-24-VM:~#  service cloud start
> Starting cloud.com service (type=secstorage) Failed
> /etc/init.d/cloud: line 94: /usr/local/cloud/systemvm/user_request: No such file or directory
> Please see the start section in /etc/init.d/cloud, in cannot see folder path CLOUD_COM_HOME="/usr/local/cloud"
in ssvm
> root@s-24-VM:/usr/local/cloud# cat /etc/init.d/cloud
> CLOUD_COM_HOME="/usr/local/cloud"
> # mkdir -p /var/log/vmops
> get_pids() {
>   local i
>   for i in $(ps -ef| grep java | grep -v grep | awk '{print $2}');
>   do
>     echo $(pwdx $i) | grep "$CLOUD_COM_HOME"  | awk -F: '{print $1}';
>   done
> }
> start() {
>    local pid=$(get_pids)
>    if [ "$pid" != "" ]; then
>        echo "cloud.com sevice is already running, PID = $pid"
>        return 0
>    fi
>    echo -n "Starting cloud.com service (type=$TYPE) "
>    if [ -f $CLOUD_COM_HOME/systemvm/run.sh ];
> Here SSVM agent log,i
> Mon Feb 18 00:07:22 UTC 2013 Executing cloud-early-config
> Mon Feb 18 00:07:22 UTC 2013 Detected that we are running inside kvm guest
> Mon Feb 18 00:07:23 UTC 2013 Setting up secondary storage system vm
> Mon Feb 18 00:07:29 UTC 2013 Successfully setup storage network with STORAGE_IP:10.223.XXX.XXX,
STORAGE_NETMASK:255.255.255.192, STORAGE_CIDR:
> Mon Feb 18 00:07:29 UTC 2013 Setting up apache web server
> Mon Feb 18 00:07:29 UTC 2013 cloud: disable rp_filter
> Mon Feb 18 00:07:29 UTC 2013 disable rpfilter
> Mon Feb 18 00:07:29 UTC 2013 cloud: enable_fwding = 0
> Mon Feb 18 00:07:29 UTC 2013 enable_fwding = 0
> Mon Feb 18 00:07:29 UTC 2013 Enable service haproxy = 0
> Mon Feb 18 00:07:29 UTC 2013 Enable service dnsmasq = 0
> Mon Feb 18 00:07:29 UTC 2013 Enable service cloud-passwd-srvr = 0
> Mon Feb 18 00:07:29 UTC 2013 Enable service cloud = 1

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message