incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastien Goasguen <run...@gmail.com>
Subject 4.0.1 on OSX 10.8.2
Date Tue, 26 Feb 2013 20:35:05 GMT
Hi,

I am trying to run 4.0.1 release tar ball on OSX 10.8.2
I install tomcat6 via macports

I set:
$ echo $CATALINA_HOME
/opt/local/share/java/tomcat6/

Then when I try to run ant deploy-server (as root), I get things like:

deploy-awsapi:
     [copy] Copying 1 file to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/services
     [copy] Copying 1 file to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/modules
     [copy] Copying 1 file to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/modules
     [copy] Copying 2 files to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/lib
     [copy] Copying 2 files to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/conf
     [copy] Copying 1 file to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/conf
     [copy] Copying 1 file to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF
     [copy] Copying 2 files to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/modules
     [copy] Copying 2 files to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps7080/awsapi/WEB-INF/classes

deploy-server:
     [copy] Copying 1 file to /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/webapps/client/WEB-INF/lib/vms


The ant debug returns:
sebmini:apache-cloudstack-4.0.1-incubating-src sebastiengoasguen$ sudo ant debug
Buildfile: /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build.xml
     [echo] Using build parameters from /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/build-cloud.properties
     [echo] Using company info from /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/cloud.properties
     [echo] Using override file from /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/replace.properties
     [echo] Using build parameters from /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/build-cloud.properties
     [echo] Using company info from /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/cloud.properties
     [echo] Using override file from /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/replace.properties
     [echo] deploy home: /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/build/deploy

debug-tomcat:
     [java] Unable to access jarfile /Users/sebastiengoasguen/Documents/rc/apache-cloudstack-4.0.1-incubating-src/${env.CATALINA_HOME}/bin/bootstrap.jar
     [java] Java Result: 1

debug:

BUILD SUCCESSFUL
Total time: 1 second

Probably an OSX issue, but I am at a loss…any thoughts ?

-Sebastien



Mime
View raw message