incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: [ISSUE]ACS 4.1 code from today (02/14) broke login auth
Date Tue, 19 Feb 2013 22:30:32 GMT
This may be related to memory stuff. I just pushed a change of the MS
memory settings for tomcat.conf, per the emails that have been flying
around about it, so this hopefully will help for at least the packaged
installs.

On Tue, Feb 19, 2013 at 3:23 PM, Marcus Sorensen <shadowsor@gmail.com> wrote:
> Ok, so I just saw this issue where after cloudstack-management
> restart, user cannot log in as admin and I get "<pick an api call>
> does not exist or it is not available for user with id:2". The
> environment was working, I restarted MS, and it stopped working. Then
> I rebooted the server, and management server came up and all was happy
> again. Very strange.
>
> On Fri, Feb 15, 2013 at 9:31 AM, Marcus Sorensen <shadowsor@gmail.com> wrote:
>> Yes, hopping on cloudstack-dev
>>
>> On Fri, Feb 15, 2013 at 9:06 AM, Musayev, Ilya <imusayev@webmd.net> wrote:
>>> Marcus,
>>>
>>> Are you on IRC by any means or some other chat?
>>>
>>> Thanks
>>> ilya
>>>
>>> -----Original Message-----
>>> From: Marcus Sorensen [mailto:shadowsor@gmail.com]
>>> Sent: Friday, February 15, 2013 10:58 AM
>>> To: cloudstack-dev@incubator.apache.org
>>> Subject: Re: [ISSUE]ACS 4.1 code from today (02/14) broke login auth
>>>
>>> I didn't assume you were using devcloud. Well if you did that then I assume you
ARE missing /var/cloudstack/management. Without a package install these aren't set up... Or
does the mvn install try to do that, and does it need to be fixed? As far as I'm aware, a
fresh OS on a management server won't work if you just run jetty out of the tree, as I've
been saying there are a lot of dependencies in the code for full paths elsewhere in the filesystem.
>>> On Feb 15, 2013 8:49 AM, "Musayev, Ilya" <imusayev@webmd.net> wrote:
>>>
>>>> Marcus
>>>>
>>>> Sorry was away from pc. I'm not using devcloud. What i did was install
>>>> blank cent 6.3 on vmware, git clone master branch, mvn install
>>>> -Dnonoss and can't recall the syntax - but also started the mvn with jetty.
>>>>
>>>> In this case, the directory structure of where the code resides and
>>>> runs from is  - at least in my case -
>>>> /usr/local/cloudstack/incubator-cloudstack-41/....
>>>>
>>>> Ill see what patch caused this issue by rolli ng back and forward -
>>>> one patch at a time.
>>>>
>>>> This is definitely a blocker ATM
>>>>
>>>> Regards
>>>> Ilya
>>>>
>>>>
>>>> Marcus Sorensen <shadowsor@gmail.com> wrote:
>>>> Any luck figuring this out? Maybe look at my email response to Dave
>>>> regarding how I fixed devcloud-kvm by uninstalling everything,
>>>> removing all
>>>> cloud* stuff, removing the cloud user... Basically starting fresh.
>>>>
>>>> Alternatively, if you have an installation you're attached to, you can
>>>> work through each thing one by one. I thin the main things are that
>>>> the cloud user's home Dir is changed and that the rpms are installed
>>>> so that all of the new paths exist.
>>>>
>>>> I think everyone who has a KVM environment will need to do this until
>>>> the RPMs are fixed to do a clean upgrade. The code just won't work
>>>> with the old installation.
>>>> On Feb 14, 2013 5:25 PM, "Marcus Sorensen" <shadowsor@gmail.com> wrote:
>>>>
>>>> > Yeah, that's one of my packaging change fixes. I'm not sure what you
>>>> > mean about your github branch being different structure. You still
>>>> > have a user 'cloud' on your management server, with a home
>>>> > directory, and the management server still attempts to create keys
>>>> > in cloud's home, etc, correct?
>>>> >
>>>> >
>>>> >
>>>> > On Thu, Feb 14, 2013 at 5:06 PM, Sudha Ponnaganti
>>>> > <sudha.ponnaganti@citrix.com> wrote:
>>>> > > Can a blocker defect be logged for this??
>>>> > >
>>>> > > -----Original Message-----
>>>> > > From: Musayev, Ilya [mailto:imusayev@webmd.net]
>>>> > > Sent: Thursday, February 14, 2013 3:31 PM
>>>> > > To: cloudstack-dev@incubator.apache.org
>>>> > > Subject: RE: [ISSUE]ACS 4.1 code from today (02/14) broke login
>>>> > > auth
>>>> > >
>>>> > > I'm 3 days apart between two HEADs and something within those 3
>>>> > > days
>>>> > caused the issue.
>>>> > >
>>>> > > -----Original Message-----
>>>> > > From: Musayev, Ilya [mailto:imusayev@webmd.net]
>>>> > > Sent: Thursday, February 14, 2013 6:22 PM
>>>> > > To: cloudstack-dev@incubator.apache.org
>>>> > > Subject: RE: [ISSUE]ACS 4.1 code from today (02/14) broke login
>>>> > > auth
>>>> > >
>>>> > > I was on 1187fb7 HEAD - where login portion was working but
>>>> > > template
>>>> > import was broken I went forward to 298c5ee HEAD  - and login
>>>> > portion is broken due to "The given command:listCapabilities" and
>>>> "command:listSwifts
>>>> > does not  exist or it is not available for user with id:2" id:2
>>>> > should be Admin
>>>> > >
>>>> > >
>>>> > >
>>>> > > -----Original Message-----
>>>> > > From: Musayev, Ilya [mailto:imusayev@webmd.net]
>>>> > > Sent: Thursday, February 14, 2013 6:08 PM
>>>> > > To: cloudstack-dev@incubator.apache.org
>>>> > > Subject: RE: [ISSUE]ACS 4.1 code from today (02/14) broke login
>>>> > > auth
>>>> > >
>>>> > > Marcus,
>>>> > >
>>>> > > Thanks for the feedback, but I don't believe it was this specific
>>>> > > issue
>>>> > as I'm running a code from github and as you know my folder
>>>> > structure is very different.
>>>> > >
>>>> > > Can someone please try pulling latest code, install with nonoss
>>>> > > and try
>>>> > to login?
>>>> > >
>>>> > > Thanks
>>>> > > ilya
>>>> > >
>>>> > > -----Original Message-----
>>>> > > From: Marcus Sorensen [mailto:shadowsor@gmail.com]
>>>> > > Sent: Thursday, February 14, 2013 5:18 PM
>>>> > > To: cloudstack-dev@incubator.apache.org
>>>> > > Subject: Re: [ISSUE]ACS 4.1 code from today (02/14) broke login
>>>> > > auth
>>>> > >
>>>> > > So, this was happening previously because the cloud user's home
>>>> > > was not
>>>> > right. I saw this yesterday and the management server was throwing
>>>> > an exception when trying to generate ssh keys in
>>>> > /var/lib/cloud/management, which didn't exist. The new path is /var/cloudstack/management.
>>>> > >
>>>> > > So what may be happening is that people are now being bitten by
>>>> > everything being changed to match the package installs. I'll bet you
>>>> > have /var/lib/cloud/management/.ssh but not
>>>> > /var/cloudstack/management/.ssh
>>>> > >
>>>> > > On Thu, Feb 14, 2013 at 2:46 PM, Musayev, Ilya
>>>> > > <imusayev@webmd.net>
>>>> > wrote:
>>>> > >> ACS 4.1 code from today (02/14) broke login auth
>>>> > >>
>>>> > >> I get an error at login prompt "The given command does not
exist
>>>> > >> or
>>>> its
>>>> > not available for the user"
>>>> > >>
>>>> > >> 2013-02-14 16:40:12,633 DEBUG [cloud.api.ApiServlet]
>>>> > >> (2087715408@qtp-44855217-5:null) ===START===  10.46.40.109
--
>>>> > >> POST null
>>>> > >> 2013-02-14 16:40:12,639 DEBUG [cloud.user.AccountManagerImpl]
>>>> > >> (2087715408@qtp-44855217-5:null) Attempting to log in user:
admin
>>>> > >> in domain 1
>>>> > >> 2013-02-14 16:40:12,640 DEBUG [server.auth.MD5UserAuthenticator]
>>>> > >> (2087715408@qtp-44855217-5:null) Retrieving user: admin
>>>> > >> 2013-02-14 16:40:12,659 DEBUG [cloud.user.AccountManagerImpl]
>>>> > >> (2087715408@qtp-44855217-5:null) User: admin in domain 1 has
>>>> > >> successfully logged in
>>>> > >> 2013-02-14 16:40:12,689 DEBUG [cloud.api.ApiServlet]
>>>> > >> (2087715408@qtp-44855217-5:null) ===END===  10.46.40.109 --
POST
>>>>  null
>>>> > >> 2013-02-14 16:40:12,709 DEBUG [cloud.api.ApiServlet]
>>>> > >> (2087715408@qtp-44855217-5:null) ===START===  10.46.40.109
-- GET
>>>> > >> command=listCapabilities&response=json&sessionkey=MHQ4BNzDLCxRyhB
>>>> > >> tAzRE
>>>> > >> vVWsJw0%3D&_=1360878012706
>>>> > >> 2013-02-14 16:40:12,729 DEBUG [cloud.api.ApiServer]
>>>> > >> (2087715408@qtp-44855217-5:null) The given
>>>> > >> command:listCapabilities does not exist or it is not available
>>>> > >> for user with id:2
>>>> > >> 2013-02-14 16:40:12,732 DEBUG [cloud.api.ApiServlet]
>>>> > >> (2087715408@qtp-44855217-5:null) ===END===  10.46.40.109 --
GET
>>>> > >> command=listCapabilities&response=json&sessionkey=MHQ4BNzDLCxRyhB
>>>> > >> tAzRE
>>>> > >> vVWsJw0%3D&_=1360878012706
>>>> > >> 2013-02-14 16:40:12,746 DEBUG [cloud.api.ApiServlet]
>>>> > >> (2087715408@qtp-44855217-5:null) ===START===  10.46.40.109
-- GET
>>>> > >> command=listSwifts&response=json&sessionkey=MHQ4BNzDLCxRyhBtAzREv
>>>> > >> VWsJw
>>>> > >> 0%3D&_=1360878012744
>>>> > >> 2013-02-14 16:40:12,766 DEBUG [cloud.api.ApiServer]
>>>> > >> (2087715408@qtp-44855217-5:null) The given command:listSwifts
>>>> > >> does
>>>> not
>>>> > >> exist or it is not available for user with id:2
>>>> > >> 2013-02-14 16:40:12,769 DEBUG [cloud.api.ApiServlet]
>>>> > >> (2087715408@qtp-44855217-5:null) ===END===  10.46.40.109 --
GET
>>>> > >> command=listSwifts&response=json&sessionkey=MHQ4BNzDLCxRyhBtAzREv
>>>> > >> VWsJw
>>>> > >> 0%3D&_=1360878012
>>>> > >>
>>>> > >>
>>>> > >
>>>> > >
>>>> > >
>>>> > >
>>>> > >
>>>> > >
>>>> >
>>>>
>>>

Mime
View raw message