incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus Sorensen <shadow...@gmail.com>
Subject Re: devcloud-kvm
Date Wed, 06 Feb 2013 16:22:25 GMT
FYI, devcloud-kvm now works on Mac. It requires VMware fusion though,
since it allows paravirtualization inside the VM (nested). I added it
to the documentation, and am having someone test the instructions just
to make sure others can import the VM without issue.

https://cwiki.apache.org/confluence/display/CLOUDSTACK/devcloud-kvm

On Fri, Jan 11, 2013 at 1:08 PM, Rohit Yadav <rohit.yadav@citrix.com> wrote:
> 431, there was bug on ApiServer that I fixed yesterday, make sure you work on the latest
code if you're on master.
> Regards.
> ________________________________________
> From: Marcus Sorensen [shadowsor@gmail.com]
> Sent: Friday, January 11, 2013 8:37 PM
> To: cloudstack-dev@incubator.apache.org
> Subject: Re: devcloud-kvm
>
> When I manually configure the advanced zone in my kvm devcloud the Vlan
> isolation works fine. It just creates a new bridge for each Vlan, and any
> VM started goes on the applicable bridge. Since its all on the same server
> they can communicate just fine without any real tagged Vlan infrastructure
> beyond the host.
>
> The 431 seemed to be an auth issue, I'll play with it further today. It may
> have had to do with needing to tweak devcloud.sql as well. When I added a
> second physical network though it seemed to fail in parsing the config, so
> I know I have that syntax wrong, that's why I fell back to using the
> advanced sandbox config.
> On Jan 11, 2013 7:28 AM, "Prasanna Santhanam" <tsp@apache.org> wrote:
>
>> On Thu, Jan 10, 2013 at 01:53:30PM -0500, Marcus Sorensen wrote:
>> > Guys,
>> >   I'm writing up basic instructions on how to run a devcloud-kvm virtual
>> > machine, for KVM development. The setup is complete, but I've run into a
>> > few things as far as configuration that I'd like some help on.
>> >
>> > 1) running services. In the past I've just built rpms and installed them
>> in
>> > the devcloud-kvm. Not only does this not work on master right now, but it
>> > takes an extra 60 seconds. With devcloud we run "mvn -P
>> developer,systemvm
>> > clean install && mvn -pl :cloud-client-ui jetty:run", I'm assuming I'll
>> > have to start the agent as well... or I guess my question is how that's
>> > handled when a normal zone creation expects the agent to be installed on
>> > the KVM host.
>> >
>> > 2) how to go about configuration. I'd like to have a marvin config that
>> > does two physical networks and an advanced zone, but I wasn't able to get
>> > anything but a 431 error when trying anything custom with a marvin cfg
>> file
>> > (both in the standard devcloud and here). I played with the sandbox
>> example
>> > at
>> >
>> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Testing+with+Pythonas
>> > well as trying to create my own cfg file, and both resulted in 431 when
>> > connecting to the management server for configuration.
>>
>> Marcus, This is exciting! I didn't find details yet in the wiki on how
>> you are doing the VLAN isolation. I was looking to do something
>> similar for devcloud using ovs-vsctl. But I guess you're doing
>> something different in devcloud-kvm?
>>
>> As for the marvin failure - could you share the json configuration
>> that you made? The two physical network setup isn't really present in
>> the sandbox, so first guess is it might have gone wrong.
>>
>> --
>> Prasanna.,
>>

Mime
View raw message