incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nalley <da...@gnsa.us>
Subject Re: License issue for js file from ui-plugins merge
Date Thu, 14 Feb 2013 14:07:35 GMT
On Thu, Feb 14, 2013 at 7:08 AM, Pranav Saxena <pranav.saxena@citrix.com> wrote:
> Yeah right now the require.js file merged has this license -
>
> /** vim: et:ts=4:sw=4:sts=4
>  * @license RequireJS 2.1.2 Copyright (c) 2010-2012, The Dojo Foundation All Rights Reserved.
>  * Available via the MIT or new BSD license.
>  * see: http://github.com/jrburke/requirejs for details
>  */
> //Not using strict: uneven strict support in browsers, #392, and causes
> //problems with requirejs.exec()/transpiler plugins that may not be strict.
> /*jslint regexp: true, nomen: true, sloppy: true */
> /*global window, navigator, document, importScripts, jQuery, setTimeout, opera *
>
>
> This needs to be changed to the Apache licensing  , right ?
>

NO - we must never change the license for code which is not ours.
The author(s) set the license, and we must honor that.

Folks, please try and communicate about adding dependencies/libraries
like this BEFORE it hits the repo.

--David

Mime
View raw message