incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wido den Hollander <w...@widodh.nl>
Subject RE: Unable to Add XS host to CloudPlatform
Date Tue, 05 Feb 2013 14:24:16 GMT
Why is this e-mail regarding CloudPlatform going to the -dev and -users list for
the CloudStack project?

If there is an bug in CloudStack feel free to file it in Jira and it will be
looked at.

Thanks!

Wido

Op 5 februari 2013 om 13:58 schreef Sandip Warke <sandip.warke@citrix.com>:

>
>  Team,
>
>  Resending (cc myself since I am not a part of any DL )
>
> 
>
>  From: Sandip Warke
>  Sent: Tuesday, 5 February 2013 5:32 PM
>  To: Somesh Naidu; 'cloudstack-dev@incubator.apache.org';
> 'cloudstack-users@incubator.apache.org'
>  Cc: #Support - Cloud Escalation
>  Subject: RE: Unable to Add XS host to CloudPlatform
>
> 
>
>  Hi,
>
>  I have checked the logs. Attached below is log when I try to add host. I have
> highlighted error.
>
> 
>
> 
>
>  2013-02-05 17:17:05,400 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) VmStatsCollector is running...
>
>  2013-02-05 17:17:05,400 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-2:null) HostStatsCollector is running...
>
>  2013-02-05 17:17:05,436 DEBUG [cloud.server.StatsCollector]
> (StatsCollector-1:null) StorageCollector is running...
>
>  2013-02-05 17:17:10,605 DEBUG [cloud.api.ApiServlet] (catalina-exec-17:null)
> Invalid paramemter in URL found. param: hosttags=
>
>  2013-02-05 17:17:10,627 INFO  [cloud.resource.ResourceManagerImpl]
> (catalina-exec-17:null) Trying to add a new host at http://192.168.122.8
> <http://192.168.122.8/> in data center 1
>
>  2013-02-05 17:17:10,703 DEBUG [xen.resource.XenServerConnectionPool]
> (catalina-exec-17:null) Slave logon to 192.168.122.8
>
>  2013-02-05 17:17:10,735 DEBUG [xen.resource.XenServerConnectionPool]
> (catalina-exec-17:null) Logging on as the master to 192.168.122.8
>
>  2013-02-05 17:17:10,910 INFO  [xen.discoverer.XcpServerDiscoverer]
> (catalina-exec-17:null) Found host FCVXENSRV04 ip=192.168.122.8 product
> version=6.0.2
>
>  2013-02-05 17:17:11,261 DEBUG [xen.resource.CitrixResourceBase]
> (catalina-exec-17:null) Management network is on
> pif=0352cd49-1722-8ede-c4a2-3b1c74018b8d
>
>  2013-02-05 17:17:11,283 WARN  [xen.resource.CitrixResourceBase]
> (catalina-exec-17:null) Unable to get host information for 192.168.122.8
>
>  java.lang.NullPointerException
>
>          at
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.getHostInfo(CitrixResourceBase.java:4305)
>
>          at
> com.cloud.hypervisor.xen.resource.CitrixResourceBase.initialize(CitrixResourceBase.java:4434)
>
>          at
> com.cloud.hypervisor.xen.resource.XenServer56Resource.initialize(XenServer56Resource.java:328)
>
>          at
> com.cloud.resource.ResourceManagerImpl.createHostAndAgent(ResourceManagerImpl.java:1688)
>
>          at
> com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:802)
>
>          at
> com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:627)
>
>          at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:136)
>
>          at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:235)
>
>          at com.cloud.api.ApiServer.queueCommand(ApiServer.java:540)
>
>          at com.cloud.api.ApiServer.handleRequest(ApiServer.java:419)
>
>          at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:300)
>
>          at com.cloud.api.ApiServlet.doGet(ApiServlet.java:59)
>
>          at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
>
>          at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
>
>          at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
>
>          at
> org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
>
>          at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
>
>          at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
>
>          at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
>
>          at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
>
>          at
> org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:555)
>
>          at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
>
>          at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
>
>          at
> org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
>
>          at
> org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:721)
>
>          at
> org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2268)
>
>          at
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
>
>          at
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
>
>          at java.lang.Thread.run(Thread.java:679)
>
>  2013-02-05 17:17:11,285 WARN  [xen.resource.CitrixResourceBase]
> (catalina-exec-17:null) Unable to get host information for 192.168.122.8
>
>  2013-02-05 17:17:11,285 INFO  [cloud.resource.ResourceManagerImpl]
> (catalina-exec-17:null) Unable to fully initialize the agent because no
> StartupCommands are returned
>
>  2013-02-05 17:17:11,285 INFO  [cloud.resource.ResourceManagerImpl]
> (catalina-exec-17:null) server resources successfully discovered by XCP Agent
>
>  2013-02-05 17:17:11,286 WARN  [cloud.api.ApiDispatcher]
> (catalina-exec-17:null) class com.cloud.api.ServerApiException : Failed to add
> host
>
>  2013-02-05 17:17:20,639 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl]
> (consoleproxy-1:null) Skip capacity scan due to there is no Primary Storage
> UPintenance mode
>
>  2013-02-05 17:17:21,421 DEBUG
> [network.router.VirtualNetworkApplianceManagerImpl]
> (RouterStatusMonitor-1:null) Found 0 routers.
>
> 
>
> 
>
> 
>
> 
>
>  With Regards
>
>  Sandip N. Warke
>
>  +91-9819931983
>
> 
>
>  From: Somesh Naidu
>  Sent: Tuesday, 5 February 2013 5:24 PM
>  To: Sandip Warke; #Support - Cloud Escalation
>  Subject: RE: Unable to Add XS host to CloudPlatform
>
> 
>
>  Sandip,
>
> 
>
>  You might benefit from,
>
>  a.       Looking at the /var/log/cloud/management-server.log
>
>  b.      Sending your queries to cloudstack-users@incubator.apache.org
> <mailto:cloudstack-users@incubator.apache.org> or
> cloudstack-dev@incubator.apache.org
> <mailto:cloudstack-dev@incubator.apache.org> .
>
> 
>
>  HTH
>
> 
>
>  Regards,
>
>  Somesh
>
> 
>
>  From: Sandip Warke
>  Sent: Tuesday, February 05, 2013 5:09 PM
>  To: #Support - Cloud Escalation
>  Cc: Sandip Warke
>  Subject: Unable to Add XS host to CloudPlatform
>
> 
>
> 
>
>  Team,
>
>   For a POC at customer location, we are trying to add virtual XenServers ( XS
> 6.1 as base Hypervisor) & XenServer 6.0.2-53456p on VM to CloudPlatform
> 3.0.5.20120904142539. However we are getting error "Unable to add host". Event
> in CloudPlatform console does not shows any "events" or "alerts".
>
> 
>
>  We have tweaked the mysql as per the below commands
>
> 
>
>  And taken care of pre-requisites
>
>  For XenServer 6.0.2:
> http://download.cloud.com/releases/3.0.1/XS-6.0.2/xenserver-cloud-supp.tgz
> <http://download.cloud.com/releases/3.0.1/XS-6.0.2/xenserver-cloud-supp.tgz>
>
>                                                  # tar xf
> xenserver-cloud-supp.tgz
>
>                                                  #
> xe-install-supplemental-pack xenserver-cloud-supp.iso
>
> 
>
>  And disabled openvswitch since we have configured basic network at
> CloudPlatform
>
>                                                  # xe-switch-network-backend
>  bridge
>
> 
>
> 
>
>  Any leads on how / where we can check in the logs to debug ?
>
>  With Regards
>
>  Sandip N. Warke
>
>  +91-9819931983
>

Mime
View raw message