incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <...@apache.org>
Subject Re: Simulator - adding cluster fails
Date Tue, 26 Feb 2013 13:28:14 GMT
On Tue, Feb 26, 2013 at 06:55:42PM +0530, Prasanna Santhanam wrote:
> On Tue, Feb 26, 2013 at 06:25:07PM +0530, Sowmya Krishnan wrote:
> > I am trying to run some tests using simulator off latest from 4.1
> > branch, but it fails when I try to add a cluster of hypervisor type
> > "Simulator". I get the following error:
> > ERROR 431: Could not find corresponding resource manager for Simulator.
> > API I used was:
> 
> > http://localhost:8096/client/?command=addCluster&hypervisor=Simulator&clustertype=CloudManaged&zoneId=1&podId=32be7171-4707-443d-9127-8599fd9a60e7&clustername=SimCluster1
> > 
> > I built with simulator using the following steps:
> > 
> > mvn install -Dsimulator
> > cp agent-simulator/tomcatconf/components-simulator.xml.in client/target/cloud-client-ui-4.1.0-SNAPSHOT/WEB-INF/classes/components-simulator.xml
> > Refer to components-simulator.xml in environment.properties
> > 
> > mvn -P developer -pl developer  -Ddeploydb
> > 
> > mvn -P developer -pl developer -Ddeploydb-simulator
> > mvn -pl :cloud-client-ui jetty:run -Dsimulator
> > 
> > Any pointers to what I might be missing here? I remember I was able
> > to get this work couple of weeks back and I was able to deploy
> > simulator VMs..etc.  I am not sure if javelin merge calls for any
> > changes to be done in the above steps...
> > 
> 
> Was broken since javelin. I fixed it last week or so on master (edac89).
> Hadn't cherry-picked to 4.1 yet. Done now (6977e7b)
> 
> This is how I run it:
> 
> mvn -Psimulator clean install 
> mvn -Pdeveloper -pl developer -Ddeploydb
> mvn -Pdeveloper -pl developer -Ddeploydb-simulator
> mvn -pl client jetty:run

Also You'll have to uncomment the simulator related beans in
componentContext.xml.in before building

components-simulator.xml.in is deprecated.

I filed a bug to get rid of our ComponentLocator vestiges to make it
less confusing:

https://issues.apache.org/jira/browse/CLOUDSTACK-1323

-- 
Prasanna.,

Mime
View raw message