incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chip Childers <chip.child...@sungard.com>
Subject Re: License issue for js file from ui-plugins merge
Date Thu, 14 Feb 2013 20:41:53 GMT
On Thu, Feb 14, 2013 at 11:49:49AM -0800, Animesh Chaturvedi wrote:
> 
> 
> > -----Original Message-----
> > From: Chip Childers [mailto:chip.childers@sungard.com]
> > Sent: Thursday, February 14, 2013 9:10 AM
> > To: cloudstack-dev@incubator.apache.org
> > Cc: Brian Federle
> > Subject: Re: License issue for js file from ui-plugins merge
> > 
> > On Thu, Feb 14, 2013 at 05:38:11PM +0530, Pranav Saxena wrote:
> > > Yeah right now the require.js file merged has this license -
> > >
> > > /** vim: et:ts=4:sw=4:sts=4
> > >  * @license RequireJS 2.1.2 Copyright (c) 2010-2012, The Dojo Foundation All
> > Rights Reserved.
> > >  * Available via the MIT or new BSD license.
> > >  * see: http://github.com/jrburke/requirejs for details  */ //Not
> > > using strict: uneven strict support in browsers, #392, and causes
> > > //problems with requirejs.exec()/transpiler plugins that may not be strict.
> > > /*jslint regexp: true, nomen: true, sloppy: true */ /*global window,
> > > navigator, document, importScripts, jQuery, setTimeout, opera *
> > >
> > 
> > I'm assuming that we have consensus that this script should be added, unless
> > anyone objects.
> > 
> > I'll look at fixing the legal docs, but please try to warn before adding something
> > new next time.
> > 
> [Animesh>] Certainly we need to check the licensing before we add new dependencies.
How do we handle this particular issue?

Well, the info needs to go into the tools/whisker/descriptor*.xml files,
and we need to re-generate the LICENSE and NOTICE at the top and in the
whisker folder.  We also need to add this file to the root pom's RAT
exclude list.

Like I said, I'll look at doing it if people want.  I'll be able to do
it tomorrow morning EST.

-chip

Mime
View raw message