incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcus Sorensen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CLOUDSTACK-1011) KVM host getting disconnected in cluster environment
Date Fri, 18 Jan 2013 07:10:12 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-1011?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13557007#comment-13557007
] 

Marcus Sorensen commented on CLOUDSTACK-1011:
---------------------------------------------

I've got a fix for this, just need to test it a bit.
                
> KVM host getting disconnected in cluster environment 
> -----------------------------------------------------
>
>                 Key: CLOUDSTACK-1011
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-1011
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: KVM
>    Affects Versions: 4.1.0
>         Environment: Build from "network-refactor"
> KVM
>            Reporter: Rayees Namathponnan
>            Assignee: Kishan Kavala
>             Fix For: 4.1.0
>
>         Attachments: Agent_Log.rar
>
>
> Steps to reproduce 
> Create advanced zone with 2 zones 
> First zone :  1 POD, 1 Cluster and 2 hosts
> Second zone : 1 POD, 1 Cluster and 1 host 
>  
> Expected result 
> System Vms should  come up successfully, and KVM host should be in connected state always
> Actual Result 
> KVM agent disconnected after some time,  i can see below null pointer exception in KVM
agent log; then tried to restart agent and libvert,  but still agent not able to connect with
MS 
> 2013-01-18 03:21:01,210 WARN  [cloud.agent.Agent] (agentRequest-Handler-1:null) Caught:

> java.lang.NullPointerException
> 	at com.cloud.hypervisor.kvm.storage.KVMStoragePoolManager.getStorageAdaptor(KVMStoragePoolManager.java:41)
> 	at com.cloud.hypervisor.kvm.storage.KVMStoragePoolManager.getStoragePool(KVMStoragePoolManager.java:66)
> 	at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.cleanupDisk(LibvirtComputingResource.java:3153)
> 	at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.execute(LibvirtComputingResource.java:2687)
> 	at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequest(LibvirtComputingResource.java:968)
> 	at com.cloud.agent.Agent.processRequest(Agent.java:525)
> 	at com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:852)
> 	at com.cloud.utils.nio.Task.run(Task.java:83)
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> 	at java.lang.Thread.run(Thread.java:679)
> 2013-01-18 03:21:01,432 WARN  [cloud.agent.Agent] (agentRequest-Handler-1:null) Caught:

> java.lang.NullPointerException
> 	at com.cloud.hypervisor.kvm.storage
> Additional information :
> I was looking Zone 1 's (adv-Kvm-Zone1) dashboard -> Storage, here storage is Allocated
: 0.00 KB / 0.00 KB

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message