incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sheng Yang <sh...@yasker.org>
Subject Re: Java-ipv6 library
Date Thu, 24 Jan 2013 00:40:33 GMT
On Wed, Jan 23, 2013 at 4:33 PM, Rohit Yadav <bhaisaab@apache.org> wrote:
> On Wed, Jan 23, 2013 at 4:19 PM, Sheng Yang <sheng@yasker.org> wrote:
>> On Wed, Jan 23, 2013 at 3:40 PM, Sheng Yang <sheng@yasker.org> wrote:
>>> On Wed, Jan 23, 2013 at 3:33 PM, Wido den Hollander <wido@widodh.nl> wrote:
>>>>
>>>>
>>>> On 01/24/2013 12:27 AM, David Nalley wrote:
>>>>>
>>>>> On Wed, Jan 23, 2013 at 6:25 PM, Sheng Yang <sheng@yasker.org>
wrote:
>>>>>>
>>>>>> I am considering adding this library to Cloudstack to help our IPv6
>>>>>> development.
>>>>>>
>>>>>> http://code.google.com/p/java-ipv6/
>>>>>>
>>>>>> It's apache license, and maven friendly.
>>>>>>
>>>>>> Is that OK?
>>>>>>
>>>>>> --Sheng
>>>>>
>>>>>
>>>>> You mean just making it a dependency?
>>>>
>>>>
>>>> I guess so? Seems like a useful library with all the stuff it can do for
>>>> you. The latest version (0.8) is indeed in Maven Central.
>>>
>>> Yes that what I suppose to say. Make it a dependency.
>>>
>>> Nice, so I would go ahead and add it. :)
>>
>> OK, one silly question: I am failed to let mvn know the package
>> com.googlecode.ipv6:
>>
>> Here is diff:
>>
>> yasker@yasker-ThinkPad-X201:~/develop/cloudstack-oss$ git diff
>> diff --git a/utils/pom.xml b/utils/pom.xml
>> index 87c078a..6f45044 100644
>> --- a/utils/pom.xml
>> +++ b/utils/pom.xml
>> @@ -129,6 +129,11 @@
>>        <version>${cs.ejb.version}</version>
>>      </dependency>
>>      <dependency>
>> +        <groupId>com.googlecode.java-ipv6</groupId>
>> +        <artifactId>java-ipv6</artifactId>
>> +        <version>${cs.java-ipv6.version}</version>
>> +    </dependency>
>> +    <dependency>
>>        <groupId>commons-configuration</groupId>
>>        <artifactId>commons-configuration</artifactId>
>>        <version>${cs.configuration.version}</version>
>> diff --git a/utils/src/com/cloud/utils/net/NetUtils.java
>> b/utils/src/com/cloud/utils/net/NetUtils.java
>> index 2a264f8..75340f4 100755
>> --- a/utils/src/com/cloud/utils/net/NetUtils.java
>> +++ b/utils/src/com/cloud/utils/net/NetUtils.java
>> @@ -42,6 +42,8 @@ import java.util.regex.Pattern;
>> import org.apache.log4j.Logger;
>> import org.apache.log4j.xml.DOMConfigurator;
>>
>> +import com.googlecode.ipv6;
>> +
>> import com.cloud.utils.IteratorUtil;
>> import com.cloud.utils.Pair;
>> import com.cloud.utils.script.Script;
>>
>> diff --git a/pom.xml b/pom.xml
>> index 35d6520..34e22c3 100644
>> --- a/pom.xml
>> +++ b/pom.xml
>> @@ -87,6 +87,7 @@
>>      <cs.lang.version>2.6</cs.lang.version>
>>      <cs.commons-io.version>1.4</cs.commons-io.version>
>>      <cs.reflections.version>0.9.8</cs.reflections.version>
>> +    <cs.java-ipv6.version>0.8</cs.java-ipv6.version>
>>    </properties>
>>
>>    <distributionManagement>
>>
>>
>> Error:
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-compiler-plugin:2.5.1:compile
>> (default-compile) on project cloud-utils: Compilation failure
>> [ERROR] /home/yasker/develop/cloudstack-oss.asf/utils/src/com/cloud/utils/net/NetUtils.java:[45,21]
>> package com.googlecode does not exist
>> [ERROR] -> [Help 1]
>> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to
>> execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:compile
>> (default-compile) on project cloud-utils: Compilation failure
>> /home/yasker/develop/cloudstack-oss.asf/utils/src/com/cloud/utils/net/NetUtils.java:[45,21]
>> package com.googlecode does not exist
>>
>> Also Eclipse didn’t recognize the package as well.
>>
>> The file existed in ~/.m2/repository:
>> yasker@yasker-ThinkPad-X201:~/.m2/repository/com/googlecode/java-ipv6/java-ipv6/0.8$
>> ll
>> total 52
>> drwxrwxr-x 2 yasker yasker  4096 Jan 23 15:50 ./
>> drwxrwxr-x 3 yasker yasker  4096 Jan 23 15:50 ../
>> -rw-rw-r-- 1 yasker yasker 22075 Jan 23 15:50 java-ipv6-0.8.jar
>> -rw-rw-r-- 1 yasker yasker    40 Jan 23 15:50 java-ipv6-0.8.jar.sha1
>> -rw-rw-r-- 1 yasker yasker  4168 Jan 23 15:50 java-ipv6-0.8.pom
>> -rw-rw-r-- 1 yasker yasker    40 Jan 23 15:50 java-ipv6-0.8.pom.sha1
>> -rw-rw-r-- 1 yasker yasker   180 Jan 23 15:50 _maven.repositories
>>
>> And here is doc:
>> https://java-ipv6.googlecode.com/svn/artifacts/0.8/doc/apidocs/index.html
>>
>> Anyone has idea what wrong here?
>
> Resolution error? You may want to import something from ipv6 package,
> like import com.googlecode.ipv6.IPv6Address and not ipv6 itself?

Yeah, really an silly mistake[:shame:]...

Just realize com.googlecode.ipv6 is the package, not com.googlecode,
so mvn complained in this way.
>
> Maven anecdotes; do a clean install: mvn clean install -pl utils
> If that fails again, clean your ~/.m2

Yeah, I've cleaned the ~/.m2 already.

Thanks!

--Sheng
>
>>
>> --Sheng
>>
>>>
>>> --Sheng
>>>>
>>>> Wido
>>>>
>>>>
>>>>> (I assume you aren't wishing to bundle it in the codebase)
>>>>>
>>>>> --David
>>>>>
>>>>

Mime
View raw message