incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Battala <rajesh.batt...@citrix.com>
Subject [LB creation Issue] my asf 4.1 work is blocked because of this issue
Date Wed, 23 Jan 2013 17:04:58 GMT
Hi All,

Am writing "AWS  Style health feature for NetScaler".
Till yesterday I was on  asf/master git commit(127867cc999a7c772cdf5108b3e7432f91178cfe )
while writing my code.
I had rebased my changes with the latest master git commit(3bac7b8c07b21eaa3a7b244f4d74efa7b4b5b41f
)
The way I had rebased is, I had clone fresh repo from asf master and merged the changes from
the working git clone to the new cloned folder.
After rebase, building and starting cloud is working perfectly fine.

The issue am facing is, When I tried to create the LB for the NetScaler Device, it's not getting
created.
But the job is showing completed. When I had verified the log, its selecting VirtualRouterElement
instead of NetScaler element to create the LB rules.
I had checked the NetScaler UI, No LB rules are created.

Till merging its working fine and selecting the NetScaler element to create the LB rules and
monitors.

I had created a new networking offering and selected Virtual Router for all the services except
Load Balancing. For Load Balancing I had selecte NetScaler.
Service Capabilities

SourceNat: VirtualRouter, Dns: VirtualRouter, Dhcp: VirtualRouter, UserData: VirtualRouter,
Firewall: VirtualRouter, Lb: Netscaler


Created a guest network from the network offering and deployed the instances. Instances got
deployed successfully. But am having issues creating LB rules for NetScaler device.

Please let me know how to resolve this issue. Am blocked because of this issue.

I have started pushing my repo to github location https://github.com/rajesh-battala/asf-cloudstack-master.git
It will take few min to complete the pushing operation.

Thanks
Rajesh Battala

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message