incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sangeetha Hariharan <Sangeetha.Hariha...@citrix.com>
Subject Not able to start System Vms on KVM host
Date Tue, 29 Jan 2013 23:57:55 GMT
Marcus,

I tried with the patch you have provided on IPV6 branch.

Now I see the the public interface being programed correctly. But there are issues with 'cloudbr1'
and system Vms are still not coming up.
The same issue is also seen when testing with master branch.

 
[root@Rack3Host4 agent]# brctl show
bridge name     bridge id               STP enabled     interfaces
brem1-1363              8000.bc305bd41f86       no              em1.1363
cloud0          8000.000000000000       no
cloudbr0                8000.bc305bd41f86       no              em1
virbr0          8000.525400463d1f       yes             virbr0-nic


[root@Rack3Host4 agent]# ls  /sys/devices/virtual/net
brem1-1363  cloud0  cloudbr0  em1.1363  lo  virbr0  virbr0-nic

Following exception seen in agent.log:

2013-01-29 18:40:55,451 WARN  [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-2:null)
Failed to start domain: v-2-VM: Cannot get interface MTU on 'cloudbr1': No such device
2013-01-29 18:40:55,452 WARN  [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-2:null)
Exception
org.libvirt.LibvirtException: Cannot get interface MTU on 'cloudbr1': No such device
        at org.libvirt.ErrorHandler.processError(Unknown Source)
        at org.libvirt.Connect.processError(Unknown Source)
        at org.libvirt.Domain.processError(Unknown Source)
        at org.libvirt.Domain.create(Unknown Source)
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.startDomain(LibvirtComputingResource.java:1049)
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.execute(LibvirtComputingResource.java:3096)
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequest(LibvirtComputingResource.java:1174)
        at com.cloud.agent.Agent.processRequest(Agent.java:525)
        at com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:852)
        at com.cloud.utils.nio.Task.run(Task.java:83)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
2013-01-29 18:40:55,452 WARN  [cloud.agent.Agent] (agentRequest-Handler-2:null) Caught:
java.lang.NullPointerException
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.cleanupVMNetworks(LibvirtComputingResource.java:4223)
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.handleVmStartFailure(LibvirtComputingResource.java:2992)
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.execute(LibvirtComputingResource.java:3116)
        at com.cloud.hypervisor.kvm.resource.LibvirtComputingResource.executeRequest(LibvirtComputingResource.java:1174)
        at com.cloud.agent.Agent.processRequest(Agent.java:525)
        at com.cloud.agent.Agent$AgentRequestHandler.doTask(Agent.java:852)
        at com.cloud.utils.nio.Task.run(Task.java:83)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)

Thanks
Sangeetha



Mime
View raw message