incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Qiu Zhigang" <qiu...@chinatelecom.com.cn>
Subject RE: deploy-db-dev.sh failed when execute command "ant deploydb"
Date Sat, 26 Jan 2013 03:08:55 GMT
Thank you.

I follow this wike page,
https://cwiki.apache.org/confluence/display/CLOUDSTACK/Setting+up+a+CloudSta
ck+dev+environment+on+Windows

Whe I use maven to build in branch 4.0, some error like '[ERROR] Could not
find the selected project in the reactor: developer' occurred.

I think 4.0 still uses the Ant for build.

Best Regards,
Qiu Zhigang

> -----Original Message-----
> From: rohityadav89@gmail.com [mailto:rohityadav89@gmail.com] On Behalf
> Of Rohit Yadav
> Sent: Saturday, January 26, 2013 3:13 AM
> To: cloudstack-dev@incubator.apache.org
> Subject: Re: deploy-db-dev.sh failed when execute command "ant deploydb"
> 
> Pl. follow the wiki page on building, we have deprecated the ant build
system,
> maven should be used for master.
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/How+to+build+on+
> master+branch
> 
> Regards.
> 
> On Fri, Jan 25, 2013 at 1:52 AM, Qiu Zhigang <qiuzhg@chinatelecom.com.cn>
> wrote:
> > Hi,
> >
> > I use dos2unix convert the script's format.
> >
> >
> > Best Regards,
> > Qiu Zhigang
> >
> >
> >> -----Original Message-----
> >> From: Qiu Zhigang [mailto:qiuzhg@chinatelecom.com.cn]
> >> Sent: Friday, January 25, 2013 3:10 PM
> >> To: cloudstack-dev@incubator.apache.org
> >> Subject: deploy-db-dev.sh failed when execute command "ant deploydb"
> >>
> >> Hi,
> >>
> >> I am trying to setup cloudstack dev environment with branch
> >> /origin/4.0 at
> > git
> >> repository.
> >> I have downloaded the src from git repository and url as well but I
> >> am
> > getting
> >> following error while deploying db...
> >>
> >>
> >> command : ant deploydb
> >>
> >> $ ant deploydb
> >> Buildfile: build.xml
> >>      [echo] Using build parameters from
> >> D:\opensource\incubator-cloudstack/build/build-cloud.properties
> >>      [echo] Using company info from
> >> D:\opensource\incubator-cloudstack\build/cloud.properties
> >>      [echo] Using override file from
> >> D:\opensource\incubator-cloudstack\build/replace.properties
> >>      [echo] Using build parameters from
> >> D:\opensource\incubator-cloudstack/build/build-cloud.properties
> >>      [echo] Using company info from
> >> D:\opensource\incubator-cloudstack\build/cloud.properties
> >>      [echo] Using override file from
> >> D:\opensource\incubator-cloudstack\build/replace.properties
> >>      [echo] deploy home:
> >> D:\opensource\incubator-cloudstack\build\deploy
> >>
> >> deploy-cloudstack-db:
> >>      [echo]
> >> D:\opensource\incubator-cloudstack\target\db\\deploy-db-dev.sh
> >> server-setup.xml templates.sql ctcloud
> >>      [exec] deploy-db-dev.sh: line 18: $'\r': command not found
> >>      [exec] deploy-db-dev.sh: line 19: $'\r': command not found
> >>      [exec] deploy-db-dev.sh: line 20: $'\r': command not found
> >>      [exec] deploy-db-dev.sh: line 21: $'\r': command not found
> >>      [exec] deploy-db-dev.sh: line 22: $'\r': command not found
> >>      [exec] deploy-db-dev.sh: line 25: $'\r': command not found
> >>      [exec] deploy-db-dev.sh: line 64: syntax error near unexpected
> >> token `$'{\r''
> >>      [exec] deploy-db-dev.sh: line 64: `handle_error() {
> >>      [exec] '
> >>
> >> BUILD FAILED
> >>
> >> I tried looking into the deploy-db-dev.sh file on the above line nos
> >> but
> > no error
> >> as prompted.
> >>
> >> Please guide me if anyone had similar kind of issue.
> >>
> >> Thanks in adavance :)
> >>
> >>
> >> Best Regards,
> >> Qiu Zhigang
> >


Mime
View raw message