incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joe Brockmeier (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CLOUDSTACK-405) management server startup missing from install documents
Date Sun, 09 Dec 2012 19:47:20 GMT

     [ https://issues.apache.org/jira/browse/CLOUDSTACK-405?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joe Brockmeier resolved CLOUDSTACK-405.
---------------------------------------

       Resolution: Fixed
    Fix Version/s: pre-4.0.0

Looks good, and no additional follow-up since October. Closing this.
                
> management server startup missing from install documents
> --------------------------------------------------------
>
>                 Key: CLOUDSTACK-405
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-405
>             Project: CloudStack
>          Issue Type: Bug
>      Security Level: Public(Anyone can view this level - this is the default.) 
>          Components: Doc
>            Reporter: Noa Resare
>            Assignee: Jessica Tomechak
>             Fix For: pre-4.0.0
>
>
> For the simplest possible test case (that I can come up with) the Installation Guide
instructions fail, with status 404 when attempting to connect to http://MANAGEMENT_SERVER:8080/client

> Expected outcome:
> The cloudstack web UI in the web browser when accessing http://MANAGEMENT_SERVER:8080/client
> Actual outcome:
> The default tomcat 404 page
> Steps to reproduce:
> - I created a fully updated vmware vm running a 64 bit Ubuntu 12.04.1
> - installed mysql-server, with root password abc123
> - ran mysql_secure_installation, default options
> - pulled the latest built ubuntu packages from jenkins: http://jenkins.cloudstack.org/job/build-4.0-ubuntu1204/535/artifact/CloudStack-oss-4.0.0-535.tar.bz2
> - ran the install script installing the management server (which translates install 'apt-get
install cloud-client')
> - ran "cloud-setup-databases cloud:foobar --deploy-as=root:abc123" with the output "CloudStack
has successfully initialized database"
> - attempted to connect with my web browser at http://MANAGEMENT_SERVER:8080/client
> Additional notes:
> Looking at the output from the installer, it seems the tomcat6 starts on install, listening
on port 8080. If I run
> "/etc/init.d/tomcat6 stop" followed by "/etc/init.d/cloud-management start" I get a cloudstack
login prompt at http://MANAGEMENT_SERVER:8080/client/

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message