incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ilya.m" <ily...@serverchief.com>
Subject Re: Review Request: Identified and resolved issue for Router VM on vSphere 5.0 and CS 4.0 - where a router VM would come up however the Link Local IP would be unreachable
Date Sat, 08 Dec 2012 04:04:12 GMT
Thank you for rolling this in Joe

I will mark the bug as resolved.

Ilya


Sent via the Samsung Galaxy S™III, an AT&T 4G LTE smartphoneJoe Brockmeier <jzb@zonker.net>
wrote:This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/8420/

Ship it!

Looked OK to me. I went ahead and added this to master. Have also cherry picked to 4.0. Please
be sure to mark this as closed. Thanks! 

- Joe


On December 7th, 2012, 9:46 p.m., ilya musayev wrote:

Review request for cloudstack.
By ilya musayev.
Updated Dec. 7, 2012, 9:46 p.m.

Description

Identified and resolved issue for Router VM on vSphere 5.0 and CS 4.0 - where a router VM
would come up however the Link Local IP would be unreachable until you initiate a ping request
from Router VM itself. As the result - you are unable to deploy instances. The logs display
a problem with DhcpEntryCommand as Router VM is unreachable. The router VM does not receive
inbound communication, but outbound communication is fine.
The ping updates the ARP table with additional MAC entry of the gateway. We are ping the gateway
of CS host specifically - as this is the major needed source of communication. Once ARP table
is updated - communication works in both directions.  
Testing

Tested on 4.0, this is a very minimal and non impacting change that fixes deployment issue.
Bugs: CLOUDSTACK-599
Diffs

patches/systemvm/debian/config/etc/init.d/cloud-early-config (11380b4)
View Diff
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message