incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohit Yadav" <rohit.ya...@citrix.com>
Subject Re: Review Request: cleanup devcloud creation process
Date Sat, 15 Dec 2012 03:39:22 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/8399/#review14536
-----------------------------------------------------------


Pfew, took me few hours to test and fix few issues.                               
First of all I want to give you kudos for your work, Kudos!
That said, the patch fails on multiple cases. I'll commit that so we can continue working
on it.
I'm able to create a basebox but vagrant fails on xenbox. Pl. test it at your end also.
Will try to fix this issue, next week in free time.
                        
Here are some of my reviews and comments:                                          
                                                                                   
0. I moved all the stuff in tools/devcloud/src/ and fixed the README.md file for some of the
things which failed for me.          
1. Is there a way we can use the default vagrant release without having to use a fork?
2. VirtualBox 4.2 was not supported, can you or Chip help fix vagrant?             
                                                                                   
I did a workaround that worked for me:                                             
diff --git a/lib/vagrant/driver/virtualbox.rb b/lib/vagrant/driver/virtualbox.rb   
index baf462b..5a1dce2 100644                                                      
--- a/lib/vagrant/driver/virtualbox.rb                                             
+++ b/lib/vagrant/driver/virtualbox.rb                                             
@@ -44,7 +44,8 @@ module Vagrant                                                   
         @logger.debug("Finding driver for VirtualBox version: #{@version}")       
         driver_map   = {                                                          
           "4.0" => VirtualBox_4_0,                                                
-          "4.1" => VirtualBox_4_1                                                 
+          "4.1" => VirtualBox_4_1,                                                
+          "4.2" => VirtualBox_4_1,                                                
         }                                                                         
                                                                                   
         driver_klass = nil                                                        
                                                                                   
3. The default basebox has only one NIC, which fails as DevCloud needs to have     
two nics; first one should be the host-only one and second one should be the       
NAT.

- Rohit Yadav


On Dec. 8, 2012, 5:31 p.m., James Martin wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/8399/
> -----------------------------------------------------------
> 
> (Updated Dec. 8, 2012, 5:31 p.m.)
> 
> 
> Review request for cloudstack, Prasanna Santhanam and Rohit Yadav.
> 
> 
> Description
> -------
> 
> This diff cleans up the devcloud build process.
> 
> Please see tools/devcloud/README.md for more information.
> 
> I also have a fork of cloudstack available with this change:
> 
> https://github.com/jsmartin/incubator-cloudstack/tree/devcloud-cleanup
> 
> 
> Diffs
> -----
> 
> 
> Diff: https://reviews.apache.org/r/8399/diff/
> 
> 
> Testing
> -------
> 
> Built the veewee basebox and the vagrant xenbox.
> Built a cloudstack vagrant box.
> Was able to reach cloudstack at http://192.168.56.10:8080/client
> 
> 
> Thanks,
> 
> James Martin
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message