incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Moulliard <ch0...@gmail.com>
Subject Re: Can we still use DevCloud VM Image ?
Date Fri, 16 Nov 2012 13:38:49 GMT
The directory /usr/lib/cloud does not exist on my ubuntu - xen runinng in
virtualbox. So how can I launch this script
(/usr/lib/cloud/common/scripts/storage/secondary/cloud-install-sys-tmplt
-m /mnt/secondary -u
http://download.cloud.com/templates/acton/acton-systemvm-02062012.vhd.bz2-h
xenserver -s <optional-management-server-secret-key> -F) as mentioned
in
previous email ?


On Thu, Nov 15, 2012 at 3:29 PM, Rohit Yadav <rohit.yadav@citrix.com> wrote:

>
> On 15-Nov-2012, at 7:12 PM, Charles Moulliard <ch007m@gmail.com> wrote:
>
> > As of ubuntu-11 is configured use xen,
> >
> > "As of Ubuntu 11.10 (Oneiric), the default kernel included in Ubuntu can
> be
> > used directly with the Xen hypervisor as the management (or control)
> domain
> > (Dom0 or Domain0 in Xen terminology). "
> >
> > why don't you create an image using it ?
>
> Yes, I'm using this only. apt-get install xen-hypervisor and you're done.
> To use xen, one just need to select the kernel with xen during booting on
> grub.
> If you're keep, hack ~/.bash_history from the DevCloud image, the history
> will tell you what was performed to create devcloud.
>
> About pre-seeding systemvm template, see this:
>
> http://incubator.apache.org/cloudstack/docs/en-US/Apache_CloudStack/4.0.0-incubating/html/Installation_Guide/management-server-install-flow.html#prepare-system-vm-template
>
> You need to pre-seed, i.e. put a systemvm template on nfs with which your
> systemvm, cpvm and domr are created.
>
> Regards.
>
> >
> >
> > On Thu, Nov 15, 2012 at 12:08 PM, Rohit Yadav <rohit.yadav@citrix.com
> >wrote:
> >
> >>
> >> On 15-Nov-2012, at 2:10 PM, Charles Moulliard <ch007m@gmail.com> wrote:
> >>
> >>> Using VirtualBox R4.2.4 on MacOS 10.7.5  and the image (
> >>> http://bhaisaab.org/vms/ubuntu-12.04-x86-minimal-vm.tar.gz) that you
> >>> provide, the OS does not boot (screen stays black).
> >>
> >> Oh :(
> >> Will start with a new image today again. Will keep you posted.
> >>
> >>>
> >>>
> >>> On Thu, Nov 15, 2012 at 9:13 AM, Charles Moulliard <ch007m@gmail.com>
> >> wrote:
> >>>
> >>>> Many thanks. What do you mean by "*Preseed a systemvm template and you
> >>>> should be good to go. (2. is the tricky one)" ?*
> >>
> >> Yes, this one:
> >> 2. Configure network such that it's accessible to the host os and can
> >> access Internet,
> >>
> >>>> *I have started to create a google document to define step-by-step
> what
> >>>> do do.*
> >>
> >> Cool.
> >>
> >>>>
> >>>>
> >>>> On Wed, Nov 14, 2012 at 11:19 AM, Rohit Yadav <rohit.yadav@citrix.com
> >>> wrote:
> >>>>
> >>>>>
> >>>>> On 14-Nov-2012, at 3:23 PM, Charles Moulliard <ch007m@gmail.com>
> >> wrote:
> >>>>>
> >>>>>> Hi Rohit,
> >>>>>>
> >>>>>> Have you been able to finalize your work about creating a new
Ubuntu
> >>>>> image
> >>>>>> for VirtualBox. If this is not the case, can you share with
us
> >>>>> (document,
> >>>>>> ...) what you have done to configure Ubunttu (Installating MySQL,
> >>>>> Tomcat,
> >>>>>> ....) ?
> >>>>>
> >>>>> Hi Charles,
> >>>>>
> >>>>> Alright I'm back online, will work on releasing a devcloud image
> that I
> >>>>> hope would work out of the box, after some code monkey duties this
> >> week. In
> >>>>> the new image, mysql, tomcat, git etc. won't be installed on
> devcloud.
> >> The
> >>>>> idea is that you develop on your host os, debug with your fav. IDE
> and
> >> run
> >>>>> mgmt server, mysql, jetty/tomcat as well (if you want to do that
on
> >>>>> devcloud that too you can do). The default image will have only
the
> >>>>> preconfigured network, xen (kvm won't run as pv hypervisor, I knew
it
> >>>>> required hvm/intel-vt or amd-v, and I still tried just to see what
> >> happens
> >>>>> and it did not run) and nfs server.
> >>>>>
> >>>>> I've already shared the base os, which is x86 ubuntu precise
> >>>>> http://bhaisaab.org/vms/ubuntu-12.04-x86-minimal-vm.tar.gz (note:
> this
> >>>>> is not devcloud, just the base system which is stripped down and
> >> archived,
> >>>>> ~250MB) Till I do that, you may try to diy devcloud, the top level
> >> goals
> >>>>> are to: 1. Install xen, 2. Configure network such that it's
> accessible
> >> to
> >>>>> the host os and can access Internet, 3. Install and configure NFS,
4.
> >>>>> Preseed a systemvm template and you should be good to go. (2. is
the
> >> tricky
> >>>>> one)
> >>>>>
> >>>>> Just skip the following, something frivolous but for fun:
> >>>>> Around devcloud, I'm experimenting a lot (slow internet, plus every
> >> time
> >>>>> I mess I start from a fresh copy) so not able to produce a final
> >> image; you
> >>>>> may call me crazy for what I'm going to share next: so I've a
> >> raspberrypi
> >>>>> with me (a dirt cheap small single board arm 32bit computer, 4 GB
> >> sdcard,
> >>>>> 512MB ram etc., http://www.raspberrypi.org and we know devcloud
was
> >>>>> cloud in a box, I'm trying to see if I can create a devpi or
> basically
> >>>>> devcloud but in hardware and not as a vm, basically cloud in your
> >> pocket. I
> >>>>> installed debian wheezy on it and xen pv for arm (xen cloudplaform
> for
> >> arm,
> >>>>> this just blows up, even after cpvm disabled, ssvm etc. would just
> >> blow it
> >>>>> up), and this thing fails at the point when I restart it, also the
> >> default
> >>>>> sd card (it's storage, think hdd) is small (4GB) and the disk io
is
> >> very
> >>>>> small re-flashing it every time consumes a lot of my time, ordered
a
> >> 16GB
> >>>>> class10 sd card for better disk io, will keep you posted how this
> >>>>> experiment went, I've a gut feeling though this won't work given
the
> >>>>> resource constraints.
> >>>>>
> >>>>> Regards.
> >>>>>
> >>>>>>
> >>>>>> Regards,
> >>>>>>
> >>>>>> Charles
> >>>>>>
> >>>>>>
> >>>>>> On Sun, Nov 11, 2012 at 5:50 PM, Rohit Yadav <
> rohit.yadav@citrix.com>
> >>>>> wrote:
> >>>>>>
> >>>>>>> Not really, in my setup I want eth0 to be host-only which
is
> causing
> >>>>> some
> >>>>>>> issues; another problem is I'm making it x86 only, so I
see few
> >>>>> crashes.
> >>>>>>> Will update when I'm done.
> >>>>>>> ________________________________________
> >>>>>>> From: Charles Moulliard [ch007m@gmail.com]
> >>>>>>> Sent: Sunday, November 11, 2012 9:06 PM
> >>>>>>> To: cloudstack-dev
> >>>>>>> Subject: Re: Can we still use DevCloud VM Image ?
> >>>>>>>
> >>>>>>> Did you succeed it to fix the routing issues ?
> >>>>>>>
> >>>>>>>
> >>>>>>> On Sat, Nov 10, 2012 at 1:53 PM, Rohit Yadav <
> rohit.yadav@citrix.com
> >>>
> >>>>>>> wrote:
> >>>>>>>
> >>>>>>>> Hi Charles, it won't work as the vms inside host only
network can
> >> only
> >>>>>>>> access the host os and other vms on it. Therefore devcloud
inside
> >>>>>>> host-only
> >>>>>>>> network won't be able to reach the Internet.
> >>>>>>>> I'm actually trying to create a new devcloud image with
two
> network
> >>>>>>>> adapters, one NAT (eth1, so devcloud is able to reach
the
> Internet)
> >>>>> and
> >>>>>>> one
> >>>>>>>> host-only adapter (eth0, so we can run mgmt server etc.)
and it
> will
> >>>>> be
> >>>>>>>> only 300-350MB (archived). I was trying not the share
the image,
> >>>>> having
> >>>>>>>> some routing issues when I do that, will share as soon
I fix those
> >>>>>>> issues.
> >>>>>>>>
> >>>>>>>> --
> >>>>>>>> Rohit
> >>>>>>>> PS. the base system is ubuntu x86 precise and the untouched
> stripped
> >>>>> down
> >>>>>>>> vm is available here: http://bhaisaab.org/vms
> >>>>>>>> ________________________________________
> >>>>>>>> From: Charles Moulliard [ch007m@gmail.com]
> >>>>>>>> Sent: Saturday, November 10, 2012 4:46 PM
> >>>>>>>> To: cloudstack-dev
> >>>>>>>> Subject: Re: Can we still use DevCloud VM Image ?
> >>>>>>>>
> >>>>>>>> Hi,
> >>>>>>>>
> >>>>>>>> I have been able to setup the bridged adapter on virtualbox
to
> allow
> >>>>> the
> >>>>>>>> guest machine to get an IP address (from my DHCP server
runinng in
> >>>>> this
> >>>>>>> lan
> >>>>>>>> : 192.168.1x).
> >>>>>>>>
> >>>>>>>> The guest is configured like this :
> >>>>>>>>
> >>>>>>>> root@devcloud:/home/devcloud/download# more
> /etc/network/interfaces
> >>>>>>>> # The loopback network interface
> >>>>>>>> auto lo
> >>>>>>>> iface lo inet loopback
> >>>>>>>>
> >>>>>>>> # The primary network interface
> >>>>>>>> auto xenbr0
> >>>>>>>> iface xenbr0 inet static
> >>>>>>>>  gateway 192.168.56.1
> >>>>>>>>  address 192.168.56.2
> >>>>>>>>  netmask 255.255.255.0
> >>>>>>>>  bridge_ports eth0
> >>>>>>>>
> >>>>>>>> auto eth0
> >>>>>>>> iface eth0 inet static
> >>>>>>>>
> >>>>>>>> auto eth1
> >>>>>>>> iface eth1 inet dhcp
> >>>>>>>> ***********************************
> >>>>>>>> eth1      Link encap:Ethernet  HWaddr 08:00:27:df:00:00
> >>>>>>>>        inet addr:192.168.1.6  Bcast:192.168.1.255
> >>>>> Mask:255.255.255.0
> >>>>>>>>        inet6 addr: fe80::a00:27ff:fedf:0/64 Scope:Link
> >>>>>>>>        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
> >>>>>>>> xenbr0    Link encap:Ethernet  HWaddr 08:00:27:7e:74:9c
> >>>>>>>>        inet addr:192.168.56.2  Bcast:192.168.56.255
> >>>>>>> Mask:255.255.255.0
> >>>>>>>>        inet6 addr: fe80::a00:27ff:fe7e:749c/64 Scope:Link
> >>>>>>>>        UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
> >>>>>>>> *************************************
> >>>>>>>> ip route
> >>>>>>>> default via 192.168.56.1 dev xenbr0  metric 100
> >>>>>>>> 192.168.1.0/24 dev eth1  proto kernel  scope link  src
> 192.168.1.6
> >>>>>>>> 192.168.56.0/24 dev xenbr0  proto kernel  scope link
 src
> >>>>> 192.168.56.2
> >>>>>>>> **************************************
> >>>>>>>>
> >>>>>>>> Unfortunately, DNS resolution still does not work. Is
there
> >> something
> >>>>>>> else
> >>>>>>>> to do ?
> >>>>>>>>
> >>>>>>>> root@devcloud:/home/devcloud/download# wget
> >>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>
> http://be.mirror.eurid.eu/centos/6.3/isos/x86_64/CentOS-6.3-x86_64-minimal.iso
> >>>>>>>> --2012-11-10 03:11:46--
> >>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>
> http://be.mirror.eurid.eu/centos/6.3/isos/x86_64/CentOS-6.3-x86_64-minimal.iso
> >>>>>>>> Resolving be.mirror.eurid.eu (be.mirror.eurid.eu)...
failed:
> >>>>> Temporary
> >>>>>>>> failure in name resolution.
> >>>>>>>> wget: unable to resolve host address `be.mirror.eurid.eu'
> >>>>>>>>
> >>>>>>>> Regards,
> >>>>>>>>
> >>>>>>>> Charles
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> On Mon, Nov 5, 2012 at 7:33 PM, Edison Su <Edison.su@citrix.com>
> >>>>> wrote:
> >>>>>>>>
> >>>>>>>>> The latest devcloud vm using host-only-network(if
you follow the
> >>>>> steps
> >>>>>>> in
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>
> https://cwiki.apache.org/CLOUDSTACK/cloudstack-devcloud-environment-setup.html
> >>>>>>>> ),
> >>>>>>>>> which means, devcloud vm can't not access public
network, thus,
> >>>>>>> download
> >>>>>>>>> template/iso doesn't work.
> >>>>>>>>> To fix the issue:
> >>>>>>>>> 1. You can use "Bridged networking", plug devcloud
vm into the
> >>>>> network
> >>>>>>>>> used by your laptop. Need to change devcloud vm's
ip to the ip
> >>>>> address
> >>>>>>> in
> >>>>>>>>> your subnet. And also need to change tools/devcloud/devcloud.cfg
> >>>>>>>>> 2. Add a new network adaptor to devcloud vm, which
is plugged
> into
> >>>>>>>>> "Bridged networking". So devcloud vm will have two
nics, one is
> on
> >>>>>>>>> "host-only network", another one is on "bridge networking",
which
> >> can
> >>>>>>>>> access public network. Then add default route on
the bridge
> network
> >>>>>>> nic.
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> -----Original Message-----
> >>>>>>>>> From: Charles Moulliard [mailto:ch007m@gmail.com]
> >>>>>>>>> Sent: Sunday, November 04, 2012 11:34 PM
> >>>>>>>>> To: cloudstack-dev
> >>>>>>>>> Subject: Can we still use DevCloud VM Image ?
> >>>>>>>>>
> >>>>>>>>> Hi,
> >>>>>>>>>
> >>>>>>>>> Last tests with DevCloud VM (
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>
> https://cwiki.apache.org/CLOUDSTACK/cloudstack-devcloud-environment-setup.html
> >>>>>>>>> )
> >>>>>>>>> does not succeed on my Linux machine. Management
server works
> fine
> >>>>> like
> >>>>>>>>> also creation of tiny instances but there are issues
with NFS
> >> mount,
> >>>>>>> DNS
> >>>>>>>>> and of course to download  new ISO file (CentOs,
...). That was
> not
> >>>>> the
> >>>>>>>>> case a few days ago
> >>>>>>>>>
> >>>>>>>>> NFS & Primary/Secondary storage
> >>>>>>>>>
> >>>>>>>>> WARN  [network.element.VpcVirtualRouterElement]
(secstorage-1:)
> >>>>> Network
> >>>>>>>>> Ntwk[204|Guest|6] is not associated with any VPC
WARN
> >>>>>>>>> [network.element.VpcVirtualRouterElement] (consoleproxy-1:)
> Network
> >>>>>>>>> Ntwk[204|Guest|6] is not associated with any VPC
WARN
> >>>>>>>>> [network.element.VpcVirtualRouterElement] (secstorage-1:)
Network
> >>>>>>>>> Ntwk[202|Control|3] is not associated with any VPC
WARN
> >>>>>>>>> [network.element.VpcVirtualRouterElement] (consoleproxy-1:)
> Network
> >>>>>>>>> Ntwk[202|Control|3] is not associated with any VPC
WARN
> >>>>>>>>> [network.element.VpcVirtualRouterElement] (secstorage-1:)
Network
> >>>>>>>>> Ntwk[201|Management|2] is not associated with any
VPC WARN
> >>>>>>>>> [network.element.VpcVirtualRouterElement] (consoleproxy-1:)
> Network
> >>>>>>>>> Ntwk[201|Management|2] is not associated with any
VPC WARN
> >>>>>>>>> [network.element.VpcVirtualRouterElement] (secstorage-1:)
Network
> >>>>>>>>> Ntwk[203|Storage|4] is not associated with any VPC
WARN
> >>>>>>> [utils.nio.Link]
> >>>>>>>>> (AgentManager-Selector:) SSL: Fail to find the generated
> keystore.
> >>>>>>>> Loading
> >>>>>>>>> fail-safe one to continue.
> >>>>>>>>> WARN  [storage.download.DownloadListener] (Timer-4:)
Entering
> >>>>> download
> >>>>>>>>> error state: timeout waiting for response from storage
host,
> >>>>>>>>> template=centos.iso at host nfs://192.168.56.2:
> >>>>> /opt/storage/secondary
> >>>>>>>>>
> >>>>>>>>> DNS
> >>>>>>>>>
> >>>>>>>>> root@devcloud:/home/devcloud/download# wget
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>
> http://ftp.belnet.be/packages/centos/6.3/isos/x86_64/CentOS-6.3-x86_64-minimal.iso
> >>>>>>>>> --2012-11-04 23:17:41--
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>
> >>>>>
> >>
> http://ftp.belnet.be/packages/centos/6.3/isos/x86_64/CentOS-6.3-x86_64-minimal.iso
> >>>>>>>>> Resolving ftp.belnet.be (ftp.belnet.be)... failed:
Temporary
> >> failure
> >>>>>>> in
> >>>>>>>>> name resolution.
> >>>>>>>>> wget: unable to resolve host address `ftp.belnet.be'
> >>>>>>>>>
> >>>>>>>>>
> >>>>>>>>> Question : Is Devcloud VM image (
> >>>>>>>>> http://download.cloud.com/templates/devcloud/DevCloud.ova)
still
> >> up
> >>>>> to
> >>>>>>>>> date to work with Cloudstack 4.10-SNAPSHOT ?
> >>>>>>>>>
> >>>>>>>>> Regards,
> >>>>>>>>>
> >>>>>>>>> --
> >>>>>>>>> Charles Moulliard
> >>>>>>>>> Apache Committer / Sr. Enterprise Architect (RedHat)
Twitter :
> >>>>>>>> @cmoulliard
> >>>>>>>>> | Blog : http://cmoulliard.blogspot.com
> >>>>>>>>>
> >>>>>>>>
> >>>>>>>>
> >>>>>>>>
> >>>>>>>> --
> >>>>>>>> Charles Moulliard
> >>>>>>>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>>>>>>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>>
> >>>>>>> --
> >>>>>>> Charles Moulliard
> >>>>>>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>>>>>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>>>>>>
> >>>>>>
> >>>>>>
> >>>>>>
> >>>>>> --
> >>>>>> Charles Moulliard
> >>>>>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>>>>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>>>>
> >>>>>
> >>>>
> >>>>
> >>>> --
> >>>> Charles Moulliard
> >>>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>>>
> >>>>
> >>>>
> >>>
> >>>
> >>> --
> >>> Charles Moulliard
> >>> Apache Committer / Sr. Enterprise Architect (RedHat)
> >>> Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
> >>
> >>
> >
> >
> > --
> > Charles Moulliard
> > Apache Committer / Sr. Enterprise Architect (RedHat)
> > Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com
>
>


-- 
Charles Moulliard
Apache Committer / Sr. Enterprise Architect (RedHat)
Twitter : @cmoulliard | Blog : http://cmoulliard.blogspot.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message