incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@citrix.com>
Subject Re: back in the game, deploying to devcloud
Date Fri, 30 Nov 2012 00:12:44 GMT
Irrespective of whatever cloudstack version you're on, you don't have different workflows for
4.0 and asf master, just build, deploydb and run the mgmt server as you have on your laptop,
using the new devcloud image: http://people.apache.org/~bhaisaab/cloudstack/devcloud/devcloud2.ova

And make sure to set these global settings and restart mgmt server, before you deploy a basic
zone:

host = 192.168.56.1
system.vm.use.local.storage = true
management.network.cidr = 192.168.56.0/24
secstorage.allowed.internal.sites = 192.168.56.0/8

If you're want to build inside use host ip equal to 192.168.56.10. Checkout instructions on
working with ASF master and the new devcloud in the DevCloud 2.0 section: http://rohityadav.in/logs/devcloud/

Hope this helps,
Rohit

On 29-Nov-2012, at 3:54 PM, Prasanna Santhanam <tsp@apache.org> wrote:

> On Thu, Nov 29, 2012 at 06:43:29PM -0500, James Martin wrote:
>> Sorry folks, had to take a long hiatus from my cloudstack work, but
>> I'm back in the game and determined to get my devcloud work ready for
>> a patch and submitted.  Right now the problem I'm running into is
>> deploying the build:
>> 
>> mvn clean install -P developer -D skipTests ; ant build-all rdeploy
>> rdeploydb -Dport=7222
>> 
>> 
>> [sshexec]
>> [sshexec]
>> [sshexec] deploydb:
>> [sshexec]
>> [sshexec]
>> [sshexec] deploycddb:
>> [sshexec]
>> [sshexec]      [exec] failed to init cloudev
>> dbdeploy-db-clouddev.sh: line 20: clouddev.sql: No such file or
>> directory
>> 
> 
> Just wondering which image of devloud you were using. Rohit released
> a new Debian Wheezy based image recently which works against master.
> 
> Are you running this for 4.0?
> 
> 
> -- 
> Prasanna.,


Mime
View raw message