incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chip Childers <chip.child...@sungard.com>
Subject Re: [VOTE] Apache Cloudstack 4.0.0-incubating Release, third round
Date Sun, 28 Oct 2012 23:28:46 GMT
On Sun, Oct 28, 2012 at 12:48 PM, Noah Slater <nslater@apache.org> wrote:
> I was expecting a VM for the storage thing. But that never appeared. I did
> see a line for the VM I created. Either way, this testing step should
> indicate *clearly* what I should be looking for before moving on.

Done.

> As it stands, CloudStack itself is now refusing to answer HTTP requests, so
> I am unable to complete the configuration change step. I am close to giving
> up. This has been an incredibly frustrating experience.
>
> On 28 October 2012 16:45, Sebastien Goasguen <runseb@gmail.com> wrote:
>
>>
>> On Oct 28, 2012, at 4:41 PM, Noah Slater <nslater@apache.org> wrote:
>>
>> > Okay,
>> >
>> > I did a rebuild and the menu populated. Very strange.
>> >
>> > Now I have two more problems.
>> >
>> > From the test procedure:
>> >
>> > Wait for secondary storage VM coming up.
>> >> This may take a bit...
>> >
>> >
>> > No clue about this. How do I know when the storage VM has come up?
>>
>> In the Infrastructure tab, do you see system VMs in running state ?
>> Check my video for help :)
>> https://vimeo.com/52150218
>>
>> PS: I ran the testing procedure on my mac air, and it was exceptionally
>> fast. I was amazed.
>>
>>
>> >
>> > I checked under instances and storage and nothing changed for about 10
>> > minutes.
>> >
>> > Last three lines in console are:
>> >
>> >  [sshexec]      [java] WARN  [network.element.VpcVirtualRouterElement]
>> > (secstorage-1:) Network Ntwk[203|Storage|4] is not associated with any
>> VPC
>> >  [sshexec]      [java] INFO  [network.security.SecurityGroupListener]
>> > (AgentManager-Handler-2:) Received a host startup notification
>> >  [sshexec]      [java] INFO  [cloud.consoleproxy.ConsoleProxyManagerImpl]
>> > (AgentManager-Handler-2:) Successfully sent out command to start HTTP
>> > handling in console proxy agent
>> >
>> > I decided to proceed to the next stage, on the off chance it had worked.
>> >
>> > I get stuck on this step:
>> >
>> > In step 2, select "tiny Linux"
>> >
>> >
>> > There are no templates to select from!
>> >
>> >
>> https://www.evernote.com/shard/s18/sh/1a151896-8cbb-41c8-93d2-d844e6461146/08efa5dddbd86cb96d7895692f9ec20d
>> >
>> https://www.evernote.com/shard/s18/sh/ee10c37e-dad1-454f-a43f-e64d9ef7d9e3/bce4465e03169a3883f825fbb6f43cd1
>> >
>> https://www.evernote.com/shard/s18/sh/58221024-608f-4a7f-9531-53c267532efc/cbdb8204c77471ae2fa194355af40430
>> >
>> > I am unable to proceed.
>> >
>> > P.S. Testing CloudStack on my MBA is exceptionally slow. Is there any way
>> > to do the whole thing on or something? I practically cannot do anything
>> > else on my computer while testing.
>> >
>> > On 28 October 2012 00:12, Chip Childers <chip.childers@sungard.com>
>> wrote:
>> >
>> >> Yeah.  Funny enough, that IS the infra menu option.
>> >>
>> >> I've never seen this before.
>> >>
>> >> I assume you are logged in as admin / password?  Can you do a fresh
>> >> build (start with "ant clean-all build-all")?
>> >>
>> >> - chip
>> >>
>> >> Sent from my iPhone.
>> >>
>> >> On Oct 27, 2012, at 5:06 PM, Noah Slater <nslater@apache.org> wrote:
>> >>
>> >>> I doubt it. Looks like part of the application code.
>> >>>
>> >>> My real problem is that I am unable to complete this step, as there
is
>> >>> nothing labeled "Infrastructure" in the UI.
>> >>>
>> >>> On 27 October 2012 19:04, Chip Childers <chip.childers@sungard.com>
>> >> wrote:
>> >>>
>> >>>> Comments below:
>> >>>>
>> >>>> - chip
>> >>>>
>> >>>> Sent from my iPhone.
>> >>>>
>> >>>> On Oct 27, 2012, at 1:28 PM, Noah Slater <nslater@apache.org>
wrote:
>> >>>>
>> >>>>> Sig: OK
>> >>>>> Hashes: OK
>> >>>>> Source checks: OK
>> >>>>> RAT: OK
>> >>>>> Build: OK
>> >>>>>
>> >>>>> However, during this:
>> >>>>>
>> >>>>> mvn -P deps
>> >>>>>
>> >>>>> I noticed line like this:
>> >>>>>
>> >>>>> [INFO] Installing
>> >>>>>>
>> /private/tmp/cloudstack/apache-cloudstack-4.0.0-incubating-src/pom.xml
>> >>>> to
>> >>>>
>> >>
>> /Users/nslater/.m2/repository/org/apache/cloudstack/cloudstack/4.0.0-incubating-SNAPSHOT/cloudstack-4.0.0-incubating-SNAPSHOT.pom
>> >>>>>> [INFO]
>> >>>>>>
>> >>>>>> [INFO]
>> >>>>>>
>> >> ------------------------------------------------------------------------
>> >>>>>> [INFO] Building Apache CloudStack Utils 4.0.0-incubating-SNAPSHOT
>> >>>>>> [INFO]
>> >>>>>>
>> >> ------------------------------------------------------------------------
>> >>>>>
>> >>>>>
>> >>>>> Any idea why that says incubating-SNAPSHOT?
>> >>>>
>> >>>> That's the default build version. If we do a binary release, it
would
>> >>>> be changed via the maven release tools.
>> >>>>
>> >>>>>
>> >>>>> A bigger problem is that I am stuck with the additional testing.
>> >>>>>
>> >>>>> Specifically, this step:
>> >>>>>
>> >>>>> Click "Infrastructure", click the "View All" button in the "Zones"
>> >>>> display
>> >>>>>> box, click "add zone"
>> >>>>>
>> >>>>>
>> >>>>> Here's what my console looks like:
>> >>>>
>> >>
>> https://www.evernote.com/shard/s18/sh/4df76607-12ea-42d6-b73a-ff36a9435d7b/510f4a49695062e03aa03fa45d32ad82
>> >>>>>
>> >>>>> Note the oddly unlabelled cloud icon, which when clicked, displays:
>> >>>>
>> >>
>> https://www.evernote.com/shard/s18/sh/95042d8c-06fa-4c56-8f89-e9b4bc2b80a4/f1b06913bdb8a327cf1c554f88899380
>> >>>>>
>> >>>>> I would like to be able to complete this testing, but would
be
>> prepared
>> >>>> to
>> >>>>> vote without it.
>> >>>>>
>> >>>>> Can someone help me?
>> >>>>
>> >>>> Browser specific issue?  Is it consistent?
>> >>>>
>> >>>>>
>> >>>>> thanks,
>> >>>>>
>> >>>>> --
>> >>>>> NS
>> >>>
>> >>>
>> >>>
>> >>> --
>> >>> NS
>> >>
>> >
>> >
>> >
>> > --
>> > NS
>>
>>
>
>
> --
> NS

Mime
View raw message