incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bilal Malik <bma...@paloaltonetworks.com>
Subject [Newbie question] unable to mvn -P vmware install
Date Fri, 26 Oct 2012 23:56:56 GMT

Hi guys,
I have followed the instructions from
https://cwiki.apache.org/CLOUDSTACK/building-with-maven.html

I am completely new to the cloudstack development and trying to get the dev environment setup
to be able to build cloud stack and also build it for vmware.

mvn clean ; mvn install ; mvn -P developer install works just fine for me

But
after i copied the vim.jar, vim25.jar and app-utils.jar to /deps/ folder then i ran ./install-non-oss.sh
everything I thought I needed to do for vmware was done.
then when i ran mvn -P vmware install I get the following error

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.5.1:compile
(default-compile) on project cloud-vmware-base: Compilation failure
[ERROR] /home/bmalik/incubator-cloudstack/vmware-base/src/com/cloud/hypervisor/vmware/mo/HostMO.java:[746,16]
cannot access org.apache.axis.AxisFault
[ERROR] class file for org.apache.axis.AxisFault not found
[ERROR] try {
[ERROR] -> [Help 1]

Looks like it is looking for Axis jars and I am not quite sure where to make it into the class
path.  I have CLASSPATH variable defined in my .bashrc like
export M2_HOME=/usr/local/maven
export PATH=${M2_HOME}/bin:$PATH
export CATALINA_HOME=/usr/share/tomcat6
export CATALINA_BASE=/usr/share/tomcat6
export JAVA_HOME=/usr/java/default
export PATH=$PATH:$JAVA_HOME/bin
export CLASSPATH=$JAVA_HOME/jre/lib:$JAVA_HOME/lib:$JAVA_HOME/lib/tools.jar:/home/bmalik/axis2-1.6.2/lib/*

any help would be really really appreciated.

Thanks


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message