incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sailaja Mada (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CLOUDSTACK-257) AWS Api is not correctly deployed
Date Sun, 07 Oct 2012 10:08:02 GMT

    [ https://issues.apache.org/jira/browse/CLOUDSTACK-257?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13471169#comment-13471169
] 

Sailaja Mada edited comment on CLOUDSTACK-257 at 10/7/12 10:07 AM:
-------------------------------------------------------------------

Regressed  using the build @ http://jenkins.cloudstack.org/job/build-4.0-nonoss-rhel63/lastSuccessfulBuild/artifact/CloudStack-non-OSS-79.tar.bz2
 to regress the bug https://issues.apache.org/jira/browse/CLOUDSTACK-257 .
 
Still getting the same error as reported in the bug. 
 
[root@rhel63 /]# cloudstack-aws-api-register --apikey=_TBTS00OHn_V0EdMIwhhqL8IXxzuk4JANl77cgguXqd4vSWvq4FJ-Ib0KgQSWiJgvWyTibKcwhMsUyTSrmJWwQ
--secretkey=mePVMlP4gJfWacYGXuGXZQvByvUmKciiu_ZRc9s55zXSS_1_2QUabIUbgOMBBVV3wPg_a-r_BWWsFypu53br4A
--cert=/path/to/cert.pem --url=http://10.102.125.239:7080/awsapi
User registration failed with http error code: 400
 
Awsapi.log does not have anything logged.  Hence reopening the defect.  Steps are followed
as per documentation. 

Few more observations :  

1.	Webapp7080 folder is available 

[root@rhel63 bridge]# pwd
/usr/share/cloud/bridge
[root@rhel63 bridge]# ls
conf  webapps7080

2.	7080 port Is in listening state .
3.	
[root@rhel63 bridge]# netstat -na | grep -i 7080
tcp        0      0 :::7080                     :::*                        LISTEN





                
      was (Author: sailaja):
    Regressed  using the build @ http://jenkins.cloudstack.org/job/build-4.0-nonoss-rhel63/lastSuccessfulBuild/artifact/CloudStack-non-OSS-79.tar.bz2
 to regress the bug https://issues.apache.org/jira/browse/CLOUDSTACK-257 .
 
Still getting the same error as reported in the bug. 
 
[root@rhel63 /]# cloudstack-aws-api-register --apikey=_TBTS00OHn_V0EdMIwhhqL8IXxzuk4JANl77cgguXqd4vSWvq4FJ-Ib0KgQSWiJgvWyTibKcwhMsUyTSrmJWwQ
--secretkey=mePVMlP4gJfWacYGXuGXZQvByvUmKciiu_ZRc9s55zXSS_1_2QUabIUbgOMBBVV3wPg_a-r_BWWsFypu53br4A
--cert=/path/to/cert.pem --url=http://10.102.125.239:7080/awsapi
User registration failed with http error code: 400
 
Awsapi.log does not have anything logged.  Hence reopening the defect.  Steps are followed
as per documentation. 

                  
> AWS Api is not correctly deployed
> ---------------------------------
>
>                 Key: CLOUDSTACK-257
>                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-257
>             Project: CloudStack
>          Issue Type: Bug
>          Components: AWSAPI
>    Affects Versions: pre-4.0.0
>         Environment: Centos 6.3
> non-oss build 60
>            Reporter: Pedro Navarro PĂ©rez
>            Assignee: Likitha Shetty
>            Priority: Blocker
>             Fix For: 4.0.0
>
>         Attachments: api-server.log, management-server.log
>
>
> 1. Fresh install
> 2. Enable the EC2 service via global configuration settings
> 3. Generate API keys for the user
> 4. Call cloudstack-aws-api-register with the input parameters.
> Error User registration failed with http error code: 400

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message