incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rohit Yadav (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-343) Document what tools and packages are required to build, package and install CloudStack 4.0
Date Sun, 14 Oct 2012 16:25:02 GMT
Rohit Yadav created CLOUDSTACK-343:
--------------------------------------

             Summary: Document what tools and packages are required to build, package and
install CloudStack 4.0
                 Key: CLOUDSTACK-343
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-343
             Project: CloudStack
          Issue Type: Bug
          Components: Install and Setup
    Affects Versions: 4.0.0
            Reporter: Rohit Yadav
             Fix For: 4.0.0


For debian building we need to do: [1][2]
sudo aptitude install openjdk-6-jdk ant python python-setuptools python-software-properties
sudo add-apt-repository ppa:natecarlson/maven3
sudo aptitude update
sudo aptitude install maven3

For debian packaging make sure you've following preinstalled: [1][2]
sudo apt-get install dpkg-dev debhelper tomcat6 libws-commons-util-java python-mysqldb

For installation via install.sh, install.sh assumes aptitude preinstalled:[2]
sudo apt-get install aptitude

[0] https://cwiki.apache.org/confluence/display/CLOUDSTACK/Building#Building-Packaging
[1] https://cwiki.apache.org/confluence/display/CLOUDSTACK/CloudStack+4.0+test+procedure

Pl. verify and do the same for RHEL.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message