incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Kinsella <...@stratosec.co>
Subject Re: May I know why is the "cloud-sccs" Information no longer available
Date Sun, 14 Oct 2012 01:14:37 GMT
Probably related - when I run "./waf install" on a clean source tree, I get…

"Unable to install the file 'sccs-info' (not found in dir:///usr/src/apache-cloudstack-4.0.0-incubating-src)"

The file's getting created - if I run the same cmd a second time everything's OK.

John

On Oct 13, 2012, at 6:04 PM, Chip Childers <chip.childers@sungard.com>
 wrote:

> On Sat, Oct 13, 2012 at 7:42 PM, Chandan Purushothama
> <Chandan.Purushothama@citrix.com> wrote:
>> Hello,
>> 
>> On the latest build http://jenkins.cloudstack.org/job/build-4.0-ubuntu1204/lastSuccessfulBuild/artifact/CloudStack-oss-4.0.0-524.tar.bz2.
I observed that I can no longer use "cloud-sccs" to obtain the git commit id Information of
the build used. I observed that the sccs-info file under /user/share/doc/cloud/ has been replaced
with version-info file. Version-info file has the ASF License and Implementation_Version Information
(looks like the timestamp of the build creation). May I know whether the git commit information
has been intentionally removed from the location. If Yes, May I know how will I be able to
figure out whether the build used has a particular commit id ? Kindly let me know.
>> 
>> The following is what I see on my management server:
>> 
>> asf@Rack3Host11:/opt/cloud/CloudStack-oss-4.0.0-524$ cloud-sccs
>> error: SCCS info file '/usr/share/doc/cloud/sccs-info' cannot be found
>> asf@Rack3Host11:/opt/cloud/CloudStack-oss-4.0.0-524$ sudo cloud-sccs
>> error: SCCS info file '/usr/share/doc/cloud/sccs-info' cannot be found
>> asf@Rack3Host11:/opt/cloud/CloudStack-oss-4.0.0-524$ sudo su
>> root@Rack3Host11:/opt/cloud/CloudStack-oss-4.0.0-524# cloud-sccs
>> error: SCCS info file '/usr/share/doc/cloud/sccs-info' cannot be found
>> root@Rack3Host11:/opt/cloud/CloudStack-oss-4.0.0-524# cd /usr/share/doc/cloud
>> cloud/            cloud-client/     cloud-core/       cloud-python/     cloud-server/
    cloud-system-iso/
>> cloud-awsapi/     cloud-client-ui/  cloud-deps/       cloud-scripts/    cloud-setup/
     cloud-utils/
>> root@Rack3Host11:/opt/cloud/CloudStack-oss-4.0.0-524# cd /usr/share/doc/cloud/
>> root@Rack3Host11:/usr/share/doc/cloud# ls
>> version-info
>> root@Rack3Host11:/usr/share/doc/cloud# vim version-info
>> root@Rack3Host11:/usr/share/doc/cloud#
>> 
>> Thank you,
>> Chandan.
> 
> David had to remove that, due to CLOUDSTACK-329.  Building from a
> non-git cloned copy is a requirement for the source distribution.
> 
> -chip
> 

Stratosec - Secure Infrastructure as a Service
o: 415.315.9385
@johnlkinsella


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message