incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "prashant kumar mishra (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-298) putting host in maintenance mode while creating snapshot ,host resorce state stuck in "ErrorInMaintenance mode" and snapshot creation fail Unable to migrate due to Requested operation is not valid: cannot migrate domain with 1 snapshots
Date Tue, 09 Oct 2012 08:16:02 GMT
prashant kumar mishra created CLOUDSTACK-298:
------------------------------------------------

             Summary: putting host in maintenance mode while creating snapshot ,host resorce
state stuck in "ErrorInMaintenance mode" and snapshot creation fail  Unable to migrate due
to Requested operation is not valid: cannot migrate domain with 1 snapshots
                 Key: CLOUDSTACK-298
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-298
             Project: CloudStack
          Issue Type: Bug
          Components: KVM
    Affects Versions: pre-4.0.0
         Environment: MS Rhl6.3
KVM(Rhl6.3)

Git Revision: fb88d2e9de795528e8b9f7e16d8a89eacc5a7e12
Git URL: https://git-wip-us.apache.org/repos/asf/incubator-cloudstack.git

            Reporter: prashant kumar mishra
            Priority: Critical


while creating snapshot put host 1 in maintenance mode , snapshot creation fails and host
resource state stuck in "ErrorInMaintenance" mode.

STEPS TO REPRODUCE
-------------------------------------
-------------------------------------
1-Create advance zone->add pod->cluster->add 1 KVM host.
2-Create ha enable service offering
3-Deploy a VM using service offering(you have created in step 2)
4-Add another KVM host in same cluster which you have created in step 1
5-Click button create a snapshot from root volume
6-While step 5 is in progress put 1st host in maintenance mode 

EXPECTED RESULT
---------------------------------
---------------------------------
1-Snapshot should backed up successfully and host should go in maintenance mode


ACTUAL RESULT
--------------------------------
------------------------------- 
1-Snapshot creation failed
2- Host resource sate stuck in   ErrorInmaintenance mode

MY OBSERVATION
------------------------------
------------------------------
1-Snapshot creation happening properly if you put host in maintenance mode which is not hosting
any vms
2- Without any maintenance activity snapshot creation is happening properly
3-Migration is happening properly without any snapshot activity

LOG
------------------
-----------------
  2012-10-09 12:45:56,505 DEBUG [agent.transport.Request] (AgentManager-Handler-5:null) Seq
8-806223881: Processing:  { Ans: , MgmtId: 7036532162601, via: 8, Ver: v1, Flags: 10, [{"BackupSnapshotAnswer":{"full":true,"result":false,"details":"Failed
to backup snapshot: qemu-img: Could not delete snapshot 'hatest_ROOT-8_20121009071100': -2
(No such file or directory)Failed to delete snapshot hatest_ROOT-8_20121009071100 for path
/mnt/59119a1e-adb2-32b7-9567-e4d52693e43c/b1f6f0f6-01cf-48f3-bb8c-6c82fa454c2a","wait":0}}]
}
2012-10-09 12:45:56,505 DEBUG [agent.transport.Request] (Job-Executor-1:job-148) Seq 8-806223881:
Received:  { Ans: , MgmtId: 7036532162601, via: 8, Ver: v1, Flags: 10, { BackupSnapshotAnswer
} }
2012-10-09 12:45:56,505 DEBUG [storage.snapshot.SnapshotManagerImpl] (Job-Executor-1:job-148)
The result for com.cloud.agent.api.BackupSnapshotCommand is Failed to backup snapshot: qemu-img:
Could not delete snapshot 'hatest_ROOT-8_20121009071100': -2 (No such file or directory)Failed
to delete snapshot hatest_ROOT-8_20121009071100 for path /mnt/59119a1e-adb2-32b7-9567-e4d52693e43c/b1f6f0f6-01cf-48f3-bb8c-6c82fa454c2a
through 8
2012-10-09 12:45:59,187 DEBUG [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
Zone 1 is ready to launch secondary storage VM
2012-10-09 12:45:59,329 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null)
Zone 1 is ready to launch console proxy
2012-10-09 12:45:59,947 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 1 routers. 
2012

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message