incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chiradeep Vittal <Chiradeep.Vit...@citrix.com>
Subject Re: error building devcloud: ClassCastException: com.cloud.agent.api.Answer
Date Fri, 28 Sep 2012 00:29:52 GMT
Did you try
ant build-apidocs
 cd tools/marvin/marvin

python deployDataCenter.py


On 9/27/12 5:24 PM, "James Martin" <jmartin@basho.com> wrote:

>Sebastien,
>
>It seems deployDataCenter.py is dependent on cloudstackAPI
>
>
>python 
>$HOME/work/code/cloudstack/cloudstack/tools/marvin/marvin/deployDataCenter
>.py
>-i devcloud.cfg Traceback (most recent call last):
>  File 
>"/Users/jmartin/work/code/cloudstack/cloudstack/tools/marvin/marvin/deploy
>DataCenter.py",
>line 19, in <module>
>    import configGenerator
>  File 
>"/Users/jmartin/work/code/cloudstack/cloudstack/tools/marvin/marvin/config
>Generator.py",
>line 21, in <module>
>    import jsonHelper
>  File 
>"/Users/jmartin/work/code/cloudstack/cloudstack/tools/marvin/marvin/jsonHe
>lper.py",
>line 21, in <module>
>    from cloudstackAPI import *
>ImportError: No module named cloudstackAPI
>
>
>I've also tried this method:
>
>python -m marvin.deployDataCenter -i devcloud.cfg
>Traceback (most recent call last):
>  File 
>"/Users/jmartin/.homebrew/Cellar/python/2.7.3/Frameworks/Python.framework/
>Versions/2.7/lib/python2.7/runpy.py",
>line 162, in _run_module_as_main
>    "__main__", fname, loader, pkg_name)
>  File 
>"/Users/jmartin/.homebrew/Cellar/python/2.7.3/Frameworks/Python.framework/
>Versions/2.7/lib/python2.7/runpy.py",
>line 72, in _run_code
>    exec code in run_globals
>  File 
>"/Users/jmartin/.homebrew/lib/python2.7/site-packages/marvin/deployDataCen
>ter.py",
>line 430, in <module>
>    deploy.deploy()
>  File 
>"/Users/jmartin/.homebrew/lib/python2.7/site-packages/marvin/deployDataCen
>ter.py",
>line 414, in deploy
>    self.createZones(self.config.zones)
>  File 
>"/Users/jmartin/.homebrew/lib/python2.7/site-packages/marvin/deployDataCen
>ter.py",
>line 287, in createZones
>    zoneId = zoneresponse.id
>AttributeError: 'NoneType' object has no attribute 'id'
>
>
>Thanks,
>
>James
>
>On Thu, Sep 27, 2012 at 5:05 PM, Sebastien Goasguen <runseb@gmail.com>
>wrote:
>> Hi James,
>>
>> if you build marvin (ant build-marvin) on your host, you should be able
>>to do:
>>
>> python /path/to/src/tools/marvin/marvin/deployDataCenter.py -i
>>devcloud.cfg
>>
>> This will talk to your Vbox vm where you are setting up devcloud.
>>Assuming you set it up on localhost with port forwarding 8096 and 3306.
>>
>> marvin requires pymysql , installable from easy_install
>>
>> I think the .cfg file that's in there is buggy, but I can patch.
>>
>> Let me know if that brings you closer.
>>
>> -sebastien
>>
>>
>> On Sep 27, 2012, at 7:42 PM, James Martin <jmartin@basho.com> wrote:
>>
>>> Sebastien,
>>>
>>> Sorry, let me give a better example.  I'm trying to run a script that
>>> will provide an initial configuration of cloudstack so I don't have to
>>> go through the initial wizard on a fresh install.  I see the
>>> devcloud.cfg  & marvin you are mentioning, but I can't figure out how
>>> it is suppose to be used to configure a fresh install.
>>>
>>>
>>> James
>>>
>>> On Thu, Sep 27, 2012 at 7:46 AM, Sebastien Goasguen <runseb@gmail.com>
>>>wrote:
>>>> Hi James,
>>>>
>>>> What do you mean by "populate" ? adding a host ?
>>>>
>>>> If that's the case, I believe the thinking was to use marvin
>>>>(/tools/marvin) deployDataCenter and use the devcloud.cfg file that's
>>>>in the devcloud dir to setup the db/zones/pods etc of devcloud.
>>>>
>>>> -Sebastien
>>>>
>>>> On Sep 27, 2012, at 1:02 AM, James Martin <jmartin@basho.com> wrote:
>>>>
>>>>> I'm using the cs-bootstrap-s3.py script to populate a  working
>>>>> devcloud instance:
>>>>>
>>>>> during the run of the script I get the error:
>>>>>
>>>>> urllib2.HTTPError: HTTP Error 530: Cannot transit agent status with
>>>>> event AgentDisconnected for host 1, mangement server id is
>>>>> 8796761548538,Unable to transition to a new state from Creating via
>>>>> AgentDisconnected
>>>>>
>>>>>
>>>>> in the in the $CATALINA_HOME/bin/vmops.log it seems to correlate to :
>>>>>
>>>>>
>>>>> 2012-09-26 22:25:08,989 WARN  [cloud.resource.ResourceManagerImpl]
>>>>> (AgentTaskPool-1:null) Unable to connect due to
>>>>> com.cloud.utils.exception.CloudRuntimeException: Unable to connect 1
>>>>>       at 
>>>>>com.cloud.agent.manager.AgentManagerImpl.notifyMonitorsOfConnection(Ag
>>>>>entManagerImpl.java:624)
>>>>>       at 
>>>>>com.cloud.agent.manager.AgentManagerImpl.handleDirectConnectAgent(Agen
>>>>>tManagerImpl.java:1500)
>>>>>       at 
>>>>>com.cloud.resource.ResourceManagerImpl.createHostAndAgent(ResourceMana
>>>>>gerImpl.java:1631)
>>>>>       at 
>>>>>com.cloud.resource.ResourceManagerImpl.createHostAndAgent(ResourceMana
>>>>>gerImpl.java:1668)
>>>>>       at 
>>>>>com.cloud.agent.manager.AgentManagerImpl$SimulateStartTask.run(AgentMa
>>>>>nagerImpl.java:1195)
>>>>>       at 
>>>>>java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.j
>>>>>ava:1110)
>>>>>       at 
>>>>>java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
>>>>>java:603)
>>>>>       at java.lang.Thread.run(Thread.java:679)
>>>>> Caused by: java.lang.ClassCastException: com.cloud.agent.api.Answer
>>>>> cannot be cast to com.cloud.agent.api.SetupAnswer
>>>>>       at 
>>>>>com.cloud.hypervisor.xen.discoverer.XcpServerDiscoverer.processConnect
>>>>>(XcpServerDiscoverer.java:634)
>>>>>       at 
>>>>>com.cloud.agent.manager.AgentManagerImpl.notifyMonitorsOfConnection(Ag
>>>>>entManagerImpl.java:605)
>>>>>       ... 7 more
>>>>>
>>>>>
>>>>>
>>>>> Can anyone provide insight here?
>>>>>
>>>>> Thanks,
>>>>>
>>>>> James
>>>>
>>


Mime
View raw message