incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ahmad Emneina <Ahmad.Emne...@citrix.com>
Subject Re: Problem with VM private IP
Date Tue, 25 Sep 2012 03:01:09 GMT
Have you looked at the Administration Guide[1]? See page 75 and see if
that solves your connectivity issue. You still need to poke the hole in
the firewal and setup a NAT rule from within cloudstack.

[1]: http://download.cloud.com/releases/3.0.0/CloudStack3.0AdminGuide.pdf

On 9/24/12 7:56 PM, "Hieu Le" <hieulq89@gmail.com> wrote:

>Hi,
>
>The telnet packets are not reaching the telnet server VM.
>
>I'm using CS 3.0.2.
>
>Thanks for replying !
>
>On Mon, Sep 24, 2012 at 5:52 PM, Jayapal Reddy Uradi <
>jayapalreddy.uradi@citrix.com> wrote:
>
>> Using firewall and port forwarding rules only  we can access the VM
>> services from the public network also from the VMs using the Public IPs.
>> For you  telnet from outside network success but from failed from VM to
>>VM
>> using public IP.
>> Seems hair pin NAT  got failed ...
>>
>> Please capture the packets on the telnet server VM to see whether telnet
>> packets are reaching or not ?
>>
>> Which version of cloudstack Is it ?
>>
>> Thanks,
>> Jayapal
>>
>> -----Original Message-----
>> From: Hieu Le [mailto:hieulq89@gmail.com]
>> Sent: Monday, September 24, 2012 3:39 PM
>> To: cloudstack-dev@incubator.apache.org
>> Subject: Problem with VM private IP
>>
>> Hi everyone,
>>
>> I have a problem while working with VM private IP. My Cloud system run 2
>> VMs in advance zone with private IP is 10.1.1.20 and 10.1.1.21 and VM
>>NAT
>> IP is 192.168.50.160 and 192.168.50.165. From outside network, I can
>>ping
>> and telnet port 80 to both VMs with public IPs. But from VM 10.1.1.21, I
>> can't telnet to other VM with its public IP.
>>
>> For details:
>> From VM1: 10.1.1.20 and 192.168.50.160.
>> ping 192.168.50.165 and ping 10.1.1.21 success telnet 10.1.1.21 80
>>success
>> telnet 192.168.50.165 80 fail
>>
>> From VM2: 10.1.1.21 and 192.168.50.165
>> ping 192.168.50.160 and ping 10.1.1.20 success telnet 10.1.1.20 success
>> telnet 192.168.50.160 80 fail
>>
>> And I can't telnet another ports with public IP.
>>
>> Can you suggest some solutions for me to telnet VM from another VM via
>> public IP.
>>
>> Thank !
>>
>
>
>
>-- 
>..:: Hieu LE ::..
>
>Class: Information System - Course 52
>School of Information and Communication Technology
>Hanoi University of Technology
>No 1, Dai Co Viet street - Hai Ba Trung district - Hanoi
>
>High Performance Computing Center
>Cloud Computing Group
>Gmail: hieulq89@gmail.com
>


-- 
Æ




Mime
View raw message