incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Busy Dev <busyd...@gmail.com>
Subject Re: Need help with deployment of agent
Date Thu, 13 Sep 2012 14:57:24 GMT
Thanks Prana.

I am using KVM on Ubuntu 12.04 (I also use CentOS 6.3)



On Thu, Sep 13, 2012 at 10:53 AM, Pranav Saxena <pranav.saxena@citrix.com>wrote:

> Hi ,
>
> Few of the points I would like to make you aware of -
>
> - You should be using asf/master to clone the repository and not 3.0.x
> since 3.0.x is almost a dead branch.
> - You would have to use maven to deploy  ( guidelines here -
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Building+with+Maven)
> - You could use the cloudstack dev ML for your issues. ( like you have
> done this time ) . Also you could consider having a look here as well -
> http://incubator.apache.org/cloudstack/develop/environment.html
>
> You could try doing a fresh installation by following the steps here -
> https://cwiki.apache.org/CLOUDSTACK/
>
> Also could you please tell , which hypervisor are you using ?
>
> Thanks & Regards,
> Pranav
>
> -----Original Message-----
> From: Busy Dev [mailto:busydev6@gmail.com]
> Sent: Thursday, September 13, 2012 7:15 PM
> To: cloudstack-dev
> Subject: Need help with deployment of agent
>
> Hi,
>
> I followed the instructions
> here<
> http://docs.cloudstack.org/Knowledge_Base/How_to_set_up_a_CloudStack_development_environment
> >to
> setup my dev environment.  I am able to build the 3.0.x branch and
> deployed it locally using "ant deploy-server", "ant deploydb" and "ant
> debug".  However, when I try to "launch" Cloudstack (after going through
> the wizard), the launch fails because the "cloud-setup-agent" command could
> not be found (this is from the vmops.log file).
>
> My questions are:
>
> 1. Can you deploy both server and agent on the same machine?
> 2. How do I "ant deploy-agent"?
> 3. Should I be using "master" instead of "3.0.x" branch? Maybe the "4.0"
> branch?
> 4. If I use master, then I need to use maven - how do you deploy using
> maven?
> 5. Is there a central resource already has answers for these types of
> "newbie" questions?
>
> Thanks for your patience and help.
>
> busydev!
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message