incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Busy Dev <busyd...@gmail.com>
Subject Re: Cannot import template - issue with secondary storage VM
Date Sat, 22 Sep 2012 05:05:59 GMT
Thanks. I'm trying it now.

On Sat, Sep 22, 2012 at 12:48 AM, Marcus Sorensen <shadowsor@gmail.com>wrote:

> will probably be /usr/lib64/cloud/common/vms/systemvm.iso or
> /usr/lib/cloud/common/vms/systemvm.iso
>
> On Fri, Sep 21, 2012 at 10:47 PM, Marcus Sorensen <shadowsor@gmail.com>
> wrote:
> > If you can't ssh in, then nothing will work since that's how the
> > system vms are controlled.  This is likely due to a recent change that
> > moved the system vm iso file. If the systemvm iso isn't mounted then
> > the authorized keys file is never copied into /root/.ssh on the system
> > vm. All of this assumes you're running the early release 4.0 stuff.
> >
> >  I did some troubleshooting on it yesterday and a fix is in master. In
> > the mean time, find the location of your systemvm.iso file and set in
> > your /etc/cloud/agent/agent.properties as systemvm.iso.path=<full
> > location of file>
> > Then restart the agent, and restart the system vms. Let me know if
> > that's not the problem.
> >
> > On Fri, Sep 21, 2012 at 10:10 PM, Busy Dev <busydev6@gmail.com> wrote:
> >> I've been trying to import a QCOW2 image onto my environment but haven't
> >> had any success.
> >>
> >> The management server shows that 2 of my system VMs are running *but*
> their
> >> are many entries like the following in my log file:
> >>
> >> *"There is no secondary storage VM for secondary storage host nfs://
> >> 192.168.1.15/export/secondary."*
> >>
> >> I have logged in (through Virtual Machine Manager) to the storage VM
> using
> >> the credentials below:
> >>
> >> USN - root
> >> PWD - 6m1ll10n
> >>
> >> and have successfully mounted the NFS drive through the command line:
> >>
> >> mount -t nfs 192.168.1.15:/export/secondary /mnt/secondary
> >>
> >> I also saw the following instructions but this failed for me.  Is this
> the
> >> reason for the secondary storage error message above?  How do I fix
> this?
> >>
> >> Thanks.
> >>
> >>
> >> [root@kvmhost .ssh]# ssh -i /root/.ssh/id_rsa.cloud -p 3922
> >> root@169.254.3.204
> >> Permission denied (publickey).
> >>
> >>
> >> I then did "-v"
> >>
> >> [root@kvmhost .ssh]# ssh -i /root/.ssh/id_rsa.cloud -p 3922
> >> root@169.254.3.204 -v
> >> OpenSSH_5.3p1, OpenSSL 1.0.0-fips 29 Mar 2010
> >> debug1: Reading configuration data /etc/ssh/ssh_config
> >> debug1: Applying options for *
> >> debug1: Connecting to 169.254.3.204 [169.254.3.204] port 3922.
> >> debug1: Connection established.
> >> debug1: permanently_set_uid: 0/0
> >> debug1: identity file /root/.ssh/id_rsa.cloud type -1
> >> debug1: Remote protocol version 2.0, remote software version
> OpenSSH_5.5p1
> >> Debian-6+squeeze1
> >> debug1: match: OpenSSH_5.5p1 Debian-6+squeeze1 pat OpenSSH*
> >> debug1: Enabling compatibility mode for protocol 2.0
> >> debug1: Local version string SSH-2.0-OpenSSH_5.3
> >> debug1: SSH2_MSG_KEXINIT sent
> >> debug1: SSH2_MSG_KEXINIT received
> >> debug1: kex: server->client aes128-ctr hmac-md5 none
> >> debug1: kex: client->server aes128-ctr hmac-md5 none
> >> debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
> >> debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
> >> debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
> >> debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
> >> debug1: Host '[169.254.3.204]:3922' is known and matches the RSA host
> key.
> >> debug1: Found key in /root/.ssh/known_hosts:5
> >> debug1: ssh_rsa_verify: signature correct
> >> debug1: SSH2_MSG_NEWKEYS sent
> >> debug1: expecting SSH2_MSG_NEWKEYS
> >> debug1: SSH2_MSG_NEWKEYS received
> >> debug1: SSH2_MSG_SERVICE_REQUEST sent
> >> debug1: SSH2_MSG_SERVICE_ACCEPT received
> >> debug1: Authentications that can continue: publickey
> >> debug1: Next authentication method: publickey
> >> debug1: Trying private key: /root/.ssh/id_rsa.cloud
> >> debug1: read PEM private key done: type RSA
> >> debug1: Authentications that can continue: publickey
> >> debug1: No more authentication methods to try.
> >> Permission denied (publickey).
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message