incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kamil Gardziejczyk <belussi...@gmail.com>
Subject Re: CloudStack Development tutorial for newbies
Date Sun, 23 Sep 2012 19:32:55 GMT
OK. I successfully build rpms ;) What do you mean saying "deploy as
normal"? I want install management server and agent using install.sh script
because this is the easist way ;) Is there any place where I can download
latest official build and just replace rpms?

2012/9/23 Gavin Lee <gavin.lxh@gmail.com>

> You may build the source and package into rpm/deb, then deploy as
> normal, see [1].
> After that, you can replace the scripts/modules with yours for
> dev/debug purpose.
> May not help you more since I don't have much experience on this part.
>
> [1]
> https://cwiki.apache.org/confluence/display/CLOUDSTACK/Building+with+Maven
>
> On Sun, Sep 23, 2012 at 10:08 PM, Kamil Gardziejczyk
> <belussi.pl@gmail.com> wrote:
> > Oliver:
> > You just have to add ant-nodeps-1.7.1.jar file to classpath. Find that
> file
> > on you file system. I had in at /usr/share/nat/lib.
> >
> > export CLASSPATH=/path/to/your/ant-nodeps-1.7.1.jar:$CLASSPATH
> >
> > Gavin:
> > I`m asking about deploying CS Agent on the same machine as management
> > server because I just want to make some development on this. I`m sure
> that
> > is possible.  Could you help me with this? I mean, write short tutorial
> how
> > to deploy agent? ;) I have already installed KVM host. Do I need to do
> some
> > special KVM configuration?
> >
> > 2012/9/23 Gavin Lee <gavin.lxh@gmail.com>
> >
> >> KVM agent will be installed on KVM hypervisor, do you plan to use host
> >> for both management server and  KVM hypervisor?
> >> Suggest install the agent on a clean KVM hypervisor.
> >>
> >> On Sun, Sep 23, 2012 at 6:11 PM, Kamil Gardziejczyk
> >> <belussi.pl@gmail.com> wrote:
> >> > Ok. My managment service is working fine ;)
> >> >
> >> > Now i have a quastion about KVM agnet. How to deploy it from source?
> with
> >> > ant? Should I install it on a separted machin or can it be shared with
> >> > management server?
> >> >
> >> >
> >> >
> >> > 2012/9/23 Kamil Gardziejczyk <belussi.pl@gmail.com>
> >> >
> >> >> Hmmm There is also issue with ant. I had installed ant before and
> >> >> everthing works fine...ehhhh
> >> >>
> >> >> compile-utils:
> >> >>     [mkdir] Created dir:
> >> >>
> >>
> /root/workspace/incubator-cloudstack/artifacts/rpmbuild/BUILD/cloud-4.0.0/target/classes/cloud-utils.jar
> >> >>
> >> >> BUILD FAILED
> >> >>
> >>
> /root/workspace/incubator-cloudstack/artifacts/rpmbuild/BUILD/cloud-4.0.0/build/build-cloud.xml:180:
> >> >> The following error occurred while executing this line:
> >> >>
> >>
> /root/workspace/incubator-cloudstack/artifacts/rpmbuild/BUILD/cloud-4.0.0/build/build-common.xml:62:
> >> >> Problem: failed to create task or type depend
> >> >> Cause: the class org.apache.tools.ant.taskdefs.optional.depend.Depend
> >> was
> >> >> not found.
> >> >>         This looks like one of Ant's optional components.
> >> >> Action: Check that the appropriate optional JAR exists in
> >> >>         -/usr/share/ant/lib
> >> >>         -/root/.ant/lib
> >> >>         -a directory added on the command line with the -lib argument
> >> >>
> >> >> Do not panic, this is a common problem.
> >> >> The commonest cause is a missing JAR.
> >> >>
> >> >> This is not a bug; it is a configuration problem
> >> >>
> >> >>
> >> >>
> >> >> 2012/9/23 Kamil Gardziejczyk <belussi.pl@gmail.com>
> >> >>
> >> >>> Thanks! I should check it before... ;)
> >> >>>
> >> >>> So, I almost run it. But i have some strange tomcat issue:
> >> >>>
> >> >>> java.lang.LinkageError: loader constraint violation: loader
> (instance
> >> of org/apache/jasper/servlet/JasperLoader) previously initiated loading
> for
> >> a different type with name "javax/servlet/http/HttpServletRequest"
> >> >>>      java.lang.Class.getDeclaredMethods0(Native Method)
> >> >>>      java.lang.Class.privateGetDeclaredMethods(Class.java:2444)
> >> >>>      java.lang.Class.getDeclaredMethods(Class.java:1808)
> >> >>>
> >>
>  org.apache.jasper.servlet.JspServletWrapper.getServlet(JspServletWrapper.java:172)
> >> >>>
> >>
>  org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:369)
> >> >>>
> >>
>  org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:390)
> >> >>>
>  org.apache.jasper.servlet.JspServlet.service(JspServlet.java:334)
> >> >>>      javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
> >> >>>
> >> >>> I`m not sure, but I think it could be connected with my previous
> >> cloudstack installation. Some servelt is duplicated? Any ideas? I just
> >> don`t want reinstall my OS...
> >> >>>
> >> >>>
> >> >>> 2012/9/22 Chip Childers <chip.childers@sungard.com>
> >> >>>
> >> >>>> Please check the top level README.md file. That should have
the
> >> >>>> rudimentary build instructions.
> >> >>>>
> >> >>>> - chip
> >> >>>>
> >> >>>> Sent from my iPhone.
> >> >>>>
> >> >>>> On Sep 22, 2012, at 3:35 PM, Kamil Gardziejczyk <
> belussi.pl@gmail.com
> >> >
> >> >>>> wrote:
> >> >>>>
> >> >>>> > UPDATE:
> >> >>>> >
> >> >>>> > What I did:
> >> >>>> > 1. Pulled CloudStack repo.
> >> >>>> > 2. Ran mv
> >> >>>> > 3. Ran deps/install-non-oss.sh
> >> >>>> >
> >> >>>> > I got oputput:
> >> >>>> >
> >> >>>> > [INFO] Scanning for projects...
> >> >>>> > Downloading:
> >> >>>> > http://repo1.maven.org/maven2/org/apache/apache/11/apache-11.pom
> >> >>>> > [WARNING] Unable to get resource 'org.apache:apache:pom:11'
from
> >> >>>> repository
> >> >>>> > central (http://repo1.maven.org/maven2): Error transferring
> file:
> >> >>>> > Connection timed out
> >> >>>> > [INFO]
> >> >>>> >
> >> >>>>
> >> ------------------------------------------------------------------------
> >> >>>> > [ERROR] FATAL ERROR
> >> >>>> > [INFO]
> >> >>>> >
> >> >>>>
> >> ------------------------------------------------------------------------
> >> >>>> > [INFO] Error building POM (may not be this project's POM).
> >> >>>> >
> >> >>>> >
> >> >>>> > Project ID: org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT
> >> >>>> >
> >> >>>> > Reason: Cannot find parent: org.apache:apache for project:
> >> >>>> > org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT for
project
> >> >>>> > org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT
> >> >>>> >
> >> >>>> >
> >> >>>> > [INFO]
> >> >>>> >
> >> >>>>
> >> ------------------------------------------------------------------------
> >> >>>> > [INFO] Trace
> >> >>>> > org.apache.maven.reactor.MavenExecutionException: Cannot
find
> >> parent:
> >> >>>> > org.apache:apache for project:
> >> >>>> > org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT for
project
> >> >>>> > org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT
> >> >>>> >        at
> >> >>>> org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:404)
> >> >>>> >        at
> >> >>>> org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:272)
> >> >>>> >        at
> >> org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
> >> >>>> >        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
> >> >>>> >        at
> >> >>>> >
> >> org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
> >> >>>> >        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
> >> Method)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
> >> >>>> >        at java.lang.reflect.Method.invoke(Method.java:616)
> >> >>>> >        at
> >> >>>> >
> org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
> >> >>>> >        at
> >> org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> >> >>>> >        at
> >> >>>> >
> >> org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> >> >>>> >        at
> org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> >> >>>> > Caused by: org.apache.maven.project.ProjectBuildingException:
> Cannot
> >> >>>> find
> >> >>>> > parent: org.apache:apache for project:
> >> >>>> > org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT for
project
> >> >>>> > org.apache.cloudstack:cloudstack:pom:4.0.0-SNAPSHOT
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1396)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.buildInternal(DefaultMavenProjectBuilder.java:823)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.buildFromSourceFileInternal(DefaultMavenProjectBuilder.java:508)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.build(DefaultMavenProjectBuilder.java:200)
> >> >>>> >        at
> >> >>>> org.apache.maven.DefaultMaven.getProject(DefaultMaven.java:604)
> >> >>>> >        at
> >> >>>> >
> org.apache.maven.DefaultMaven.collectProjects(DefaultMaven.java:487)
> >> >>>> >        at
> >> >>>> org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:391)
> >> >>>> >        ... 12 more
> >> >>>> > Caused by: org.apache.maven.project.ProjectBuildingException:
POM
> >> >>>> > 'org.apache:apache' not found in repository: Unable to
download
> the
> >> >>>> > artifact from any repository
> >> >>>> >
> >> >>>> >  org.apache:apache:pom:11
> >> >>>> >
> >> >>>> > from the specified remote repositories:
> >> >>>> >  central (http://repo1.maven.org/maven2)
> >> >>>> >
> >> >>>> > for project org.apache:apache
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:605)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.assembleLineage(DefaultMavenProjectBuilder.java:1392)
> >> >>>> >        ... 18 more
> >> >>>> > Caused by:
> >> >>>> org.apache.maven.artifact.resolver.ArtifactNotFoundException:
> >> >>>> > Unable to download the artifact from any repository
> >> >>>> >
> >> >>>> >  org.apache:apache:pom:11
> >> >>>> >
> >> >>>> > from the specified remote repositories:
> >> >>>> >  central (http://repo1.maven.org/maven2)
> >> >>>> >
> >> >>>> >
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:228)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:90)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:558)
> >> >>>> >        ... 19 more
> >> >>>> > Caused by: org.apache.maven.wagon.ResourceDoesNotExistException:
> >> >>>> Unable to
> >> >>>> > download the artifact from any repository
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(DefaultWagonManager.java:404)
> >> >>>> >        at
> >> >>>> >
> >> >>>>
> >>
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(DefaultArtifactResolver.java:216)
> >> >>>> >        ... 21 more
> >> >>>> >
> >> >>>> >
> >> >>>> > 2012/9/22 Kamil Gardziejczyk <belussi.pl@gmail.com>
> >> >>>> >
> >> >>>> >> Hi,
> >> >>>> >> I`m looking for help with setting up CloudStack development
> >> >>>> environment. I
> >> >>>> >> found some tutorials but i still have some issues...
> >> >>>> >>
> >> >>>> >>
> >> >>>>
> >>
> http://docs.cloudstack.org/Knowledge_Base/How_to_set_up_a_CloudStack_development_environment
> >> >>>> >>
> >> >>>> >>
> >> >>>> >> I have already pull newest Repo, but there is no ant
inside....
> >> >>>> >>
> >> >>>> >> Could anyone help me with this. I mean, show how to
set up
> >> developemnt
> >> >>>> >> enviroment step by step? I need to set up CS management
server
> on
> >> >>>> RHEL 6.2
> >> >>>> >> and on the second machine CS KVM agenet. Any help
would be
> greatly
> >> >>>> >> appreciated.
> >> >>>> >> --
> >> >>>> >> Pozdrawiam,
> >> >>>> >> Kamil Gardziejczyk
> >> >>>> >>
> >> >>>> >>
> >> >>>> >
> >> >>>> >
> >> >>>> > --
> >> >>>> > Pozdrawiam,
> >> >>>> > Kamil Gardziejczyk
> >> >>>>
> >> >>>
> >> >>>
> >> >>>
> >> >>> --
> >> >>> Pozdrawiam,
> >> >>> Kamil Gardziejczyk
> >> >>>
> >> >>>
> >> >>
> >> >>
> >> >> --
> >> >> Pozdrawiam,
> >> >> Kamil Gardziejczyk
> >> >>
> >> >>
> >> >
> >> >
> >> > --
> >> > Pozdrawiam,
> >> > Kamil Gardziejczyk
> >>
> >>
> >>
> >> --
> >> Gavin
> >>
> >
> >
> >
> > --
> > Pozdrawiam,
> > Kamil Gardziejczyk
>
>
>
> --
> Gavin
>



-- 
Pozdrawiam,
Kamil Gardziejczyk

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message