incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rohit Yadav <rohit.ya...@citrix.com>
Subject Re: maven build package error.
Date Tue, 25 Sep 2012 10:27:05 GMT
Are you trying to build with nonoss activator?

>   /usr/share/java/cloud-iControl.jar
>   /usr/share/java/cloud-manageontap.jar
>   /usr/share/java/cloud-netscaler-sdx.jar
>   /usr/share/java/cloud-netscaler.jar

These should not be in oss build.

For non oss build, you need to get the updated patch, see wiki for steps/link:
https://cwiki.apache.org/confluence/display/CLOUDSTACK/Building+with+Maven#BuildingwithMaven-TemporaryBuildProcessonASFMaster

On 25-Sep-2012, at 3:31 PM, coudstacks <cloudstacks@163.com> wrote:

> Obsoletes: vmops-agent < 4.0.0-0.1000.el6.rc1 vmops-console < 4.0.0-0.1000.el6.rc1
cloud-console < 4.0.0-0.1000.el6.rc1 cloud-vnet < 4.0.0-0.1000.el6.rc1 cloud-premium-agent
< 4.0.0-0.1000.el6.rc1
> Processing files: cloud-baremetal-agent-4.0.0-0.1000.el6.rc1.x86_64
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix)
<= 4.0-1
> Requires: /usr/bin/python
> Processing files: cloud-cli-4.0.0-0.1000.el6.rc1.x86_64
> Provides: config(cloud-cli) = 4.0.0-0.1000.el6.rc1
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix)
<= 4.0-1
> Requires: /usr/bin/env /usr/bin/python python(abi) = 2.6
> Processing files: cloud-usage-4.0.0-0.1000.el6.rc1.x86_64
> Provides: config(cloud-usage) = 4.0.0-0.1000.el6.rc1
> Requires(interp): /bin/sh /bin/sh /bin/sh
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix)
<= 4.0-1 rpmlib(VersionedDependencies) <= 3.0.3-1
> Requires(pre): /bin/sh
> Requires(post): /bin/sh
> Requires(preun): /bin/sh
> Requires: /bin/bash
> Obsoletes: vmops-usage < 4.0.0-0.1000.el6.rc1
> Processing files: cloud-aws-api-4.0.0-0.1000.el6.rc1.x86_64
> Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix)
<= 4.0-1 rpmlib(VersionedDependencies) <= 3.0.3-1
> Obsoletes: cloud-bridge < 4.0.0-0.1000.el6.rc1
> Checking for unpackaged file(s): /usr/lib/rpm/check-files /root/incubator-cloudstack/artifacts/rpmbuild/BUILDROOT/cloud-4.0.0-0.1000.el6.rc1.x86_64
> error: Installed (but unpackaged) file(s) found:
>   /usr/share/java/cloud-iControl.jar
>   /usr/share/java/cloud-manageontap.jar
>   /usr/share/java/cloud-netscaler-sdx.jar
>   /usr/share/java/cloud-netscaler.jar
> 
> 
> RPM build errors:
>    File listed twice: /etc/cloud/management/Catalina
>    File listed twice: /etc/cloud/management/Catalina/localhost
>    File listed twice: /etc/cloud/management/Catalina/localhost/client
>    File listed twice: /etc/cloud/management/db.properties
>    File listed twice: /etc/cloud/management/log4j-cloud.xml
>    File listed twice: /etc/cloud/management/tomcat6.conf
>    Installed (but unpackaged) file(s) found:
>   /usr/share/java/cloud-iControl.jar
>   /usr/share/java/cloud-manageontap.jar
>   /usr/share/java/cloud-netscaler-sdx.jar
>   /usr/share/java/cloud-netscaler.jar
> system command rpmbuild failed with error value 1

Mime
View raw message