incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anthony Xu <Xuefei...@citrix.com>
Subject RE: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????
Date Mon, 10 Sep 2012 18:07:39 GMT
Sounds like a VLAN configuration issue in physical switch, the switch drops VLAN package.
Port may need to be configured as VLAN trunk.

Anthony

-----Original Message-----
From: VietNd4@viettel.com.vn [mailto:VietNd4@viettel.com.vn] 
Sent: Monday, September 10, 2012 3:52 AM
To: cloudstack-dev@incubator.apache.org
Subject: RE: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????

Hi guy,
My network is divided VLAN and CS server (MS, hosts) belong to the same special VLAN. All
host and MS are pluged into the same physical switch and this switch use a hub (plug and play,
not create VLAN). But when I create Cloudstack advance zone, I don't define VLAN ID in Public
Traffic create step because I think all host and MS in the same vlan and physical switch then
they can communicate normaly. This can affect the problem that I'm having? VLAN ID in Public
Traffic create step is required in VLAN network environment?


-----Original Message-----
From: VietNd4@viettel.com.vn [mailto:VietNd4@viettel.com.vn] 
Sent: Monday, September 10, 2012 2:53 PM
To: cloudstack-dev@incubator.apache.org
Subject: RE: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????


Hi guy,
I  try creating many VMs from other templates included: Ubuntu, CentOS, Windows 2k with the
same scerano then i have the same result too. When I migrate XP VM from host 1 to host 2 then
it can obtain IP address from VR and can not  obtain IP address when I migrate it back to
host 1.




Thanks & Best Regards.


-----Original Message-----
From: srivatsav.prasanna@gmail.com [mailto:srivatsav.prasanna@gmail.com] On Behalf Of prasanna
Sent: Sunday, September 09, 2012 8:07 PM
To: cloudstack-dev@incubator.apache.org
Subject: Re: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????

On 8 September 2012 09:58, Nguyễn Đình Việt <VietNd4@viettel.com.vn> wrote:
> Hi,
> I run 2 VM on 2 different hosts (VM XP run on host 1, VM hyperv run on host 2, and VR
running on host 2, VR's ip address is 10.1.1.1. All host running on the same VLAN), only VM
hyperv obtained IP address from VR.  This is result in /var/log/message on VR:
>

Can you try and deploy the HyperV VM on both hosts? If the VMs (one on
VR host and one on different host) from the same template don't get
DHCPed you have to check your VLANs. If not there could be a problem
with the template. Is your XP template sysprepped?


> Sep  8 04:12:13 r-468-VM cloud: edithosts: update 02:00:27:b0:00:35 10.1.1.90 XP to hosts
> Sep  8 04:12:13 r-468-VM cloud: /root/edithosts.sh: setting default router for 10.1.1.90
to 10.1.1.1
> Sep  8 04:12:13 r-468-VM cloud: /root/edithosts.sh: setting dns server for 10.1.1.90
to 10.1.1.1
> Sep  8 04:12:44 r-468-VM cloud: edithosts: update 02:00:04:d3:00:3a 10.1.1.107 hyperv
to hosts
> Sep  8 04:12:44 r-468-VM cloud: /root/edithosts.sh: setting default router for 10.1.1.107
to 10.1.1.1
> Sep  8 04:12:44 r-468-VM cloud: /root/edithosts.sh: setting dns server for 10.1.1.107
to 10.1.1.1
>

> When I use renew ip address command on VM XP (run on host 1, other with VR)  and tcpdump
command on VR then I don't receive any DHCP packet from VM XP.

Hmm - It looks like both the VMs have been given IPs by cloudstack -
10.1.1.107 and 10.1.1.90. Okay - it could be a problem with the XP
template. Are you able to get IPs for templates other than XP with the
same scenario?
Mime
View raw message