incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kelceydamage@bbits" <kel...@bbits.ca>
Subject Re: Still cannot add KVM host
Date Wed, 19 Sep 2012 07:00:05 GMT
Nah, I think drumming works better. 

But yeah, no mention was made of which host os is in use. I'm kind of guessing Ubuntu.

Sent from my iPhone

On Sep 18, 2012, at 11:50 PM, Marcus Sorensen <shadowsor@gmail.com> wrote:

> Drumming? I meant running!
> On Sep 19, 2012 12:49 AM, "Marcus Sorensen" <shadowsor@gmail.com> wrote:
> 
>> Did he say which distribution? I recently submitted a fix for cent 6.3, it
>> wasn't setting up the cgconfig service.
>> 
>> I second drumming cloud-setup-agent. If you look at the management server
>> log you should see the exact command/arcs being sent to the host. Copy that
>> and run it manually to see where it fails.
>> On Sep 19, 2012 12:23 AM, "Kelcey Jamison-Damage" <kelcey@bbits.ca> wrote:
>> 
>>> Have you tried running cloud-setup-agent on the host? If so what is its
>>> output?
>>> 
>>> Are you building 3.0.2 or 4.0 source?
>>> 
>>> 
>>> 
>>> Busy Dev <busydev6@gmail.com> wrote:
>>> 
>>>> Thanks - I checked my KVM host and that directory already exists.
>>>> 
>>>> 
>>>> 
>>>> On Wed, Sep 19, 2012 at 1:07 AM, KAWAI Hiroaki <kawai@stratosphere.co.jp
>>>> wrote:
>>>> 
>>>>> Hi,
>>>>> I run into the same problem. On KVM host OS, try:
>>>>> 
>>>>> mkdir /var/lib/libvirt/images/
>>>>> 
>>>>> logging will be added with patch https://reviews.apache.org/r/**7153/<
>>> https://reviews.apache.org/r/7153/>
>>>>> 
>>>>> 
>>>>> 
>>>>> (2012/09/19 14:00), Busy Dev wrote:
>>>>> 
>>>>>> I've been able to setup my development environment and am now trying
>>> to
>>>>>> setup the management server.  However, when I "launch" Cloudstack,
I
>>> am
>>>>>> unable to add a KVM host.
>>>>>> 
>>>>>> The error in the log file
>>>>>> 
>>>>>> 2012-09-19 00:50:48,883 INFO  [utils.component.**ComponentLocator]
>>>>>> (main:null) Unable to find components.xml
>>>>>> 2012-09-19 00:50:48,884 INFO  [utils.component.**ComponentLocator]
>>>>>> (main:null) Skipping configuration using components.xml
>>>>>> 2012-09-19 00:50:48,885 INFO  [cloud.agent.AgentShell] (main:null)
>>>>>> Implementation Version is 4.0.0.48.20120918191610
>>>>>> 2012-09-19 00:50:48,885 INFO  [cloud.agent.AgentShell] (main:null)
>>>>>> agent.properties found at /etc/cloud/agent/agent.**properties
>>>>>> 2012-09-19 00:50:48,886 INFO  [cloud.agent.AgentShell] (main:null)
>>>>>> Defaulting to using properties file for storage
>>>>>> 2012-09-19 00:50:48,888 INFO  [cloud.agent.AgentShell] (main:null)
>>>>>> Defaulting to the constant time backoff algorithm
>>>>>> 2012-09-19 00:50:48,949 INFO  [cloud.agent.Agent] (main:null) id
is
>>>>>> 2012-09-19 00:50:49,055 INFO
>>>>>>  [resource.virtualnetwork.**VirtualRoutingResource] (main:null)
>>>>>> VirtualRoutingResource _scriptDir to use: scripts/network/domr/kvm
>>>>>> 2012-09-19 00:50:50,048 INFO
>>> [kvm.resource.**LibvirtComputingResource]
>>>>>> (main:null) No libvirt.vif.driver specififed. Defaults to
>>> BridgeVifDriver.
>>>>>> 2012-09-19 00:50:50,080 INFO  [cloud.agent.Agent] (main:null) Agent
>>> [id =
>>>>>> new : type = LibvirtComputingResource : zone = 1 : pod = 1 : workers
>>> = 5 :
>>>>>> host = 192.168.1.8 : port = 8250
>>>>>> 2012-09-19 00:50:50,093 INFO  [utils.nio.NioClient]
>>> (Agent-Selector:null)
>>>>>> Connecting to 192.168.1.8:8250
>>>>>> 2012-09-19 00:50:50,285 INFO  [utils.nio.NioClient]
>>> (Agent-Selector:null)
>>>>>> SSL: Handshake done
>>>>>> 2012-09-19 00:50:50,635 WARN  [utils.nio.Task] (Agent-Handler-1:null)
>>>>>> Caught the following exception but pushing on
>>>>>> java.lang.NullPointerException
>>>>>>         at
>>>>>> com.cloud.hypervisor.kvm.**storage.LibvirtStorageAdaptor.**
>>>>>> createStoragePool(**LibvirtStorageAdaptor.java:**562)
>>>>>>         at
>>>>>> com.cloud.hypervisor.kvm.**storage.KVMStoragePoolManager.**
>>>>>> createStoragePool(**KVMStoragePoolManager.java:57)
>>>>>>         at
>>>>>> com.cloud.hypervisor.kvm.**resource.**LibvirtComputingResource.**
>>>>>> initialize(**LibvirtComputingResource.java:**3243)
>>>>>>         at com.cloud.agent.Agent.**sendStartup(Agent.java:320)
>>>>>>         at com.cloud.agent.Agent$**ServerHandler.doTask(Agent.**
>>>>>> java:850)
>>>>>>         at com.cloud.utils.nio.Task.run(**Task.java:83)
>>>>>>         at
>>>>>> java.util.concurrent.**ThreadPoolExecutor.runWorker(**
>>>>>> ThreadPoolExecutor.java:1110)
>>>>>>         at
>>>>>> java.util.concurrent.**ThreadPoolExecutor$Worker.run(**
>>>>>> ThreadPoolExecutor.java:603)
>>>>>>         at java.lang.Thread.run(Thread.**java:679)
>>>>>> 
>>>>>> 
>>>>>> Thanks for your help.
>>>>>> 
>>>>>> 
>>>>> 
>>> 
>> 

Mime
View raw message