incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kraig Amador <kama...@shopzilla.com>
Subject Re: Missing Ubuntu Pkg dependency for libtcnative-1
Date Wed, 26 Sep 2012 17:22:24 GMT
I am attempting to do the same but I am getting exceptions for the Api server not running and
the /client servlet failing because of a missing shell script. Did you run into the same issues?

2012-09-26 10:19:53,897 DEBUG [utils.script.Script] (main:null) Searching in the current directory
2012-09-26 10:19:53,897 DEBUG [utils.script.Script] (main:null) Looking for scripts/vm/systemvm/injectkeys.sh
in /tmp/cloud-management-temp/./scripts/vm/systemvm/injectkeys.sh
2012-09-26 10:19:53,897 DEBUG [utils.script.Script] (main:null) Looking for scripts/vm/systemvm/injectkeys.sh
in /tmp/cloud-management-temp/./scripts/vm/systemvm/injectkeys.sh
2012-09-26 10:19:53,898 WARN  [utils.script.Script] (main:null) Unable to find script scripts/vm/systemvm/injectkeys.sh
2012-09-26 10:19:53,900 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in the classpath
2012-09-26 10:19:53,900 DEBUG [utils.script.Script] (main:null) System resource: null
2012-09-26 10:19:53,901 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
2012-09-26 10:19:53,901 DEBUG [utils.script.Script] (main:null) Current binaries reside at
/usr/share/java
2012-09-26 10:19:53,901 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/share/java/vms/systemvm.iso
2012-09-26 10:19:53,902 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/share/java/vms/systemvm.iso
2012-09-26 10:19:53,902 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/share/vms/systemvm.iso
2012-09-26 10:19:53,902 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/vms/systemvm.iso
2012-09-26 10:19:53,903 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /vms/systemvm.iso
2012-09-26 10:19:53,903 DEBUG [utils.script.Script] (main:null) Searching in environment.properties
2012-09-26 10:19:53,904 DEBUG [utils.script.Script] (main:null) environment.properties says
scripts should be in /usr/lib/cloud/common
2012-09-26 10:19:53,904 DEBUG [utils.script.Script] (main:null) Looking for vms/systemvm.iso
in /usr/lib/cloud/common/vms/systemvm.iso
2012-09-26 10:19:53,909 ERROR [cloud.servlet.CloudStartupServlet] (main:null) Exception starting
management server 
com.cloud.utils.exception.CloudRuntimeException: Unable to find key inject script scripts/vm/systemvm/injectkeys.sh
at com.cloud.server.ConfigurationServerImpl.updateKeyPairs(ConfigurationServerImpl.java:675)
at com.cloud.utils.db.DatabaseCallback.intercept(DatabaseCallback.java:34)
at com.cloud.server.ConfigurationServerImpl.persistDefaultValues(ConfigurationServerImpl.java:265)
at com.cloud.utils.db.DatabaseCallback.intercept(DatabaseCallback.java:34)
at com.cloud.servlet.CloudStartupServlet.init(CloudStartupServlet.java:47)
at javax.servlet.GenericServlet.init(GenericServlet.java:212)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206)
at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1026)
at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:4421)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4734)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:601)
at org.apache.catalina.startup.HostConfig.deployDirectory(HostConfig.java:1079)
at org.apache.catalina.startup.HostConfig.deployDirectories(HostConfig.java:1002)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:506)
at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1317)
at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:324)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1065)
at org.apache.catalina.core.StandardHost.start(StandardHost.java:840)
at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1057)
at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:463)
at org.apache.catalina.core.StandardService.start(StandardService.java:525)
at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)
at org.apache.catalina.startup.Catalina.start(Catalina.java:595)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:616)
at org.apache.commons.daemon.support.DaemonLoader.start(DaemonLoader.java:243)




-- 
Kraig Amador


On Wednesday, September 26, 2012 at 8:31 AM, Shanker Balan wrote:

> Hi Wido/CS Packaging Team,
> 
> Thanks for taking the effort to package up CS and hosting the repo at http://cloudstack.apt-get.eu.
> 
> I did a clean install of cloud-client on Ubuntu 12.04 Precise a few moments ago only
to run into the follow error while starting cloud-management server:
> 
> catalina.2012-09-26.log:INFO: The APR based Apache Tomcat Native library which allows
optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.6.0-openjdk-amd64//jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-amd64//jre/lib/amd64:/usr/java/packages/lib/amd64:/usr/lib/x86_64-linux-gnu/jni:/lib/x86_64-linux-gnu:/usr/lib/x86_64-linux-gnu:/usr/lib/jni:/lib:/usr/lib
> 
> This can be fixed with a "aptitude install libtcnative-1". Missing dependency I suppose.
> 
> Thanks.
> 
> Shanker Balan
> mail@shankerbalan.net (mailto:mail@shankerbalan.net)
> 
> PS: Let me know if you need me to open a ticket. 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message