incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhinav Roy (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CLOUDSTACK-181) Not able to add KVM (ubuntu 12.04 ) host to the MS
Date Fri, 21 Sep 2012 08:53:08 GMT
Abhinav Roy created CLOUDSTACK-181:
--------------------------------------

             Summary: Not able to add KVM (ubuntu 12.04 ) host to the MS
                 Key: CLOUDSTACK-181
                 URL: https://issues.apache.org/jira/browse/CLOUDSTACK-181
             Project: CloudStack
          Issue Type: Bug
          Components: KVM, Management Server
    Affects Versions: pre-4.0.0
         Environment: MS : ubuntu 12.04
HOST : KVM - ubuntu 12.04
BUILD : [Git Revision: 0699d65ef155aeff60aab294987815251cc94900 Git URL: https://git-wip-us.apache.org/repos/asf/incubator-cloudstack.git]
http://jenkins.cloudstack.org/job/build-4.0-ubuntu1204/54/artifact/CloudStack-oss-4.0.0-54.tar.bz2
            Reporter: Abhinav Roy
            Priority: Blocker
             Fix For: pre-4.0.0


Steps :
=====================
1. Deploy a Advanced zone setup.
2. Install agent on the KVM host.
3. Add host to MS.

Expected behaviour :
=====================
Host should be successfully added to the MS

Observed behaviour :
=====================
1. While adding the host to the MS for the first time I see these errors in managment server
logs :

 2012-09-21 12:29:32,763 DEBUG [cloud.api.ApiServlet] (catalina-exec-8:null) Invalid paramemter
in URL found. param: hosttags=
2012-09-21 12:29:32,774 INFO  [cloud.resource.ResourceManagerImpl] (catalina-exec-8:null)
Trying to add a new host at http://10.102.125.205 in data center 1
2012-09-21 12:29:33,081 DEBUG [utils.ssh.SSHCmdHelper] (catalina-exec-8:null) Executing cmd:
lsmod|grep kvm
2012-09-21 12:29:34,447 DEBUG [utils.ssh.SSHCmdHelper] (catalina-exec-8:null) lsmod|grep kvm
output:kvm_intel             137721  0 
kvm                   415459  1 kvm_intel

2012-09-21 12:29:35,455 DEBUG [utils.ssh.SSHCmdHelper] (catalina-exec-8:null) Executing cmd:
cloud-setup-agent  -m 10.102.125.241 -z 1 -p 1 -c 1 -g d8830471-0deb-31e3-aef0-30a145f93689
-a --pubNic=cloudbr0 --prvNic=cloudbr0 --guestNic=cloudbr0
2012-09-21 12:29:36,579 DEBUG [utils.ssh.SSHCmdHelper] (catalina-exec-8:null) cloud-setup-agent
 -m 10.102.125.241 -z 1 -p 1 -c 1 -g d8830471-0deb-31e3-aef0-30a145f93689 -a --pubNic=cloudbr0
--prvNic=cloudbr0 --guestNic=cloudbr0 output:Starting to configure your system:
Need to execute with root permission

Try to restore your system:

2012-09-21 12:34:37,600 WARN  [cloud.resource.ResourceManagerImpl] (catalina-exec-8:null)
Unable to find the server resources at http://10.102.125.205
2012-09-21 12:34:37,602 WARN  [api.commands.AddHostCmd] (catalina-exec-8:null) Exception:

com.cloud.exception.DiscoveryException: Unable to add the host
        at com.cloud.resource.ResourceManagerImpl.discoverHostsFull(ResourceManagerImpl.java:737)
        at com.cloud.resource.ResourceManagerImpl.discoverHosts(ResourceManagerImpl.java:544)
        at com.cloud.api.commands.AddHostCmd.execute(AddHostCmd.java:140)
        at com.cloud.api.ApiDispatcher.dispatch(ApiDispatcher.java:138)
        at com.cloud.api.ApiServer.queueCommand(ApiServer.java:543)
        at com.cloud.api.ApiServer.handleRequest(ApiServer.java:422)
        at com.cloud.api.ApiServlet.processRequest(ApiServlet.java:304)
        at com.cloud.api.ApiServlet.doGet(ApiServlet.java:63)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:615)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
        at org.apache.coyote.http11.Http11NioProcessor.process(Http11NioProcessor.java:889)
        at org.apache.coyote.http11.Http11NioProtocol$Http11ConnectionHandler.process(Http11NioProtocol.java:744)
        at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:2274)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
2012-09-21 12:34:37,604 WARN  [cloud.api.ApiDispatcher] (catalina-exec-8:null) class com.cloud.api.ServerApiException
: Unable to add the host
2012-09-21 12:34:44,661 DEBUG [cloud.server.StatsCollector] (StatsCollector-1:null) 


2. After this I login to my host as root and run cloud-setup-agent, it went fine. But again
I see these errors

management server logs :

2012-09-21 13:04:45,657 DEBUG [cloud.network.NetworkUsageManagerImpl] (AgentManager-Handler-9:null)
Disconnected called on 3 with status Alert
2012-09-21 13:04:45,657 DEBUG [cloud.host.Status] (AgentManager-Handler-9:null) Transition:[Resource
state = Enabled, Agent event = AgentDisconnected, Host id = 3, name = BAND-CLOUD-19]
2012-09-21 13:04:45,660 DEBUG [cloud.host.Status] (AgentManager-Handler-9:null) Agent status
update: [id = 3; name = BAND-CLOUD-19; old status = Connecting; event = AgentDisconnected;
new status = Alert; old update count = 91; new update count = 92]
2012-09-21 13:04:45,660 DEBUG [agent.manager.ClusteredAgentManagerImpl] (AgentManager-Handler-9:null)
Notifying other nodes of to disconnect
2012-09-21 13:04:45,662 DEBUG [agent.manager.AgentManagerImpl] (AgentManager-Handler-9:null)
Can not send command com.cloud.agent.api.ReadyCommand due to Host 3 is not up
2012-09-21 13:04:45,663 WARN  [agent.manager.AgentManagerImpl] (AgentManager-Handler-9:null)
Unable to create attache for agent: Seq 3-23:  { Cmd , MgmtId: -1, via: 3, Ver: v1, Flags:
1, [{"StartupRoutingCommand":{"cpus":8,"speed":2393,"memory":16814125056,"dom0MinMemory":805306368,"poolSync":false,"vms":{},"caps":"hvm,snapshot","pool":"/root","hypervisorType":"KVM","hostDetails":{"com.cloud.network.Networks.RouterPrivateIpStrategy":"HostLocal","Host.OS":"Ubuntu","Host.OS.Kernel.Version":"3.2.0-23-generic","Host.OS.Version":"12.04"},"type":"Routing","dataCenter":"default","pod":"default","cluster":"1","guid":"0cae007a-79f9-4cd5-983c-120e3bb18a76-LibvirtComputingResource","name":"BAND-CLOUD-19","id":3,"version":"2.2.20120921050455","publicIpAddress":"10.102.125.205","publicNetmask":"255.255.255.0","publicMacAddress":"78:2b:cb:5e:d1:cb","privateIpAddress":"10.102.125.205","privateMacAddress":"78:2b:cb:5e:d1:cb","privateNetmask":"255.255.255.0","storageIpAddress":"10.102.125.205","storageNetmask":"255.255.255.0","storageMacAddress":"78:2b:cb:5e:d1:cb","resourceName":"LibvirtComputingResource","gatewayIpAddress":"10.102.125.1","wait":0}},{"StartupStorageCommand":{"totalSize":0,"poolInfo":{"uuid":"8023a232-1422-4f7f-b626-c3b9cf5a5cb0","host":"10.102.125.205","localPath":"/var/lib/libvirt/images/","hostPath":"/var/lib/libvirt/images/","poolType":"Filesystem","capacityBytes":481612062720,"availableBytes":8557076480},"resourceType":"STORAGE_POOL","hostDetails":{},"type":"Storage","dataCenter":"default","pod":"default","guid":"0cae007a-79f9-4cd5-983c-120e3bb18a76-LibvirtComputingResource","name":"BAND-CLOUD-19","id":3,"version":"2.2.20120921050455","resourceName":"LibvirtComputingResource","wait":0}}]
}


HOST agent logs :

2012-09-21 13:05:17,681 INFO  [utils.nio.NioClient] (Agent-Selector:null) Connecting to 10.102.125.241:8250
2012-09-21 13:05:17,768 INFO  [utils.nio.NioClient] (Agent-Selector:null) SSL: Handshake done
2012-09-21 13:05:18,789 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Proccess agent startup
answer, agent id = 3
2012-09-21 13:05:18,790 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Set agent id 3
2012-09-21 13:05:18,791 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Startup Response
Received: agent id = 3
2012-09-21 13:05:18,892 WARN  [cloud.agent.Agent] (Agent-Handler-4:null) Unable to send response:
null
2012-09-21 13:05:18,898 WARN  [cloud.agent.Agent] (UgentTask-5:null) Unable to send request:
null
2012-09-21 13:05:22,768 INFO  [cloud.agent.Agent] (Agent-Handler-5:null) Connected to the
server
2012-09-21 13:05:23,798 INFO  [cloud.agent.Agent] (Agent-Handler-5:null) Lost connection to
the server. Dealing with the remaining commands...
2012-09-21 13:05:28,800 INFO  [cloud.agent.Agent] (Agent-Handler-5:null) Reconnecting...
2012-09-21 13:05:28,801 INFO  [utils.nio.NioClient] (Agent-Selector:null) Connecting to 10.102.125.241:8250
2012-09-21 13:05:28,883 INFO  [utils.nio.NioClient] (Agent-Selector:null) SSL: Handshake done
2012-09-21 13:05:29,730 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Proccess agent startup
answer, agent id = 3
2012-09-21 13:05:29,731 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Set agent id 3
2012-09-21 13:05:29,731 INFO  [cloud.agent.Agent] (Agent-Handler-2:null) Startup Response
Received: agent id = 3
2012-09-21 13:05:29,834 WARN  [cloud.agent.Agent] (Agent-Handler-4:null) Unable to send response:
null
2012-09-21 13:05:29,839 WARN  [cloud.agent.Agent] (UgentTask-5:null) Unable to send request:
null


3. I tried restarting cloud-agent services and libvertd but the behaviour didn't change.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message