incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Nalley <da...@gnsa.us>
Subject Re: CloudStack 4.0 KVM system requirements
Date Thu, 02 Aug 2012 16:33:06 GMT
On Thu, Aug 2, 2012 at 8:57 AM, Wido den Hollander <wido@widodh.nl> wrote:
> Hi,
>
> As we are working our way towards CS 4.0 I think we should set some system
> requirements.
>
> My experience with other Hypervisors than KVM is limited, I'd like to keep
> this discussion limited to the KVM Hypervisors.
>
> What platforms are we going to support?
>
> The reason I'm asking that I still have a couple of things I want to fix,
> but they require at least libvirt 0.9.0
>
> Ubuntu 10.04 and RHEL/CentOS 5 ship with an ancient version of libvirt.
>
> Ubuntu 12.04 has 0.9.8 and CentOS 6.3 has 0.9.10 while CentOS 6.2 has 0.9.4.
> CentOS 6.1 has 0.8.7 though.
>
> Are we going to set the requirement that the hypervisor should be at least
> Ubuntu 12.04 or CentOS 6.2?
>
> This way we know that we will be working with at least libvirt 0.9.4 which
> has a lot more features then <0.9.0 did.
>
> New features:
> - disk I/O tuning
> - More/better CPU scheduling
>
> The exception will however be that when you want to use RBD you need at
> least 0.10.0 (due to come out in a couple of days), but that's a specific
> use-case for new users.
>
> Can we set this requirement for users who want to upgrade their KVM
> clusters?
>
> Wido

So I think it's important to realize that the actual release is a
source release. That makes the question (at least in my mind) what
platforms will we build convenience binaries for, as I suspect anyone
who builds from source doesn't really care about our concepts of
'supported platforms'. The better question to define in my mind is
what versions of required libraries need to be there. (and perhaps
secondarily, will it work elsewhere - for instance the existing Ubuntu
10.04 KVM support doesn't include snapshot capabilities IIRC).

With that said the 3.0.x series didn't support KVM on EL5, so I see
little reason to start supporting it now, but I am somewhat concerned
about Ubuntu 10.04 support; but 4.0.0 is obviously a major 'new'
version, so if we are going to drop a 'platform', now is certainly the
time the time to do rather than orphaning folks at some point down the
road. I'd far rather see us limit ourselves to the number of platforms
that we know we can maintain going forward, rather than trying to do
everything and then dropping stuff down the road.

--David

Mime
View raw message