incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebgoa <run...@gmail.com>
Subject [DEVCLOUD] Re: Build process for devcloud image.
Date Mon, 13 Aug 2012 14:06:24 GMT

On Aug 9, 2012, at 6:06 PM, David Nalley wrote:

> On Thu, Aug 9, 2012 at 5:05 PM, Chip Childers <chip.childers@sungard.com> wrote:
>> On Thu, Aug 9, 2012 at 9:36 AM, sebgoa <runseb@gmail.com> wrote:
>>> Hi Chip,
>>> 
>>> I am almost through the entire build.
>>> 
>>> However puppet seems stuck at:
>>> 
>>> notice: /Stage[main]/Puppet-devcloud/File[/opt/storage/secondary/template/tmpl/1/1]/ensure:
created
>>> 
>>> Downloading the tinylinux VM ?
>>> 
>>> -Sebastien
>>> 
>>> On Aug 7, 2012, at 8:05 PM, Chip Childers wrote:
>>> 
>>>> Edison (others),
>>>> 
>>>> I'd love if you would give the devcloud "build process" a try.  I
>>>> combined your veewee stuff, with puppet manifests that build a base
>>>> box, and then are used whenever devcloud is started from vagrant.
>>>> 
>>>> Basic instructions are here:
>>>> 
>>>> To build a "devcloud base box", run you need a system with VirtualBox
>>>> and rvm installed (use ruby 1.9.2).  Run build_vagrant_basebox.sh to
>>>> build the base box.
>>>> 
>>>> To use the "devcloud base box" that is created in the previous step,
>>>> you need to have installed a forked version of Vagrant (until we make
>>>> the changes plugins instead of direct source patches) that can be
>>>> found here:  https://github.com/chipchilders/vagrant
>>>> 
>>>> Once installed per the Vagrant installation process, run:
>>>> 
>>>> vagrant box add devcloud [path to devcloud.box]
>>>> 
>>>> Then, either go into the devcloudbox folder of your checked out
>>>> version of the CloudStack code
>>>> (incubator-cloudstack/tools/devcloud/devcloudbox), or copy the
>>>> contents of that folder to another location.
>>>> 
>>>> Assuming the patched Vagrant installation is working, you then simply
>>>> run "vagrant up" from within that directory.
>>>> 
>>>> -chip
>>> 
>>> -Sebastien Goasguen
>>> Apache Cloudstack Evangelist, EMEA
>>> 
>>> 
>>> 
>>> 
>> 
>> Sebastien and I spoke about this on IRC.  It turns out that he was
>> seeing the really long download time for the system VM images.
>> 
>> There are a couple of other issues that he ran into (and is going to
>> try to look at):
>> 
>> The big one is that "xe host-list" isn't actually functioning, and you
>> can't add the host via the CS UI.
>> 
>> Sebastien also ran into an issue where root isn't able to log into the
>> box remotely.
>> 
>> He's going to try to take a look at those issues...  but I'll come
>> back to this after I get through the dependency license work.
>> 
>> -chip
> 
> Thanks for bringing this back to the list. I wonder if this is part of
> the problem that Olga is having with Devcloud.
> 
> --David


David: I don't think so, it looks like there is a puppet issue with the build. Olga must have
another issue.

Everything is not solved yet but I started a wiki page at:

https://cwiki.apache.org/confluence/display/CLOUDSTACK/Building+DevCloud



-Sebastien


-Sebastien Goasguen
Apache Cloudstack Evangelist, EMEA




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message