incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Kinsella <...@stratosec.co>
Subject Re: CloudStack 4.0 KVM system requirements
Date Thu, 02 Aug 2012 17:38:14 GMT
I was referring to the install.sh which shipped in the release tar balls and users are instructed
in the install guides to use to install CS management server and agents…I don't see it in
the repo either?

Could put the logic into the pre-install scripts in the packages also…checking for the packages
does make more sense than checking the distro version.

On Aug 2, 2012, at 7:22 AM, Wido den Hollander wrote:

> On 08/02/2012 04:10 PM, John Kinsella wrote:
>> Sounds reasonable to me. Also…can we test for those conditions in the installer
and clearly state if they're not met?
> 
> We can have the spec file and debian control file depend on specific libvirt versions.
> 
> You are probably referring to the agent install script? I can't find that script in the
repository, but imho setting up a Hypervisor could be done by installing the RPM's or DEB's
which will fail if your installed libvirt is to old.
> 
> In the Agent we can also verify the libvirt version through the libvirt API, so the Agent
can also throw an exception when you are running a to old libvirt.
> 
> Wido
> 
>> 
>> On Aug 2, 2012, at 5:57 AM, Wido den Hollander wrote:
>> 
>> Hi,
>> 
>> As we are working our way towards CS 4.0 I think we should set some system requirements.
>> 
>> My experience with other Hypervisors than KVM is limited, I'd like to keep this discussion
limited to the KVM Hypervisors.
>> 
>> What platforms are we going to support?
>> 
>> The reason I'm asking that I still have a couple of things I want to fix, but they
require at least libvirt 0.9.0
>> 
>> Ubuntu 10.04 and RHEL/CentOS 5 ship with an ancient version of libvirt.
>> 
>> Ubuntu 12.04 has 0.9.8 and CentOS 6.3 has 0.9.10 while CentOS 6.2 has 0.9.4. CentOS
6.1 has 0.8.7 though.
>> 
>> Are we going to set the requirement that the hypervisor should be at least Ubuntu
12.04 or CentOS 6.2?
>> 
>> This way we know that we will be working with at least libvirt 0.9.4 which has a
lot more features then <0.9.0 did.
>> 
>> New features:
>> - disk I/O tuning
>> - More/better CPU scheduling
>> 
>> The exception will however be that when you want to use RBD you need at least 0.10.0
(due to come out in a couple of days), but that's a specific use-case for new users.
>> 
>> Can we set this requirement for users who want to upgrade their KVM clusters?
>> 
>> Wido
>> 
>> 
>> Stratosec<http://stratosec.co> - Secure Infrastructure as a Service
>> o: 415.315.9385
>> @johnlkinsella<http://twitter.com/johnlkinsella>
>> 
>> 
> 
> 

Stratosec - Secure Infrastructure as a Service
o: 415.315.9385
@johnlkinsella



Mime
View raw message