incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Brockmeier <...@zonker.net>
Subject Re: [DOCS] links within a document.
Date Thu, 16 Aug 2012 21:27:18 GMT
On Thu, Aug 16, 2012 at 03:20:34PM -0400, David Nalley wrote:
> So we have a mass of xml files that are assembled into different
> documents by other XML files.
> So for something I was playing with locally, I built the developers
> guide, or well, tried to. It failed (for multiple reasons) I fixed the
> first, and started to fix the second, when I realized that this could
> easily be a much larger issue, and so I figured I'd bring it here for
> discussion.

I'm not sure this is a larger issue so much as a reflection of the fact
that we haven't fully pulled everything in yet. That is to say, the docs
are in a not-yet complete state right now, so attempts to build any of
them (Runbook excepted) are going to be iffy. 

> As a side note, I started adding documents to be built in jenkins so
> we can start catching this kind of thing, but the log for
> cloudstack-dev-guide is good for this conversation.
> 
> http://jenkins.cloudstack.org/job/build-docs-devguide-master/123/console

I get a "Status Code: 404" page from this? 

> Curious as to your thoughts on this - do we just have lots of CI that
> catches it for us? Is there some way to catch this without CI?

I don't think we need CI for this, really. Once docs are in a stable
state, it should be on the folks working with the docs to do a test
publican build to ensure that it doesn't break. I've been doing a test
with the publican-all.cfg for all the stuff I've done under docs, but
not for each individual guide. 

Best, 

Joe
-- 
Joe Brockmeier
http://dissociatedpress.net/
Twitter: @jzb

Mime
View raw message