incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <Prasanna.Santha...@citrix.com>
Subject Re: cloudbridge from master
Date Mon, 06 Aug 2012 13:13:15 GMT
On Mon, Aug 06, 2012 at 08:46:39AM -0400, sebgoa wrote:
> Hi Likitha,
> 
> I am referring to the deployment of cloudbridge within the CS
> management server. I believe that's how it's supposed to be now, as
> opposed to a separate installation like in the current binary
> release.
> 
> Specifically, if you checkout the current master from git, and
> build-all, I understand that both the mgt server and the awsapi
> server are supposed to run. With the awsapi endpoint being
> http://<host>:8080/awsapi
> 
> -Sebastien

I haven't succeeded in making boto connect to it either. Could you try
the EC2 cmd line tools and see if that works? 

Also, Is there anything extra required to be changed in CloudStack to
have it accept the query api?

> 
> On Aug 6, 2012, at 8:08 AM, Likitha Shetty wrote:
> 
> > Hi Sebastien,
> > 
> > Are you referring to the deployment of cloudbridge as a separate
> > setup ? Because I have been able to successfully run the ec2
> > commands against CloudStack(integrated codebase) using the ec2-api
> > tools.
> > 
> > Thank you,
> > Likitha
> > 
> > -----Original Message-----
> > From: sebgoa [mailto:runseb@gmail.com] 
> > Sent: Monday, August 06, 2012 3:32 PM
> > To: cloudstack-dev@incubator.apache.org
> > Subject: cloudbridge from master
> > 
> > Hi all,
> > 
> > I am wondering if anyone has had success deploying and *using* cloudbridge from
the master branch..
> > 
> > I did a ant build-all and a ant rdeploy to devcloud, the database
> > gets created, I can register the user and cert as documented in
> > http://support.citrix.com/servlet/KbServlet/download/31038-102-684646/CloudPlatform3.0.3_3.0.4InstallGuide.pdf
> > and in previous cloudbridge install.
> > 
> > However the service offering registration does not produce
> > anything and the query api using boto fails.
> > 
> > All of that with nothing in awsapi.log to get a clue with what's
> > wrong.
> > 
> > 
> > -Sebastien Goasguen
> > Apache Cloudstack Evangelist, EMEA
> 
> -Sebastien Goasguen
> Apache Cloudstack Evangelist, EMEA
> 
> 

-- 
Prasanna.,

Mime
View raw message