incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tommy Aditya Lawanto <to...@wowrack.com>
Subject RE: Fail attaching volume to a virtual machine
Date Tue, 31 Jul 2012 08:25:43 GMT
@edison : 

i use CentOS 6.2. 

I tried stop the vm, start it, then attach the volume => no good, it fail

Also try reboot, and then attach the volume => also fail

Then i try to just stop the vm, attach the volume, and then start the vm => surprisingly
it works

After it works, i try to detach the volume => successful. 

And then i attach it again => fail like usual.

Does this mean the virtual machine must be in stopped state in order to attach volume into
it?
________________________________________
From: Edison Su [Edison.su@citrix.com]
Sent: Monday, July 30, 2012 10:59 PM
To: cloudstack-dev@incubator.apache.org
Subject: RE: Fail attaching volume to a virtual machine

What's the kvm host os? Centos/RHEL 6.2? can you stop/start the vm, then attach/detach the
volume, will it work?

> -----Original Message-----
> From: Tommy Aditya Lawanto [mailto:tommy@wowrack.com]
> Sent: Sunday, July 29, 2012 11:55 PM
> To: cloudstack-dev@incubator.apache.org
> Subject: RE: Fail attaching volume to a virtual machine
>
> @david nalley: Okay, here is the xml i get by running "virsh dumpxml
> <instance>"  :
>
> http://pastebin.com/cTSrHwpV
>
> Thank you for your help :)
> ________________________________________
> From: Tommy Aditya Lawanto [tommy@wowrack.com]
> Sent: Monday, July 30, 2012 9:48 AM
> To: cloudstack-dev@incubator.apache.org
> Subject: RE: Fail attaching volume to a virtual machine
>
> @david nalley : I'm running cloudstack version 3, on basic networking
> mode.
>
> Sorry, but how do i "virsh dumpxml <instance>" on the HyperVisor? (do
> you mean that i should type that command when i ssh to my management
> server?
> ________________________________________
> From: Tommy Aditya Lawanto [tommy@wowrack.com]
> Sent: Friday, July 27, 2012 1:46 PM
> To: cloudstack-users@incubator.apache.org
> Subject: RE: Fail attaching volume to a virtual machine
>
> @david nalley : I'm running cloudstack version 3, on basic networking
> mode.
>
> Sorry, but how do i "virsh dumpxml <instance>" on the HyperVisor? (do
> you mean that i should type that command when i ssh to my management
> server?
> ________________________________________
> From: Tommy Aditya Lawanto [tommy@wowrack.com]
> Sent: Friday, July 27, 2012 1:32 PM
> To: cloudstack-users@incubator.apache.org
> Subject: Fail attaching volume to a virtual machine
>
> Im getting this error after I removed a Volume from an CentOS 5.8
> Instance and tried to attach another volume to it:
>
> Failed to attach volume: try volume to VM: f0f33816-0b2d-477d-b673-
> 7789ecd9b738; org.libvirt.LibvirtException: internal error unable to
> execute QEMU command '__com.redhat_drive_add': Duplicate ID 'drive-
> virtio-disk1' for drive
>
> How can I fix it?
>
> Cheers!

Mime
View raw message