incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nitin Mehta <Nitin.Me...@citrix.com>
Subject RE: Secondary storage is not working
Date Tue, 12 Jun 2012 04:02:42 GMT
Lu - With the information provided it seems that the system vm template and secondary storage
have been configured correctly.
Let's circle back to the error in the logs then. Can you try and manually mount the entire
path (1.1.128.2:/data/template/tmpl/1/1) on the xenserver ?

com.cloud.utils.exception.CloudRuntimeException: can't mount
1.1.128.2:/data/template/tmpl/1/1
to /var/run/cloud_mount/f2c6f574-35f4-4552-80a8-0052b7b70bde ?

If this works then let's look into the logs of this failure which should be available on SMlog
on the hypervisor.  Search for the mounting error and see if you can find something there.

Thanks,
-Nitin

-----Original Message-----
From: Lu Heng [mailto:h.lu@anytimechinese.com] 
Sent: Tuesday, June 12, 2012 9:19 AM
To: cloudstack-dev@incubator.apache.org
Cc: Nitin Mehta
Subject: Re: Secondary storage is not working

Hi

some more information:

Server IP:1.1.1.1(replaced with example ip, but the path is the same) path:/data

preparation of the system template:
/usr/lib64/cloud/agent/scripts/storage/secondary/cloud-install-sys-tmplt
-m /data -u http://download.cloud.com/templates/acton/acton-systemvm-02062012.vhd.bz2
-h xenserver -F
--2012-06-11 23:44:07--
http://download.cloud.com/templates/acton/acton-systemvm-02062012.vhd.bz2
Resolving download.cloud.com... 207.171.185.201 Connecting to download.cloud.com|207.171.185.201|:80...
connected.
HTTP request sent, awaiting response... 200 OK
Length: 140616708 (134M) [binary/octet-stream] Saving to: `/usr/lib64/cloud/agent/scripts/storage/secondary/8ab03e88-d05e-4a86-bb00-cca4ad60f4f6.vhd'

100%[==================================================================================================================================>]
140,616,708 42.4M/s   in 4.7s

2012-06-11 23:44:12 (28.3 MB/s) -
`/usr/lib64/cloud/agent/scripts/storage/secondary/8ab03e88-d05e-4a86-bb00-cca4ad60f4f6.vhd'
saved [140616708/140616708]

Uncompressing to
/usr/lib64/cloud/agent/scripts/storage/secondary/8ab03e88-d05e-4a86-bb00-cca4ad60f4f6.vhd.tmp
(type bz2)...could take a long time
Moving to /data/template/tmpl/1/1///8ab03e88-d05e-4a86-bb00-cca4ad60f4f6.vhd...could
take a while
Successfully installed system VM template  to /data/template/tmpl/1/1/

/etc/exports:
/data *(rw,async,no_root_squash)

Please let me know if you need more information.
On Tue, Jun 12, 2012 at 5:30 AM, Lu Heng <h.lu@anytimechinese.com> wrote:
> Hi Nitin:
>
> Thanks for replying.
>
> See my reply.
>
> On Tue, Jun 12, 2012 at 5:09 AM, Nitin Mehta <Nitin.Mehta@citrix.com> wrote:
>>
>> Lu,
>>
>> Can you paste the snippet of logs where you see the error? Can you please elaborate
on what you mean by secondary storage setup is not working.
>> In my knowledge, MS doesn't validate the secondary storage path and does very basic
tests while adding it. Typically I have seen the following issues users commit while adding
secondary storage.
>> Please check if your issue falls under one of them.
>>
>> 1.      Users skip the preparation of the storage (e.g. not seeding 
>> the System VM to the NFS export or seeding the wrong version for the 
>> hypervisor)
>
> /usr/lib64/cloud/agent/scripts/storage/secondary/cloud-install-sys-tmp
> lt -m /mnt/secondary -u 
> http://download.cloud.com/templates/acton/acton-systemvm-
> 02062012.vhd.bz2 -h xenserver -F
> is proformed in the management server, in which
> /data/template/tmpl/1/1 was created, and a vhd file together with a 
> template.properties was under that folder.
> three things I saw:
> 1. under template section of the cloudstack, I saw SystemVM Template 
> (XenServer)   usdatacenter1   XenServer, and if I open it, I saw 
> "download complete"
> However, seems it have nothing to do with the real storage, as if I 
> delete the secondary storage, it is still there.
> 2. in the installation guide it says it tooks up to 30 mins to 
> download that template, however, I saw "successful installation" after 
> about 30 seconds.
> 3. seems cloud stack does not check the secondary storage, i tried to 
> add random IP address with random path, it still shows "enabled".
>
>>
>> 2.      NFS v4 is used which causes errors during Secondary Storage 
>> preparation (Solution: mount the storage and force NFS v3 before 
>> preparing the Storage: mount -v -t nfs -o vers=3   
>> servername:/nfs/share /mnt/secondary)
> output from the management server:
> Server rpc stats:
> calls      badcalls   badauth    badclnt    xdrcall
> 3803       0          0          0          0
>
> Server nfs v3:
> null         getattr      setattr      lookup       access       
> readlink
> 3232     85% 12        0% 0         0% 0         0% 5         0% 0
        
> 0% read         write        create       mkdir        symlink      
> mknod
> 545      14% 0         0% 0         0% 0         0% 0         0% 0
        
> 0% remove       rmdir        rename       link         readdir      
> readdirplus
> 0         0% 0         0% 0         0% 0         0% 0         0%
3         
> 0% fsstat       fsinfo       pathconf     commit
> 0         0% 4         0% 0         0% 0         0%
>
>> 3.      The /etc/export file on the NFS does not contain 'no_root_squash'
> It does.
>> 4.      The /etc/export file on the NFS blocks the host/Management 
>> Network CIDR
> the NFS is on the management server.
>> 5.      Users enter wrong NFS share path (no validation by 
>> CloudStack)
> it is correct as I have successfully mounted it from Host sever.
>>
>> Thanks,
>> -Nitin
>>
>> -----Original Message-----
>> From: Lu Heng [mailto:h.lu@anytimechinese.com]
>> Sent: Tuesday, June 12, 2012 7:59 AM
>> To: cloudstack-dev@incubator.apache.org
>> Subject: Secondary storage is not working
>>
>> Hi
>>
>>  I have secondary storage setup at management server's /data path, and while I add
it to the zone, it is not working(with information server:<management-server-IP> path:/data),
however,I can successfully mount secondary storage in the HV server, any one have idea what
is wrong?
>>
>>
>> --
>> --
>> Kind regards.
>> Lu
>>
>> This transmission is intended solely for the addressee(s) shown above.
>> It may contain information that is privileged, confidential or otherwise protected
from disclosure. Any review, dissemination or use of this transmission or its contents by
persons other than the intended addressee(s) is strictly prohibited. If you have received
this transmission in error, please notify this office immediately and e-mail the original
at the sender's address above by replying to this message and including the text of the transmission
received.
>
>
>
>
> --
> --
> Kind regards.
> Lu
>
> This transmission is intended solely for the addressee(s) shown above.
> It may contain information that is privileged, confidential or 
> otherwise protected from disclosure. Any review, dissemination or use 
> of this transmission or its contents by persons other than the 
> intended addressee(s) is strictly prohibited. If you have received 
> this transmission in error, please notify this office immediately and 
> e-mail the original at the sender's address above by replying to this 
> message and including the text of the transmission received.



--
--
Kind regards.
Lu

This transmission is intended solely for the addressee(s) shown above.
It may contain information that is privileged, confidential or otherwise protected from disclosure.
Any review, dissemination or use of this transmission or its contents by persons other than
the intended addressee(s) is strictly prohibited. If you have received this transmission in
error, please notify this office immediately and e-mail the original at the sender's address
above by replying to this message and including the text of the transmission received.

Mime
View raw message