incubator-cloudstack-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edison Su <Edison...@citrix.com>
Subject RE: Reinstalling Cloudstack 3.0.2 on CentOS 6.2
Date Fri, 15 Jun 2012 17:36:54 GMT


> -----Original Message-----
> From: Eric [mailto:epretorious@yahoo.com]
> Sent: Thursday, June 14, 2012 11:32 PM
> To: cloudstack-dev@incubator.apache.org
> Subject: Reinstalling Cloudstack 3.0.2 on CentOS 6.2
> 
> When reinstalling Cloudstack 3.0.2 on CentOS 6.2 I've noticed that the
> installation script (./install.sh) complains...
> 
> > 10 packages excluded due to repository priority protections
> 
> 
> > [eric@sn1 yum.repos.d]$ yum repolist all
> > ...
> > repo id                     repo
> name                                  status
> > base                        CentOS-6 -
> Base                            enabled:   6,294
> > c6-media                    CentOS-6 -
> Media                           disabled
> > centosplus                  CentOS-6 -
> Plus                            disabled
> > contrib                     CentOS-6 -
> Contrib                         disabled
> > debug                       CentOS-6 -
> Debuginfo                       disabled
> > extras                      CentOS-6 -
> Extras                          enabled:       6
> > rpmforge                    RHEL 6 - RPMforge.net -
> dag                enabled: 4,368+3
> > rpmforge-extras             RHEL 6 - RPMforge.net -
> extras             disabled
> > rpmforge-testing            RHEL 6 - RPMforge.net -
> testing            disabled
> > updates                     CentOS-6 -
> Updates                         enabled:   1,129
> 
> 
> What is this about? What packages were excluded? Are the excluded
> packages critical? Can the installation script enable the repositories
> that contain the excluded packages (so that I don't have to edit the
> repository files manually)?
> 

The cloudstack installation script only creates a new local repository which includes all
the cloudstack packages, then call "yum install cloud-agent" to install cloudstack related
software.
The warning "10 packages excluded due to repository priority protections" comes from the priority
setting in your repositories. Regarding to priority setting in Yum repo:
http://wiki.centos.org/PackageManagement/Yum/Priorities, I doesn't think it's a right way
to suppress/disable priority setting in your repositories in cloudstack installation script,
as the priority setting is a system wide configuration, cloudstack needs to respect it. 
It's better to manually change the priority setting based on your need: you can disable it,
enable it, change the priority level for certain repository etc.

> On the management agent:
> =======================================================================
> ===============
> > Running Transaction
> >   Installing : cloud-utils-3.0.2-
> 1.el6.x86_64                                     
1/9
> >   Installing : cloud-deps-3.0.2-
> 1.el6.x86_64                                      
2/9
> >   Installing : cloud-python-3.0.2-
> 1.el6.x86_64                                    
3/9
> >   Installing : cloud-core-3.0.2-
> 1.el6.x86_64                                      
4/9
> >   Installing : cloud-server-3.0.2-
> 1.el6.x86_64                                    
5/9
> >   Installing : cloud-setup-3.0.2-
> 1.el6.x86_64                                     
6/9
> >   Installing : cloud-agent-scripts-3.0.2-
> 1.el6.x86_64                              7/9
> >   Installing : cloud-client-3.0.2-
> 1.el6.x86_64                                    
8/9
> >   Installing : cloud-client-ui-3.0.2-
> 1.el6.x86_64                                  9/9
> >
> > Installed:
> >   cloud-client.x86_64 0:3.0.2-
> 1.el6
> >
> > Dependency Installed:
> >   cloud-agent-scripts.x86_64 0:3.0.2-1.el6     cloud-client-ui.x86_64
> 0:3.0.2-1.el6
> >   cloud-core.x86_64 0:3.0.2-1.el6              cloud-deps.x86_64
> 0:3.0.2-1.el6
> >   cloud-python.x86_64 0:3.0.2-1.el6            cloud-server.x86_64
> 0:3.0.2-1.el6
> >   cloud-setup.x86_64 0:3.0.2-1.el6             cloud-utils.x86_64
> 0:3.0.2-1.el6
> >
> > Complete!
> 
> On the agent:
> =======================================================================
> ===============
> > Running Transaction
> >   Installing : cloud-utils-3.0.2-
> 1.el6.x86_64                                     
1/8
> >   Installing : cloud-deps-3.0.2-
> 1.el6.x86_64                                      
2/8
> >   Installing : cloud-core-3.0.2-
> 1.el6.x86_64                                      
3/8
> >   Installing : cloud-agent-libs-3.0.2-
> 1.el6.x86_64                                 4/8
> >   Installing : cloud-daemonize-3.0.2-
> 1.el6.x86_64                                  5/8
> >   Installing : cloud-python-3.0.2-
> 1.el6.x86_64                                    
6/8
> >   Installing : cloud-agent-scripts-3.0.2-
> 1.el6.x86_64                              7/8
> >   Installing : cloud-agent-3.0.2-
> 1.el6.x86_64                                     
8/8
> >
> > Installed:
> >   cloud-agent.x86_64 0:3.0.2-
> 1.el6
> >
> > Dependency Installed:
> >   cloud-agent-libs.x86_64 0:3.0.2-1.el6    cloud-agent-scripts.x86_64
> 0:3.0.2-1.el6
> >   cloud-core.x86_64 0:3.0.2-1.el6          cloud-daemonize.x86_64
> 0:3.0.2-1.el6
> >   cloud-deps.x86_64 0:3.0.2-1.el6          cloud-python.x86_64
> 0:3.0.2-1.el6
> >   cloud-utils.x86_64 0:3.0.2-1.el6
> >
> > Complete!
> > Loaded plugins: fastestmirror, priorities
> > Loading mirror speeds from cached hostfile
> >  * base: centos.mirrors.hoobly.com
> >  * extras: centos.mirror.facebook.net
> >  * rpmforge: mirror.hmc.edu
> >  * updates: mirrors.usc.edu
> > 10 packages excluded due to repository priority protections
> 
> TIA,
> Eric Pretorious
> Truckee, CA

Mime
View raw message