incubator-clerezza-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anuj Kumar <anujs...@gmail.com>
Subject Re: Build failure due to stack overflow
Date Thu, 12 May 2011 18:27:06 GMT
Thanks for the response Reto.
Yes, I did it earlier but it didn't work. How much should I set it to?

Thanks,
Anuj

On Thu, May 12, 2011 at 11:50 PM, Reto Bachmann-Gmuer <
reto.bachmann@trialox.org> wrote:

> On Thu, May 12, 2011 at 8:08 PM, Anuj Kumar <anujsays@gmail.com> wrote:
> > Hi Hasan,
> >
> > It's Apache Maven 2.2.1 (r801777; 2009-08-07 00:46:01+0530).
> > Ok, I can try to update that and see if it helps.
> I'm using 2.2.1 too. so that can't be the problem. I'd recommend
> increasing the satck size with MAVEN_OPTS environment variable.
>
> Cheers,
> Reto
>
> >
> > Thanks,
> > Anuj
> >
> > On Thu, May 12, 2011 at 10:45 PM, Hasan Hasan <hasan@trialox.org> wrote:
> >
> >> which maven version are you using?
> >> I use 3.0
> >>
> >> hasan
> >>
> >> On Thu, May 12, 2011 at 3:31 PM, Anuj Kumar <anujsays@gmail.com> wrote:
> >>
> >> > Hello Everyone,
> >> >
> >> > I tried to play around with various JVM options as well but it isn't
> >> > working.
> >> > Has anyone else faced similar issue before?
> >> >
> >> > Thanks,
> >> > Anuj
> >> >
> >> > On Thu, May 12, 2011 at 2:05 PM, Anuj Kumar <anujsays@gmail.com>
> wrote:
> >> >
> >> > > Hi,
> >> > >
> >> > > On Thu, May 12, 2011 at 12:25 PM, Henry Story <
> henry.story@bblfish.net
> >> > >wrote:
> >> > >
> >> > >>
> >> > >> On 12 May 2011, at 04:25, Anuj Kumar wrote:
> >> > >>
> >> > >> > Hello Everyone,
> >> > >> >
> >> > >> > I have just started with Clerezza project and was trying
to build
> >> the
> >> > >> code
> >> > >> > base by following this wiki page-
> >> > >> >
> >> >
> http://incubator.apache.org/clerezza/getting-started/building-clerezza/
> >> > >> >
> >> > >> > First observation is that there is no scala-scripting directory.
> >> > >>
> >> > >> Reto just moved that scripting directory yesterday to the parent
I
> >> > think,
> >> > >> so that the whole thing could be built in one go. I think it is
> >> > >> in platform.scripting now
> >> > >>
> >> > >> > So, I
> >> > >> > skipped that point and proceeded to the fourth step. When
I run
> the
> >> > >> build
> >> > >> > for parent directory, it fails with the StackOverflow error.
I am
> >> > using
> >> > >> > Windows Vista and the memory allocated to maven is 512m.
> >> > >> >
> >> > >> > What might be the problem?
> >> > >>
> >> > >> I tried that on OSX a don't get the problem.
> >> > >>
> >> > >
> >> > > I think I need to increase the stack size. I will try that as soon
> as I
> >> > get
> >> > > access to my laptop and let you know. If it works on OSX then it
> might
> >> be
> >> > a
> >> > > configuration issue with my JVM. Here are the posts that talk about
> >> > similar
> >> > > issues-
> >> > >
> >> > > http://www.assembla.com/spaces/scala-ide/tickets/1000143
> >> > >
> >>
> http://groups.google.com/group/scala-ide-user/msg/1f679ad0a6b8b9e6?pli=1
> >> > >
> >> > > Regards,
> >> > > Anuj
> >> > >
> >> >
> >>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message